aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-08-08 17:53:35 +0800
committerclement <clement@FreeBSD.org>2004-08-08 17:53:35 +0800
commit22447ab65ceeb62d2aa5b3f4e5a807183277bbce (patch)
tree2272e6a7345aeb3d2b456ae3de2a58d2bb965cda
parenta614ad1ea9b9175f65c20783086aa6d7cbca9c98 (diff)
downloadfreebsd-ports-gnome-22447ab65ceeb62d2aa5b3f4e5a807183277bbce.tar.gz
freebsd-ports-gnome-22447ab65ceeb62d2aa5b3f4e5a807183277bbce.tar.zst
freebsd-ports-gnome-22447ab65ceeb62d2aa5b3f4e5a807183277bbce.zip
Add mod_auth_cookie_mysql2 0.3
This modules (for apache2) allows you to auth your users with cookies stored in a MySQL database.
-rw-r--r--CVSROOT/modules1
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_cookie_mysql2/Makefile36
-rw-r--r--www/mod_auth_cookie_mysql2/distinfo2
-rw-r--r--www/mod_auth_cookie_mysql2/pkg-descr4
5 files changed, 44 insertions, 0 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index c97b0cca6aa5..66a8b90d8a53 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -5351,6 +5351,7 @@ mod_accesscookie ports/www/mod_accesscookie
mod_accounting ports/www/mod_accounting
mod_auth_any ports/www/mod_auth_any
mod_auth_cookie_mysql ports/www/mod_auth_cookie_mysql
+mod_auth_cookie_mysql2 ports/www/mod_auth_cookie_mysql2
mod_auth_external ports/www/mod_auth_external
mod_auth_external2 ports/www/mod_auth_external2
mod_auth_imap ports/www/mod_auth_imap
diff --git a/www/Makefile b/www/Makefile
index 64f33e0c403d..c36bc58bb395 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -222,6 +222,7 @@
SUBDIR += mod_accounting
SUBDIR += mod_auth_any
SUBDIR += mod_auth_cookie_mysql
+ SUBDIR += mod_auth_cookie_mysql2
SUBDIR += mod_auth_external
SUBDIR += mod_auth_external2
SUBDIR += mod_auth_imap
diff --git a/www/mod_auth_cookie_mysql2/Makefile b/www/mod_auth_cookie_mysql2/Makefile
new file mode 100644
index 000000000000..d6e794bc6cd1
--- /dev/null
+++ b/www/mod_auth_cookie_mysql2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_auth_cookie_mysql2
+# Date created: Sun Aug 8 2004
+# Whom: clement
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_cookie_mysql2
+PORTVERSION= 0.3
+CATEGORIES= www
+MASTER_SITES= http://home.digithi.de/digithi/dev/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+DIST_SUBDIR= apache2
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= Allows authentication against a MySQL database via a secure cookie
+
+USE_MYSQL= YES
+# If someone can test it with MySQL 4.1 ;-)
+BROKEN_WITH_MYSQL= 41
+
+WANT_APACHE= 2
+
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+AP_INC?= ${LOCALBASE}/include/mysql
+AP_LIB?= ${LOCALBASE}/lib/mysql -lmysqlclient -lz
+PORTDOCS= mod_auth_cookie_mysql2.html
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_cookie_mysql2/distinfo b/www/mod_auth_cookie_mysql2/distinfo
new file mode 100644
index 000000000000..13b3e7b90488
--- /dev/null
+++ b/www/mod_auth_cookie_mysql2/distinfo
@@ -0,0 +1,2 @@
+MD5 (apache2/mod_auth_cookie_mysql2_0.3.tar.gz) = e8c4dd0b14d31167710a2505a2cef2dc
+SIZE (apache2/mod_auth_cookie_mysql2_0.3.tar.gz) = 6741
diff --git a/www/mod_auth_cookie_mysql2/pkg-descr b/www/mod_auth_cookie_mysql2/pkg-descr
new file mode 100644
index 000000000000..afb833e1e825
--- /dev/null
+++ b/www/mod_auth_cookie_mysql2/pkg-descr
@@ -0,0 +1,4 @@
+This Apache module allows authentication against a MySQL database via a
+cryptographically secure cookie.
+
+WWW: http://home.digithi.de/digithi/dev/mod_auth_cookie_mysql2.html