aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-10-14 05:23:35 +0800
committergerald <gerald@FreeBSD.org>2013-10-14 05:23:35 +0800
commit2378c1edb96057140f174b09337b45aef8e4731b (patch)
tree548774f41a2ce2dc3e9eb1bbcab17321a91b007d
parent52450e34b660afb9cebb40e3afbaf351cbbef247 (diff)
downloadfreebsd-ports-gnome-2378c1edb96057140f174b09337b45aef8e4731b.tar.gz
freebsd-ports-gnome-2378c1edb96057140f174b09337b45aef8e4731b.tar.zst
freebsd-ports-gnome-2378c1edb96057140f174b09337b45aef8e4731b.zip
Add support for USE_GCC=4.9 and USE_GCC=4.9+.
Beware, this version of GCC is _not_ anywhere near ready for production use. Use at your own risk, and rather don't use it for regular ports. Submitted by: devzone.my@gmail.com
-rw-r--r--Mk/bsd.gcc.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 5ef0197089a4..c40ec93e953d 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -42,7 +42,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
-GCCVERSIONS= 030402 040200 040400 040600 040700 040800
+GCCVERSIONS= 030402 040200 040400 040600 040700 040800 040900
# The first field if the OSVERSION in which it appeared in the base.
# The second field is the OSVERSION in which it disappeared from the base.
@@ -53,6 +53,7 @@ GCCVERSION_040400= 0 0 4.4
GCCVERSION_040600= 0 0 4.6
GCCVERSION_040700= 0 0 4.7
GCCVERSION_040800= 0 0 4.8
+GCCVERSION_040900= 0 0 4.9
GCC_DEFAULT_VERSION= 4.6
GCC_DEFAULT_V= ${GCC_DEFAULT_VERSION:S/.//}