aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-05-30 19:06:05 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-05-30 19:06:05 +0800
commit248c49d71fda1f34891d41b2b29c2837ffd35cce (patch)
tree66523f5a5d7f1cc0f83737815f16b584fa93dd08
parent628b326b5f1e32f18e5a62f1e56d57f17ac68888 (diff)
downloadfreebsd-ports-gnome-248c49d71fda1f34891d41b2b29c2837ffd35cce.tar.gz
freebsd-ports-gnome-248c49d71fda1f34891d41b2b29c2837ffd35cce.tar.zst
freebsd-ports-gnome-248c49d71fda1f34891d41b2b29c2837ffd35cce.zip
- Upgrade to 1.4.45.
- Remove off64 option. This is no effect on FreeBSD. - Remove ZLIB and BZIP2 options. I cannot image who want to disabe them. - Add LZMA and LZO options (use lzmalib from ports even if on recent 9-current because of missing header). - Add missing SHARED option and sort options [1]. - Clean up usage of WITH_ and WITHOUT_ [1]. PR: ports/146164 [1] Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> [1]
-rw-r--r--databases/tokyocabinet/Makefile51
-rw-r--r--databases/tokyocabinet/distinfo6
2 files changed, 28 insertions, 29 deletions
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index 01dd68bdf3f1..52bf75770a9f 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tokyocabinet
-PORTVERSION= 1.4.44
+PORTVERSION= 1.4.45
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://1978th.net/tokyocabinet/
@@ -17,7 +17,6 @@ COMMENT= A modern implementation of DBM
MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS= --enable-off64
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
@@ -36,14 +35,14 @@ MAN3= tcadb.3 tcbdb.3 tcfdb.3 tchdb.3 tclist.3 tcmap.3 \
OPTIONS= DEBUG "Debugging support" off \
DEVEL "Development build" off \
- PROFILE "Profiling build" off \
- OFF64 "Use to compile on 64-bit system" off \
FASTEST "Fastest run" off \
+ LZMA "Enable LZMA codec" off \
+ LZO "Enable LZO codec" off \
+ PTHREAD "Disable POSIX thread support" on \
+ PROFILE "Profiling build" off \
+ SHARED "Shared build" on \
SWAB "Swapping byte-orders build" off \
- UYIELD "Detecting race conditions" off \
- ZLIB "Disable ZLIB compression" off \
- BZIP2 "BZIP2 compression" on \
- PTHREAD "Disable POSIX thread support" off
+ UYIELD "Detecting race conditions" off
.include <bsd.port.pre.mk>
@@ -57,14 +56,26 @@ CONFIGURE_ARGS+= --enable-debug
.if defined(WITH_DEVEL)
CONFIGURE_ARGS+= --enable-devel
.endif
+.if defined(WITH_FASTEST)
+CONFIGURE_ARGS+= --enable-fastest
+.endif
+# liblzma on 9-current does not have liblzma.h file.
+.if defined(WITH_LZMA) || exists(${LOCALBASE}/include/liblzma.h)
+CONFIGURE_ARGS+= --enable-exlzma
+LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/lzmalib
+.endif
+.if defined(WITH_LZO) || exists(${LOCALBASE}/lib/liblzo2.so)
+CONFIGURE_ARGS+= --enable-exlzo
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+.endif
+.if defined(WITHOUT_PTHREAD)
+CONFIGURE_ARGS+= --disable-pthread
+.endif
.if defined(WITH_PROFILE)
CONFIGURE_ARGS+= --enable-profile
.endif
-.if defined(WITH_OFF64)
-CONFIGURE_ARGS+= --enable-off64
-.endif
-.if defined(WITH_FASTEST)
-CONFIGURE_ARGS+= --enable-fastest
+.if defined(WITHOUT_SHARED)
+CONFIGURE_ARGS+= --disable-shared
.endif
.if defined(WITH_SWAB)
CONFIGURE_ARGS+= --enable-swab
@@ -72,20 +83,8 @@ CONFIGURE_ARGS+= --enable-swab
.if defined(WITH_UYIELD)
CONFIGURE_ARGS+= --enable-uyield
.endif
-.if defined(WITH_ZLIB)
-CONFIGURE_ARGS+= --disable-zlib
-.endif
-.if defined(WITHOUT_BZIP2)
-CONFIGURE_ARGS+= --disable-bzip
-.endif
-.if defined(WITH_PTHREAD)
-CONFIGURE_ARGS+= --disable-pthread
-.endif
-.if defined(WITH_SHARED)
-CONFIGURE_ARGS+= --disable-shared
-.endif
-SHLIB_VER= 9.7.0
+SHLIB_VER= 9.8.0
SHLIB_VER_MAJ= 9
PLIST_SUB+= SHLIB_VER=${SHLIB_VER} SHLIB_VER_MAJ=${SHLIB_VER_MAJ}
diff --git a/databases/tokyocabinet/distinfo b/databases/tokyocabinet/distinfo
index 9f968098ca4a..8c9eb70938fb 100644
--- a/databases/tokyocabinet/distinfo
+++ b/databases/tokyocabinet/distinfo
@@ -1,3 +1,3 @@
-MD5 (tokyocabinet-1.4.44.tar.gz) = 1f80c11abf10d816a0a42c1d74fd0391
-SHA256 (tokyocabinet-1.4.44.tar.gz) = eb5244d31d07e614a8be93c324478a7d410fb7bebf7e06eccfd183dfdbbd27ac
-SIZE (tokyocabinet-1.4.44.tar.gz) = 988966
+MD5 (tokyocabinet-1.4.45.tar.gz) = 4e891fef32663c707ae0156b47c7ee1f
+SHA256 (tokyocabinet-1.4.45.tar.gz) = ef6a5d44bb876db9eb5f65128d995f6227d05dfd1166e0e32cb59d77c605b15d
+SIZE (tokyocabinet-1.4.45.tar.gz) = 995916