aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2014-01-28 22:43:06 +0800
committerskreuzer <skreuzer@FreeBSD.org>2014-01-28 22:43:06 +0800
commit25b06a33f0586ebb2d6471accf0c0db9ba076817 (patch)
tree3ca89a38df7f5b73d1077319aa2c25fb303a59c5
parent7a791b40f52c3947d3f88bab60df09200e892c01 (diff)
downloadfreebsd-ports-gnome-25b06a33f0586ebb2d6471accf0c0db9ba076817.tar.gz
freebsd-ports-gnome-25b06a33f0586ebb2d6471accf0c0db9ba076817.tar.zst
freebsd-ports-gnome-25b06a33f0586ebb2d6471accf0c0db9ba076817.zip
Blessings lifts several of curses' limiting assumptions, and it makes
your code pretty Use styles, color, and maybe a little positioning without necessarily clearing the whole screen first. Leave more than one screenful of scrollback in the buffer after your program exits, like a well-behaved command-line app should. Get rid of all those noisy, C-like calls to tigetstr and tparm, so your code doesn't get crowded out by terminal bookkeeping. Act intelligently when somebody redirects your output to a file, omitting the terminal control codes the user doesn't want to see. WWW: https://github.com/erikrose/blessings
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-blessings/Makefile18
-rw-r--r--devel/py-blessings/distinfo2
-rw-r--r--devel/py-blessings/pkg-descr12
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 972ea2671aff..c6c4c033d03c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3519,6 +3519,7 @@
SUBDIR += py-bison
SUBDIR += py-bitarray
SUBDIR += py-bitstring
+ SUBDIR += py-blessings
SUBDIR += py-blinker
SUBDIR += py-bluelet
SUBDIR += py-boto
diff --git a/devel/py-blessings/Makefile b/devel/py-blessings/Makefile
new file mode 100644
index 000000000000..c567a671edc1
--- /dev/null
+++ b/devel/py-blessings/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= blessings
+PORTVERSION= 1.5.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Thin wrapper around terminal coloring, styling, and positioning
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-blessings/distinfo b/devel/py-blessings/distinfo
new file mode 100644
index 000000000000..6139532ee358
--- /dev/null
+++ b/devel/py-blessings/distinfo
@@ -0,0 +1,2 @@
+SHA256 (blessings-1.5.1.tar.gz) = 2f6f5509fe180ae3092fdc559585a83a3cfce30afba9de25ccefc5ecfbfedbfc
+SIZE (blessings-1.5.1.tar.gz) = 19239
diff --git a/devel/py-blessings/pkg-descr b/devel/py-blessings/pkg-descr
new file mode 100644
index 000000000000..ddef70ea54c9
--- /dev/null
+++ b/devel/py-blessings/pkg-descr
@@ -0,0 +1,12 @@
+Blessings lifts several of curses' limiting assumptions, and it makes
+your code pretty
+
+Use styles, color, and maybe a little positioning without necessarily
+clearing the whole screen first. Leave more than one screenful of
+scrollback in the buffer after your program exits, like a well-behaved
+command-line app should. Get rid of all those noisy, C-like calls to
+tigetstr and tparm, so your code doesn't get crowded out by terminal
+bookkeeping. Act intelligently when somebody redirects your output to a
+file, omitting the terminal control codes the user doesn't want to see.
+
+WWW: https://github.com/erikrose/blessings