aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-27 02:57:13 +0800
committerrm <rm@FreeBSD.org>2012-10-27 02:57:13 +0800
commit276f3ce1d61544d11faebc6a344c49619dc23a47 (patch)
treea6e686db1315b44ab57a9efcf71e3843b0527ae7
parentf656e9f0ff410d058c8bf2e45ec69e58a4b0582a (diff)
downloadfreebsd-ports-gnome-276f3ce1d61544d11faebc6a344c49619dc23a47.tar.gz
freebsd-ports-gnome-276f3ce1d61544d11faebc6a344c49619dc23a47.tar.zst
freebsd-ports-gnome-276f3ce1d61544d11faebc6a344c49619dc23a47.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES PR: 173107 Submitted by: rm (myself) Approved by: glarkin (maintainer, by mail) Feature safe: yes
-rw-r--r--www/trac-pagelist/Makefile18
-rw-r--r--www/trac-pagelist/pkg-plist1
2 files changed, 6 insertions, 13 deletions
diff --git a/www/trac-pagelist/Makefile b/www/trac-pagelist/Makefile
index e922b851d00b..f9a4784dc886 100644
--- a/www/trac-pagelist/Makefile
+++ b/www/trac-pagelist/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-pagelist
-# Date created: May 18 2007
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= pagelist
PORTVERSION= 0.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www devel python
MASTER_SITES= http://www.gerritbeine.de/download/trac/
PKGNAMEPREFIX= trac-
@@ -16,14 +12,12 @@ DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= TracPageList
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
WRKSRC= ${WRKDIR}/${PORTNAME}plugin
-NO_BUILD= yes
-USE_PYTHON= 2.5+
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracPageList
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>
diff --git a/www/trac-pagelist/pkg-plist b/www/trac-pagelist/pkg-plist
deleted file mode 100644
index 5c3460a8282c..000000000000
--- a/www/trac-pagelist/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/TracPageList-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg