aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-09-01 06:01:26 +0800
committerdhn <dhn@FreeBSD.org>2011-09-01 06:01:26 +0800
commit28a56fbecb7125d3ecfc4f2dc7487017c3b05ad3 (patch)
tree69d9b1e8343dfdc7cd780f9bbe441bf7ff72373f
parenteda0f0ad9192704e467a3f1e0f0e7e44bf1995b0 (diff)
downloadfreebsd-ports-gnome-28a56fbecb7125d3ecfc4f2dc7487017c3b05ad3.tar.gz
freebsd-ports-gnome-28a56fbecb7125d3ecfc4f2dc7487017c3b05ad3.tar.zst
freebsd-ports-gnome-28a56fbecb7125d3ecfc4f2dc7487017c3b05ad3.zip
- Update to 3.0.2
PR: ports/160120 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
-rw-r--r--graphics/raster3d/Makefile40
-rw-r--r--graphics/raster3d/distinfo4
-rw-r--r--graphics/raster3d/files/extrapatch-avs2ps.c11
-rw-r--r--graphics/raster3d/files/extrapatch-in.h521
-rw-r--r--graphics/raster3d/files/patch-Makefile19
-rw-r--r--graphics/raster3d/pkg-plist10
6 files changed, 30 insertions, 575 deletions
diff --git a/graphics/raster3d/Makefile b/graphics/raster3d/Makefile
index 6b764a9b345d..038f5f4fa0ed 100644
--- a/graphics/raster3d/Makefile
+++ b/graphics/raster3d/Makefile
@@ -6,30 +6,33 @@
#
PORTNAME= raster3d
-PORTVERSION= 2.7s
-PORTREVISION= 2
+PORTVERSION= 3.0.2
CATEGORIES= graphics biology
MASTER_SITES= http://skuld.bmsc.washington.edu/${PORTNAME}/
-DISTNAME= Raster3D_${PORTVERSION}
+DISTNAME= Raster3D_${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of tools for generating raster images of proteins and molecules
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LICENSE= ART20
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
tiff.4:${PORTSDIR}/graphics/tiff
OPTIONS= IMAGEMAGICK "ImageMagick graphics support" on
USE_FORTRAN= yes
-MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" FC="${FC}" FFLAGS="${FFLAGS}" \
+MAKE_ARGS= INCDIRS="-I${LOCALBASE}/include" LIBDIRS="-L${LOCALBASE}/lib" \
+ CC="${CC}" CFLAGS="${CFLAGS}" FC="${FC}" FFLAGS="${FFLAGS}" \
RM="${RM}" OS="${OPSYS}"
-ALL_TARGET= strip-for-g77 all
+ALL_TARGET= linux all
+MAKE_JOBS_SAFE= yes
MANL= avs2ps.l balls.l label3d.l r3d_objects.l r3dtops.l rastep.l \
raster3d.l render.l ribbon.l rods.l normal3d.l stereo3d.l
-CFLAGS+= -DLINUX -DNETWORKBYTEORDER
-FFLAGS+= -fno-range-check
+CFLAGS+= -DLINUX -DNETWORKBYTEORDER -Dgfortran
+FFLAGS+= -fno-range-check -ffixed-line-length-132
.include <bsd.port.pre.mk>
@@ -47,16 +50,13 @@ CFLAGS+= -DIMAGEPIPE
PLIST_SUB+= IMAGEMAGICK=""
.endif
-do-configure:
- @cd ${WRKSRC}; ${SED} 's:^prefix.*$$:prefix = ${PREFIX}:g ; \
- s:^INCDIRS.*$$:INCDIRS = -I${LOCALBASE}/include:g ; \
- s:^LIBDIRS.*$$:LIBDIRS = -L${LOCALBASE}/lib:g ; \
- s:IDEFS:#IDEFS:g' Makefile.template > Makefile.incl
-
do-install:
.for file in avs2ps balls normal3d rastep render ribbon rings3d rods
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${file} ${PREFIX}/bin
.endfor
+.for file in worms
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${file} ${PREFIX}/bin
+.endfor
.if !defined(WITHOUT_IMAGEMAGICK)
.for file in label3d stereo3d
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${file} ${PREFIX}/bin
@@ -66,14 +66,18 @@ do-install:
@${MKDIR} ${DATADIR}/materials
cd ${WRKSRC}/materials && ${INSTALL_DATA} * ${DATADIR}/materials
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/html
+ @${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} R3D_manual.pdf ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/html
cd ${WRKSRC}/html && ${INSTALL_DATA} * ${DOCSDIR}/html
.endif
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}/msms
- cd ${WRKSRC}/examples && ${INSTALL_DATA} *.* ${EXAMPLESDIR}
- cd ${WRKSRC}/examples/msms && ${INSTALL_DATA} * ${EXAMPLESDIR}/msms
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${TAR} --exclude "CVS" -cf - . | \
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -)
+ @${FIND} ${EXAMPLESDIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ @${FIND} ${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
+ @${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/raster3d/distinfo b/graphics/raster3d/distinfo
index ff2e11b5148a..11c384ac934c 100644
--- a/graphics/raster3d/distinfo
+++ b/graphics/raster3d/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Raster3D_2.7s.tar.gz) = a5952a26ece4af67ac0b4331601e639055cdafb5622aa778779cd15feb071a1a
-SIZE (Raster3D_2.7s.tar.gz) = 1724766
+SHA256 (Raster3D_3.0-2.tar.gz) = a89bdfda61fae8d189820941f1b5685b40743b817128f57bc1225f983a47d984
+SIZE (Raster3D_3.0-2.tar.gz) = 1743034
diff --git a/graphics/raster3d/files/extrapatch-avs2ps.c b/graphics/raster3d/files/extrapatch-avs2ps.c
deleted file mode 100644
index d610a5d85d41..000000000000
--- a/graphics/raster3d/files/extrapatch-avs2ps.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- avs2ps.c.orig Fri Apr 28 15:34:10 2006
-+++ avs2ps.c Fri Apr 28 15:35:09 2006
-@@ -10,7 +10,7 @@
- #include <math.h>
- #include <string.h>
- #include <stdlib.h>
--#include <netinet/in.h>
-+#include "in.h"
-
- #ifdef WIN32
- #define random rand
diff --git a/graphics/raster3d/files/extrapatch-in.h b/graphics/raster3d/files/extrapatch-in.h
deleted file mode 100644
index e97a127f34c7..000000000000
--- a/graphics/raster3d/files/extrapatch-in.h
+++ /dev/null
@@ -1,521 +0,0 @@
---- in.h.orig Fri Apr 28 15:38:06 2006
-+++ in.h Fri Apr 28 15:38:06 2006
-@@ -0,0 +1,518 @@
-+/*
-+ * Copyright (c) 1982, 1986, 1990, 1993
-+ * The Regents of the University of California. All rights reserved.
-+ *
-+ * Redistribution and use in source and binary forms, with or without
-+ * modification, are permitted provided that the following conditions
-+ * are met:
-+ * 1. Redistributions of source code must retain the above copyright
-+ * notice, this list of conditions and the following disclaimer.
-+ * 2. Redistributions in binary form must reproduce the above copyright
-+ * notice, this list of conditions and the following disclaimer in the
-+ * documentation and/or other materials provided with the distribution.
-+ * 3. All advertising materials mentioning features or use of this software
-+ * must display the following acknowledgement:
-+ * This product includes software developed by the University of
-+ * California, Berkeley and its contributors.
-+ * 4. Neither the name of the University nor the names of its contributors
-+ * may be used to endorse or promote products derived from this software
-+ * without specific prior written permission.
-+ *
-+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
-+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
-+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-+ * SUCH DAMAGE.
-+ *
-+ * @(#)in.h 8.3 (Berkeley) 1/3/94
-+ * $FreeBSD: /tmp/pcvs/ports/graphics/raster3d/files/Attic/extrapatch-in.h,v 1.1 2006-04-28 14:20:45 ehaupt Exp $
-+ */
-+
-+#ifndef _NETINET_IN_H_
-+#define _NETINET_IN_H_
-+
-+#include <sys/types.h>
-+
-+/*
-+ * Constants and structures defined by the internet system,
-+ * Per RFC 790, September 1981, and numerous additions.
-+ */
-+
-+/*
-+ * Protocols (RFC 1700)
-+ */
-+#define IPPROTO_IP 0 /* dummy for IP */
-+#define IPPROTO_HOPOPTS 0 /* IP6 hop-by-hop options */
-+#define IPPROTO_ICMP 1 /* control message protocol */
-+#define IPPROTO_IGMP 2 /* group mgmt protocol */
-+#define IPPROTO_GGP 3 /* gateway^2 (deprecated) */
-+#define IPPROTO_IPV4 4 /* IPv4 encapsulation */
-+#define IPPROTO_IPIP IPPROTO_IPV4 /* for compatibility */
-+#define IPPROTO_TCP 6 /* tcp */
-+#define IPPROTO_ST 7 /* Stream protocol II */
-+#define IPPROTO_EGP 8 /* exterior gateway protocol */
-+#define IPPROTO_PIGP 9 /* private interior gateway */
-+#define IPPROTO_RCCMON 10 /* BBN RCC Monitoring */
-+#define IPPROTO_NVPII 11 /* network voice protocol*/
-+#define IPPROTO_PUP 12 /* pup */
-+#define IPPROTO_ARGUS 13 /* Argus */
-+#define IPPROTO_EMCON 14 /* EMCON */
-+#define IPPROTO_XNET 15 /* Cross Net Debugger */
-+#define IPPROTO_CHAOS 16 /* Chaos*/
-+#define IPPROTO_UDP 17 /* user datagram protocol */
-+#define IPPROTO_MUX 18 /* Multiplexing */
-+#define IPPROTO_MEAS 19 /* DCN Measurement Subsystems */
-+#define IPPROTO_HMP 20 /* Host Monitoring */
-+#define IPPROTO_PRM 21 /* Packet Radio Measurement */
-+#define IPPROTO_IDP 22 /* xns idp */
-+#define IPPROTO_TRUNK1 23 /* Trunk-1 */
-+#define IPPROTO_TRUNK2 24 /* Trunk-2 */
-+#define IPPROTO_LEAF1 25 /* Leaf-1 */
-+#define IPPROTO_LEAF2 26 /* Leaf-2 */
-+#define IPPROTO_RDP 27 /* Reliable Data */
-+#define IPPROTO_IRTP 28 /* Reliable Transaction */
-+#define IPPROTO_TP 29 /* tp-4 w/ class negotiation */
-+#define IPPROTO_BLT 30 /* Bulk Data Transfer */
-+#define IPPROTO_NSP 31 /* Network Services */
-+#define IPPROTO_INP 32 /* Merit Internodal */
-+#define IPPROTO_SEP 33 /* Sequential Exchange */
-+#define IPPROTO_3PC 34 /* Third Party Connect */
-+#define IPPROTO_IDPR 35 /* InterDomain Policy Routing */
-+#define IPPROTO_XTP 36 /* XTP */
-+#define IPPROTO_DDP 37 /* Datagram Delivery */
-+#define IPPROTO_CMTP 38 /* Control Message Transport */
-+#define IPPROTO_TPXX 39 /* TP++ Transport */
-+#define IPPROTO_IL 40 /* IL transport protocol */
-+#define IPPROTO_IPV6 41 /* IP6 header */
-+#define IPPROTO_SDRP 42 /* Source Demand Routing */
-+#define IPPROTO_ROUTING 43 /* IP6 routing header */
-+#define IPPROTO_FRAGMENT 44 /* IP6 fragmentation header */
-+#define IPPROTO_IDRP 45 /* InterDomain Routing*/
-+#define IPPROTO_RSVP 46 /* resource reservation */
-+#define IPPROTO_GRE 47 /* General Routing Encap. */
-+#define IPPROTO_MHRP 48 /* Mobile Host Routing */
-+#define IPPROTO_BHA 49 /* BHA */
-+#define IPPROTO_ESP 50 /* IP6 Encap Sec. Payload */
-+#define IPPROTO_AH 51 /* IP6 Auth Header */
-+#define IPPROTO_INLSP 52 /* Integ. Net Layer Security */
-+#define IPPROTO_SWIPE 53 /* IP with encryption */
-+#define IPPROTO_NHRP 54 /* Next Hop Resolution */
-+#define IPPROTO_MOBILE 55 /* IP Mobility */
-+#define IPPROTO_TLSP 56 /* Transport Layer Security */
-+#define IPPROTO_SKIP 57 /* SKIP */
-+#define IPPROTO_ICMPV6 58 /* ICMP6 */
-+#define IPPROTO_NONE 59 /* IP6 no next header */
-+#define IPPROTO_DSTOPTS 60 /* IP6 destination option */
-+#define IPPROTO_AHIP 61 /* any host internal protocol */
-+#define IPPROTO_CFTP 62 /* CFTP */
-+#define IPPROTO_HELLO 63 /* "hello" routing protocol */
-+#define IPPROTO_SATEXPAK 64 /* SATNET/Backroom EXPAK */
-+#define IPPROTO_KRYPTOLAN 65 /* Kryptolan */
-+#define IPPROTO_RVD 66 /* Remote Virtual Disk */
-+#define IPPROTO_IPPC 67 /* Pluribus Packet Core */
-+#define IPPROTO_ADFS 68 /* Any distributed FS */
-+#define IPPROTO_SATMON 69 /* Satnet Monitoring */
-+#define IPPROTO_VISA 70 /* VISA Protocol */
-+#define IPPROTO_IPCV 71 /* Packet Core Utility */
-+#define IPPROTO_CPNX 72 /* Comp. Prot. Net. Executive */
-+#define IPPROTO_CPHB 73 /* Comp. Prot. HeartBeat */
-+#define IPPROTO_WSN 74 /* Wang Span Network */
-+#define IPPROTO_PVP 75 /* Packet Video Protocol */
-+#define IPPROTO_BRSATMON 76 /* BackRoom SATNET Monitoring */
-+#define IPPROTO_ND 77 /* Sun net disk proto (temp.) */
-+#define IPPROTO_WBMON 78 /* WIDEBAND Monitoring */
-+#define IPPROTO_WBEXPAK 79 /* WIDEBAND EXPAK */
-+#define IPPROTO_EON 80 /* ISO cnlp */
-+#define IPPROTO_VMTP 81 /* VMTP */
-+#define IPPROTO_SVMTP 82 /* Secure VMTP */
-+#define IPPROTO_VINES 83 /* Banyon VINES */
-+#define IPPROTO_TTP 84 /* TTP */
-+#define IPPROTO_IGP 85 /* NSFNET-IGP */
-+#define IPPROTO_DGP 86 /* dissimilar gateway prot. */
-+#define IPPROTO_TCF 87 /* TCF */
-+#define IPPROTO_IGRP 88 /* Cisco/GXS IGRP */
-+#define IPPROTO_OSPFIGP 89 /* OSPFIGP */
-+#define IPPROTO_SRPC 90 /* Strite RPC protocol */
-+#define IPPROTO_LARP 91 /* Locus Address Resoloution */
-+#define IPPROTO_MTP 92 /* Multicast Transport */
-+#define IPPROTO_AX25 93 /* AX.25 Frames */
-+#define IPPROTO_IPEIP 94 /* IP encapsulated in IP */
-+#define IPPROTO_MICP 95 /* Mobile Int.ing control */
-+#define IPPROTO_SCCSP 96 /* Semaphore Comm. security */
-+#define IPPROTO_ETHERIP 97 /* Ethernet IP encapsulation */
-+#define IPPROTO_ENCAP 98 /* encapsulation header */
-+#define IPPROTO_APES 99 /* any private encr. scheme */
-+#define IPPROTO_GMTP 100 /* GMTP*/
-+#define IPPROTO_IPCOMP 108 /* payload compression (IPComp) */
-+/* 101-254: Partly Unassigned */
-+#define IPPROTO_PIM 103 /* Protocol Independent Mcast */
-+#define IPPROTO_PGM 113 /* PGM */
-+/* 255: Reserved */
-+/* BSD Private, local use, namespace incursion */
-+#define IPPROTO_DIVERT 254 /* divert pseudo-protocol */
-+#define IPPROTO_RAW 255 /* raw IP packet */
-+#define IPPROTO_MAX 256
-+
-+/* last return value of *_input(), meaning "all job for this pkt is done". */
-+#define IPPROTO_DONE 257
-+
-+/*
-+ * Local port number conventions:
-+ *
-+ * When a user does a bind(2) or connect(2) with a port number of zero,
-+ * a non-conflicting local port address is chosen.
-+ * The default range is IPPORT_RESERVED through
-+ * IPPORT_USERRESERVED, although that is settable by sysctl.
-+ *
-+ * A user may set the IPPROTO_IP option IP_PORTRANGE to change this
-+ * default assignment range.
-+ *
-+ * The value IP_PORTRANGE_DEFAULT causes the default behavior.
-+ *
-+ * The value IP_PORTRANGE_HIGH changes the range of candidate port numbers
-+ * into the "high" range. These are reserved for client outbound connections
-+ * which do not want to be filtered by any firewalls.
-+ *
-+ * The value IP_PORTRANGE_LOW changes the range to the "low" are
-+ * that is (by convention) restricted to privileged processes. This
-+ * convention is based on "vouchsafe" principles only. It is only secure
-+ * if you trust the remote host to restrict these ports.
-+ *
-+ * The default range of ports and the high range can be changed by
-+ * sysctl(3). (net.inet.ip.port{hi,low}{first,last}_auto)
-+ *
-+ * Changing those values has bad security implications if you are
-+ * using a a stateless firewall that is allowing packets outside of that
-+ * range in order to allow transparent outgoing connections.
-+ *
-+ * Such a firewall configuration will generally depend on the use of these
-+ * default values. If you change them, you may find your Security
-+ * Administrator looking for you with a heavy object.
-+ *
-+ * For a slightly more orthodox text view on this:
-+ *
-+ * ftp://ftp.isi.edu/in-notes/iana/assignments/port-numbers
-+ *
-+ * port numbers are divided into three ranges:
-+ *
-+ * 0 - 1023 Well Known Ports
-+ * 1024 - 49151 Registered Ports
-+ * 49152 - 65535 Dynamic and/or Private Ports
-+ *
-+ */
-+
-+/*
-+ * Ports < IPPORT_RESERVED are reserved for
-+ * privileged processes (e.g. root). (IP_PORTRANGE_LOW)
-+ * Ports > IPPORT_USERRESERVED are reserved
-+ * for servers, not necessarily privileged. (IP_PORTRANGE_DEFAULT)
-+ */
-+#define IPPORT_RESERVED 1024
-+#define IPPORT_USERRESERVED 5000
-+
-+/*
-+ * Default local port range to use by setting IP_PORTRANGE_HIGH
-+ */
-+#define IPPORT_HIFIRSTAUTO 49152
-+#define IPPORT_HILASTAUTO 65535
-+
-+/*
-+ * Scanning for a free reserved port return a value below IPPORT_RESERVED,
-+ * but higher than IPPORT_RESERVEDSTART. Traditionally the start value was
-+ * 512, but that conflicts with some well-known-services that firewalls may
-+ * have a fit if we use.
-+ */
-+#define IPPORT_RESERVEDSTART 600
-+
-+/*
-+ * Internet address (a structure for historical reasons)
-+ */
-+struct in_addr {
-+ in_addr_t s_addr;
-+};
-+
-+/*
-+ * Definitions of bits in internet address integers.
-+ * On subnets, the decomposition of addresses to host and net parts
-+ * is done according to subnet mask, not the masks here.
-+ */
-+#define IN_CLASSA(i) (((u_int32_t)(i) & 0x80000000) == 0)
-+#define IN_CLASSA_NET 0xff000000
-+#define IN_CLASSA_NSHIFT 24
-+#define IN_CLASSA_HOST 0x00ffffff
-+#define IN_CLASSA_MAX 128
-+
-+#define IN_CLASSB(i) (((u_int32_t)(i) & 0xc0000000) == 0x80000000)
-+#define IN_CLASSB_NET 0xffff0000
-+#define IN_CLASSB_NSHIFT 16
-+#define IN_CLASSB_HOST 0x0000ffff
-+#define IN_CLASSB_MAX 65536
-+
-+#define IN_CLASSC(i) (((u_int32_t)(i) & 0xe0000000) == 0xc0000000)
-+#define IN_CLASSC_NET 0xffffff00
-+#define IN_CLASSC_NSHIFT 8
-+#define IN_CLASSC_HOST 0x000000ff
-+
-+#define IN_CLASSD(i) (((u_int32_t)(i) & 0xf0000000) == 0xe0000000)
-+#define IN_CLASSD_NET 0xf0000000 /* These ones aren't really */
-+#define IN_CLASSD_NSHIFT 28 /* net and host fields, but */
-+#define IN_CLASSD_HOST 0x0fffffff /* routing needn't know. */
-+#define IN_MULTICAST(i) IN_CLASSD(i)
-+
-+#define IN_EXPERIMENTAL(i) (((u_int32_t)(i) & 0xf0000000) == 0xf0000000)
-+#define IN_BADCLASS(i) (((u_int32_t)(i) & 0xf0000000) == 0xf0000000)
-+
-+#define INADDR_ANY (u_int32_t)0x00000000
-+#define INADDR_LOOPBACK (u_int32_t)0x7f000001
-+#define INADDR_BROADCAST (u_int32_t)0xffffffff /* must be masked */
-+#ifndef _KERNEL
-+#define INADDR_NONE 0xffffffff /* -1 return */
-+#endif
-+
-+#define INADDR_UNSPEC_GROUP (u_int32_t)0xe0000000 /* 224.0.0.0 */
-+#define INADDR_ALLHOSTS_GROUP (u_int32_t)0xe0000001 /* 224.0.0.1 */
-+#define INADDR_ALLRTRS_GROUP (u_int32_t)0xe0000002 /* 224.0.0.2 */
-+#define INADDR_MAX_LOCAL_GROUP (u_int32_t)0xe00000ff /* 224.0.0.255 */
-+
-+#define IN_LOOPBACKNET 127 /* official! */
-+
-+/*
-+ * Socket address, internet style.
-+ */
-+struct sockaddr_in {
-+ u_char sin_len;
-+ u_char sin_family;
-+ u_short sin_port;
-+ struct in_addr sin_addr;
-+ char sin_zero[8];
-+};
-+
-+#define INET_ADDRSTRLEN 16
-+
-+/*
-+ * Options for use with [gs]etsockopt at the IP level.
-+ * First word of comment is data type; bool is stored in int.
-+ */
-+#define IP_OPTIONS 1 /* buf/ip_opts; set/get IP options */
-+#define IP_HDRINCL 2 /* int; header is included with data */
-+#define IP_TOS 3 /* int; IP type of service and preced. */
-+#define IP_TTL 4 /* int; IP time to live */
-+#define IP_RECVOPTS 5 /* bool; receive all IP opts w/dgram */
-+#define IP_RECVRETOPTS 6 /* bool; receive IP opts for response */
-+#define IP_RECVDSTADDR 7 /* bool; receive IP dst addr w/dgram */
-+#define IP_RETOPTS 8 /* ip_opts; set/get IP options */
-+#define IP_MULTICAST_IF 9 /* u_char; set/get IP multicast i/f */
-+#define IP_MULTICAST_TTL 10 /* u_char; set/get IP multicast ttl */
-+#define IP_MULTICAST_LOOP 11 /* u_char; set/get IP multicast loopback */
-+#define IP_ADD_MEMBERSHIP 12 /* ip_mreq; add an IP group membership */
-+#define IP_DROP_MEMBERSHIP 13 /* ip_mreq; drop an IP group membership */
-+#define IP_MULTICAST_VIF 14 /* set/get IP mcast virt. iface */
-+#define IP_RSVP_ON 15 /* enable RSVP in kernel */
-+#define IP_RSVP_OFF 16 /* disable RSVP in kernel */
-+#define IP_RSVP_VIF_ON 17 /* set RSVP per-vif socket */
-+#define IP_RSVP_VIF_OFF 18 /* unset RSVP per-vif socket */
-+#define IP_PORTRANGE 19 /* int; range to choose for unspec port */
-+#define IP_RECVIF 20 /* bool; receive reception if w/dgram */
-+/* for IPSEC */
-+#define IP_IPSEC_POLICY 21 /* int; set/get security policy */
-+#define IP_FAITH 22 /* bool; accept FAITH'ed connections */
-+
-+#define IP_ONESBCAST 23 /* bool: send all-ones broadcast */
-+
-+#define IP_FW_TABLE_ADD 40 /* add entry */
-+#define IP_FW_TABLE_DEL 41 /* delete entry */
-+#define IP_FW_TABLE_FLUSH 42 /* flush table */
-+#define IP_FW_TABLE_GETSIZE 43 /* get table size */
-+#define IP_FW_TABLE_LIST 44 /* list table contents */
-+
-+#define IP_FW_ADD 50 /* add a firewall rule to chain */
-+#define IP_FW_DEL 51 /* delete a firewall rule from chain */
-+#define IP_FW_FLUSH 52 /* flush firewall rule chain */
-+#define IP_FW_ZERO 53 /* clear single/all firewall counter(s) */
-+#define IP_FW_GET 54 /* get entire firewall rule chain */
-+#define IP_FW_RESETLOG 55 /* reset logging counters */
-+
-+#define IP_DUMMYNET_CONFIGURE 60 /* add/configure a dummynet pipe */
-+#define IP_DUMMYNET_DEL 61 /* delete a dummynet pipe from chain */
-+#define IP_DUMMYNET_FLUSH 62 /* flush dummynet */
-+#define IP_DUMMYNET_GET 64 /* get entire dummynet pipes */
-+
-+/*
-+ * Defaults and limits for options
-+ */
-+#define IP_DEFAULT_MULTICAST_TTL 1 /* normally limit m'casts to 1 hop */
-+#define IP_DEFAULT_MULTICAST_LOOP 1 /* normally hear sends if a member */
-+#define IP_MAX_MEMBERSHIPS 20 /* per socket */
-+
-+/*
-+ * Argument structure for IP_ADD_MEMBERSHIP and IP_DROP_MEMBERSHIP.
-+ */
-+struct ip_mreq {
-+ struct in_addr imr_multiaddr; /* IP multicast address of group */
-+ struct in_addr imr_interface; /* local IP address of interface */
-+};
-+
-+/*
-+ * Argument for IP_PORTRANGE:
-+ * - which range to search when port is unspecified at bind() or connect()
-+ */
-+#define IP_PORTRANGE_DEFAULT 0 /* default range */
-+#define IP_PORTRANGE_HIGH 1 /* "high" - request firewall bypass */
-+#define IP_PORTRANGE_LOW 2 /* "low" - vouchsafe security */
-+
-+/*
-+ * Definitions for inet sysctl operations.
-+ *
-+ * Third level is protocol number.
-+ * Fourth level is desired variable within that protocol.
-+ */
-+#define IPPROTO_MAXID (IPPROTO_AH + 1) /* don't list to IPPROTO_MAX */
-+
-+#define CTL_IPPROTO_NAMES { \
-+ { "ip", CTLTYPE_NODE }, \
-+ { "icmp", CTLTYPE_NODE }, \
-+ { "igmp", CTLTYPE_NODE }, \
-+ { "ggp", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { "tcp", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { "egp", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { "pup", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { "udp", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { "idp", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { "ipsec", CTLTYPE_NODE }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { 0, 0 }, \
-+ { "pim", CTLTYPE_NODE }, \
-+}
-+
-+/*
-+ * Names for IP sysctl objects
-+ */
-+#define IPCTL_FORWARDING 1 /* act as router */
-+#define IPCTL_SENDREDIRECTS 2 /* may send redirects when forwarding */
-+#define IPCTL_DEFTTL 3 /* default TTL */
-+#ifdef notyet
-+#define IPCTL_DEFMTU 4 /* default MTU */
-+#endif
-+#define IPCTL_RTEXPIRE 5 /* cloned route expiration time */
-+#define IPCTL_RTMINEXPIRE 6 /* min value for expiration time */
-+#define IPCTL_RTMAXCACHE 7 /* trigger level for dynamic expire */
-+#define IPCTL_SOURCEROUTE 8 /* may perform source routes */
-+#define IPCTL_DIRECTEDBROADCAST 9 /* may re-broadcast received packets */
-+#define IPCTL_INTRQMAXLEN 10 /* max length of netisr queue */
-+#define IPCTL_INTRQDROPS 11 /* number of netisr q drops */
-+#define IPCTL_STATS 12 /* ipstat structure */
-+#define IPCTL_ACCEPTSOURCEROUTE 13 /* may accept source routed packets */
-+#define IPCTL_FASTFORWARDING 14 /* use fast IP forwarding code */
-+#define IPCTL_KEEPFAITH 15 /* FAITH IPv4->IPv6 translater ctl */
-+#define IPCTL_GIF_TTL 16 /* default TTL for gif encap packet */
-+#define IPCTL_MAXID 17
-+
-+#define IPCTL_NAMES { \
-+ { 0, 0 }, \
-+ { "forwarding", CTLTYPE_INT }, \
-+ { "redirect", CTLTYPE_INT }, \
-+ { "ttl", CTLTYPE_INT }, \
-+ { "mtu", CTLTYPE_INT }, \
-+ { "rtexpire", CTLTYPE_INT }, \
-+ { "rtminexpire", CTLTYPE_INT }, \
-+ { "rtmaxcache", CTLTYPE_INT }, \
-+ { "sourceroute", CTLTYPE_INT }, \
-+ { "directed-broadcast", CTLTYPE_INT }, \
-+ { "intr-queue-maxlen", CTLTYPE_INT }, \
-+ { "intr-queue-drops", CTLTYPE_INT }, \
-+ { "stats", CTLTYPE_STRUCT }, \
-+ { "accept_sourceroute", CTLTYPE_INT }, \
-+ { "fastforwarding", CTLTYPE_INT }, \
-+}
-+
-+#ifdef _KERNEL
-+struct ifnet; struct mbuf; /* forward declarations for Standard C */
-+#endif
-+
-+/* INET6 stuff */
-+#define __KAME_NETINET_IN_H_INCLUDED_
-+#include <netinet6/in6.h>
-+#undef __KAME_NETINET_IN_H_INCLUDED_
-+
-+#ifdef _KERNEL
-+
-+int in_broadcast __P((struct in_addr, struct ifnet *));
-+int in_canforward __P((struct in_addr));
-+int in_cksum __P((struct mbuf *, int));
-+int in_localaddr __P((struct in_addr));
-+char *inet_ntoa __P((struct in_addr)); /* in libkern */
-+
-+int prison_ip __P((struct proc *p, int flag, u_int32_t *ip));
-+void prison_remote_ip __P((struct proc *p, int flag, u_int32_t *ip));
-+
-+#define in_hosteq(s, t) ((s).s_addr == (t).s_addr)
-+#define in_nullhost(x) ((x).s_addr == INADDR_ANY)
-+
-+#define satosin(sa) ((struct sockaddr_in *)(sa))
-+#define sintosa(sin) ((struct sockaddr *)(sin))
-+#define ifatoia(ifa) ((struct in_ifaddr *)(ifa))
-+
-+#endif
-+
-+#endif
diff --git a/graphics/raster3d/files/patch-Makefile b/graphics/raster3d/files/patch-Makefile
deleted file mode 100644
index c862db5edf22..000000000000
--- a/graphics/raster3d/files/patch-Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.orig Wed Apr 12 19:46:10 2006
-+++ Makefile Fri Apr 28 02:48:06 2006
-@@ -156,6 +156,16 @@
- @echo FFLAGS = \${CFLAGS} >> Makefile.incl
- @echo RM = /bin/rm -f >> Makefile.incl
-
-+freebsd: strip-for-g77
-+ @cp Makefile.template Makefile.incl
-+ @echo OS = freebsd >> Makefile.incl
-+ @echo CC = ${CC} >> Makefile.incl
-+ @echo CFLAGS = ${CFLAGS} >> Makefile.incl
-+ @echo FC = ${F77} >> Makefile.incl
-+ @echo FFLAGS = ${FFLAGS} >> Makefile.incl
-+ @echo RM = /bin/rm -f >> Makefile.incl
-+ @echo OSDEFS = -DLINUX -DNETWORKBYTEORDER >> Makefile.incl
-+ @echo include Makefile.package >> Makefile.incl
-
- strip-for-g77: render.f.bak normal3d.f.bak rastep.f.bak
- render.f.bak:
diff --git a/graphics/raster3d/pkg-plist b/graphics/raster3d/pkg-plist
index 06d5cd4f719f..b33b7e1ca06b 100644
--- a/graphics/raster3d/pkg-plist
+++ b/graphics/raster3d/pkg-plist
@@ -8,6 +8,8 @@ bin/rods
bin/normal3d
%%IMAGEMAGICK%%bin/label3d
%%IMAGEMAGICK%%bin/stereo3d
+bin/worms
+%%PORTDOCS%%%%DOCSDIR%%/R3D_manual.pdf
%%PORTDOCS%%%%DOCSDIR%%/html/README
%%PORTDOCS%%%%DOCSDIR%%/html/avs2ps.html
%%PORTDOCS%%%%DOCSDIR%%/html/balls.html
@@ -56,11 +58,8 @@ bin/normal3d
%%PORTDOCS%%%%DOCSDIR%%/html/rings3d.html
%%PORTDOCS%%%%DOCSDIR%%/html/rods.html
%%PORTDOCS%%%%DOCSDIR%%/html/stereo3d.html
-%%PORTDOCS%%%%DOCSDIR%%/R3D_manual.pdf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msms/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msms/msms2r3d.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msms/msms_example.script
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/LT.pdb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.examples
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chaincolours.pdb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clip.r3d
@@ -93,6 +92,9 @@ bin/normal3d
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/header2.r3d
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/header4.r3d
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/header8.r3d
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msms/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msms/msms2r3d.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msms/msms_example.script
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plane.r3d
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sugarG.pdb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sugarcolours.pdb