aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-05-20 01:09:56 +0800
committerijliao <ijliao@FreeBSD.org>2001-05-20 01:09:56 +0800
commit29f1ae3f4b80f639d1c15b5770bf582aedceb73d (patch)
tree0709476b719deff73c338a3944cb244087dc8849
parentf3f7833e03b8c4d3cb833707f8878dd3178c1ba1 (diff)
downloadfreebsd-ports-gnome-29f1ae3f4b80f639d1c15b5770bf582aedceb73d.tar.gz
freebsd-ports-gnome-29f1ae3f4b80f639d1c15b5770bf582aedceb73d.tar.zst
freebsd-ports-gnome-29f1ae3f4b80f639d1c15b5770bf582aedceb73d.zip
add pfaedit
Type 1/TrueType/OpenType/bitmap font editor PR: 26515 Submitted by: KANOU Hiroki <kanou@mil.allnet.ne.jp>
-rw-r--r--print/Makefile1
-rw-r--r--print/fontforge/Makefile41
-rw-r--r--print/fontforge/distinfo3
-rw-r--r--print/fontforge/pkg-comment1
-rw-r--r--print/fontforge/pkg-descr10
-rw-r--r--print/fontforge/pkg-plist1
-rw-r--r--print/pfaedit/Makefile41
-rw-r--r--print/pfaedit/distinfo3
-rw-r--r--print/pfaedit/pkg-comment1
-rw-r--r--print/pfaedit/pkg-descr10
-rw-r--r--print/pfaedit/pkg-plist1
11 files changed, 113 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 1a28993b54b7..3554323246df 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -85,6 +85,7 @@
SUBDIR += pdflib3
SUBDIR += pdq
SUBDIR += perlftlib
+ SUBDIR += pfaedit
SUBDIR += pic2fig
SUBDIR += pips-sc680_777
SUBDIR += pips-sc880
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
new file mode 100644
index 000000000000..a109174521d1
--- /dev/null
+++ b/print/fontforge/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pfaedit
+# Date created: 25 March 2001
+# Whom: KANOU Hiroki <kanou@mil.allnet.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfaedit
+PORTVERSION= 20010410
+CATEGORIES= print
+MASTER_SITES= http://bibliofile.mc.duke.edu/gww/Freeware/PfaEdit/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}_src-${DIST_VER}.tgz \
+ libgunicode-${LIBGUNI_VER}.tgz libgdraw-${LIBGDRAW_VER}.tgz
+
+MAINTAINER= kanou@mil.allnet.ne.jp
+
+DIST_VER= 230401
+LIBGDRAW_VER= 220401
+LIBGUNI_VER= 220401
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.4:${PORTSDIR}/graphics/png \
+ ungif.5:${PORTSDIR}/graphics/libungif
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= pfaedit
+
+MAN1= pfaedit.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pfaedit/pfaedit ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pfaedit/pfaedit.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/print/fontforge/distinfo b/print/fontforge/distinfo
new file mode 100644
index 000000000000..45a5569f6444
--- /dev/null
+++ b/print/fontforge/distinfo
@@ -0,0 +1,3 @@
+MD5 (pfaedit_src-230401.tgz) = 274232db99779d96dbcd673172b3bc46
+MD5 (libgunicode-220401.tgz) = e4da6d0c4380df8d2cfdec87689525e1
+MD5 (libgdraw-220401.tgz) = 81464356be0dd91866601219e5492e34
diff --git a/print/fontforge/pkg-comment b/print/fontforge/pkg-comment
new file mode 100644
index 000000000000..d93a19a53722
--- /dev/null
+++ b/print/fontforge/pkg-comment
@@ -0,0 +1 @@
+Type 1/TrueType/OpenType/bitmap font editor
diff --git a/print/fontforge/pkg-descr b/print/fontforge/pkg-descr
new file mode 100644
index 000000000000..8e8d7901848f
--- /dev/null
+++ b/print/fontforge/pkg-descr
@@ -0,0 +1,10 @@
+PfaEdit is a PostScript font editor which can create and modify outline
+fonts in Type 1, TrueType, or OpenType format. It can generate bitmaps
+and save in BDF format.
+
+If you have installed 'autotrace', you can generate outlines from
+imported bitmap images.
+
+For more Information, see
+
+WWW: http://bibliofile.mc.duke.edu/gww/FreeWare/PfaEdit/
diff --git a/print/fontforge/pkg-plist b/print/fontforge/pkg-plist
new file mode 100644
index 000000000000..4766bcbf81c1
--- /dev/null
+++ b/print/fontforge/pkg-plist
@@ -0,0 +1 @@
+bin/pfaedit
diff --git a/print/pfaedit/Makefile b/print/pfaedit/Makefile
new file mode 100644
index 000000000000..a109174521d1
--- /dev/null
+++ b/print/pfaedit/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pfaedit
+# Date created: 25 March 2001
+# Whom: KANOU Hiroki <kanou@mil.allnet.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfaedit
+PORTVERSION= 20010410
+CATEGORIES= print
+MASTER_SITES= http://bibliofile.mc.duke.edu/gww/Freeware/PfaEdit/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}_src-${DIST_VER}.tgz \
+ libgunicode-${LIBGUNI_VER}.tgz libgdraw-${LIBGDRAW_VER}.tgz
+
+MAINTAINER= kanou@mil.allnet.ne.jp
+
+DIST_VER= 230401
+LIBGDRAW_VER= 220401
+LIBGUNI_VER= 220401
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.4:${PORTSDIR}/graphics/png \
+ ungif.5:${PORTSDIR}/graphics/libungif
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= pfaedit
+
+MAN1= pfaedit.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pfaedit/pfaedit ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pfaedit/pfaedit.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/print/pfaedit/distinfo b/print/pfaedit/distinfo
new file mode 100644
index 000000000000..45a5569f6444
--- /dev/null
+++ b/print/pfaedit/distinfo
@@ -0,0 +1,3 @@
+MD5 (pfaedit_src-230401.tgz) = 274232db99779d96dbcd673172b3bc46
+MD5 (libgunicode-220401.tgz) = e4da6d0c4380df8d2cfdec87689525e1
+MD5 (libgdraw-220401.tgz) = 81464356be0dd91866601219e5492e34
diff --git a/print/pfaedit/pkg-comment b/print/pfaedit/pkg-comment
new file mode 100644
index 000000000000..d93a19a53722
--- /dev/null
+++ b/print/pfaedit/pkg-comment
@@ -0,0 +1 @@
+Type 1/TrueType/OpenType/bitmap font editor
diff --git a/print/pfaedit/pkg-descr b/print/pfaedit/pkg-descr
new file mode 100644
index 000000000000..8e8d7901848f
--- /dev/null
+++ b/print/pfaedit/pkg-descr
@@ -0,0 +1,10 @@
+PfaEdit is a PostScript font editor which can create and modify outline
+fonts in Type 1, TrueType, or OpenType format. It can generate bitmaps
+and save in BDF format.
+
+If you have installed 'autotrace', you can generate outlines from
+imported bitmap images.
+
+For more Information, see
+
+WWW: http://bibliofile.mc.duke.edu/gww/FreeWare/PfaEdit/
diff --git a/print/pfaedit/pkg-plist b/print/pfaedit/pkg-plist
new file mode 100644
index 000000000000..4766bcbf81c1
--- /dev/null
+++ b/print/pfaedit/pkg-plist
@@ -0,0 +1 @@
+bin/pfaedit