aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-02-26 02:53:40 +0800
committerleeym <leeym@FreeBSD.org>2003-02-26 02:53:40 +0800
commit29f27b79add92fc0eeb3613f804050e73ae29aea (patch)
tree11899f6ca9e025cf4a614fd9c9de75cfe1ef582b
parentf0f329b33ba611a4db381432ee85229e0cb30c79 (diff)
downloadfreebsd-ports-gnome-29f27b79add92fc0eeb3613f804050e73ae29aea.tar.gz
freebsd-ports-gnome-29f27b79add92fc0eeb3613f804050e73ae29aea.tar.zst
freebsd-ports-gnome-29f27b79add92fc0eeb3613f804050e73ae29aea.zip
add gubby-0.3.2
Gubby is a small program that continually shows where Procmail has placed new email. It runs both in commandline and in an ncurses environment with colors, and will update the overview in real time, while using very low resources. Users can launch a specified mailreader by selecting a folder and pressing enter. PR: 47907 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/gubby/Makefile31
-rw-r--r--mail/gubby/distinfo1
-rw-r--r--mail/gubby/files/patch-aa18
-rw-r--r--mail/gubby/files/patch-ab13
-rw-r--r--mail/gubby/pkg-descr11
-rw-r--r--mail/gubby/pkg-plist3
7 files changed, 78 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 27f951e1cba1..9cc1ee4ce7ed 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -77,6 +77,7 @@
SUBDIR += gotmail
SUBDIR += grepmail
SUBDIR += gtkgrepmail
+ SUBDIR += gubby
SUBDIR += hbiff
SUBDIR += hotwayd
SUBDIR += icqmail
diff --git a/mail/gubby/Makefile b/mail/gubby/Makefile
new file mode 100644
index 000000000000..8d9fca5f2416
--- /dev/null
+++ b/mail/gubby/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: gubby
+# Date created: Feb 4, 2003
+# Whom: mich@freebsdcluster.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gubby
+PORTVERSION= 0.3.2
+CATEGORIES= mail
+MASTER_SITES= http://sublevel3.org/~csl/gubby/dist/
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= A program showing where new mail has been placed
+
+LDFLAGS+= -lncurses -ltermcap
+CFLAGS+= -felide-constructors -fno-default-inline
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CXX} ${CFLAGS} -o ${PORTNAME} -Iinclude/ ${LDFLAGS} src/gubby.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gubby ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/gubby/distinfo b/mail/gubby/distinfo
new file mode 100644
index 000000000000..d08c6c3b6cbe
--- /dev/null
+++ b/mail/gubby/distinfo
@@ -0,0 +1 @@
+MD5 (gubby-0.3.2.tar.gz) = 14e5261531f8bb9142e037ce10cd2d0a
diff --git a/mail/gubby/files/patch-aa b/mail/gubby/files/patch-aa
new file mode 100644
index 000000000000..30571fa82b7f
--- /dev/null
+++ b/mail/gubby/files/patch-aa
@@ -0,0 +1,18 @@
+--- src/gubby.cpp.orig Tue Feb 4 16:16:09 2003
++++ src/gubby.cpp Tue Feb 4 16:15:32 2003
+@@ -49,13 +49,13 @@
+ char buf[1024];
+
+ if ( f != 0 )
+- while ( !feof(f) ) {
++ while ( !feof(f.fptr()) ) {
+
+ buf[0] = 0;
+ char* s = &buf[0];
+ const char* p = find;
+
+- fgets(s, sizeof buf / sizeof(char), f);
++ fgets(s, sizeof buf / sizeof(char), f.fptr());
+
+ // search for matched string
+ while ( *p++ == *s++ );
diff --git a/mail/gubby/files/patch-ab b/mail/gubby/files/patch-ab
new file mode 100644
index 000000000000..c2258833e776
--- /dev/null
+++ b/mail/gubby/files/patch-ab
@@ -0,0 +1,13 @@
+--- include/file_ptr.h.orig Mon Feb 3 09:38:16 2003
++++ include/file_ptr.h Tue Feb 4 16:15:37 2003
+@@ -61,6 +61,10 @@
+ return ptr;
+ }
+
++ FILE* fptr() const {
++ return ptr;
++ }
++
+ void operator=(FILE* f) {
+ close();
+ ptr = f;
diff --git a/mail/gubby/pkg-descr b/mail/gubby/pkg-descr
new file mode 100644
index 000000000000..ea32bfab762b
--- /dev/null
+++ b/mail/gubby/pkg-descr
@@ -0,0 +1,11 @@
+Gubby is a small program that continually shows where Procmail has placed
+new email. It runs both in commandline and in an ncurses environment with
+colors, and will update the overview in real time, while using very low
+resources. Users can launch a specified mailreader by selecting a folder
+and pressing enter.
+
+AUTHOR: C.S. Larsen <csl@sublevel3.org>
+WWW: http://sublevel3.org/~csl/gubby/
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/mail/gubby/pkg-plist b/mail/gubby/pkg-plist
new file mode 100644
index 000000000000..bab25a77c0bd
--- /dev/null
+++ b/mail/gubby/pkg-plist
@@ -0,0 +1,3 @@
+bin/gubby
+%%PORTDOCS%%share/doc/gubby/README
+%%PORTDOCS%%@dirrm share/doc/gubby