diff options
author | rm <rm@FreeBSD.org> | 2012-11-22 19:21:39 +0800 |
---|---|---|
committer | rm <rm@FreeBSD.org> | 2012-11-22 19:21:39 +0800 |
commit | 2ba1bd2cc1fafbb0ae7dba87bad4f43ec1f82b87 (patch) | |
tree | 5ff640bc26d5be279793a548a10788287934441f | |
parent | 86a1495116079f423fdec3fe2c967c730f791aca (diff) | |
download | freebsd-ports-gnome-2ba1bd2cc1fafbb0ae7dba87bad4f43ec1f82b87.tar.gz freebsd-ports-gnome-2ba1bd2cc1fafbb0ae7dba87bad4f43ec1f82b87.tar.zst freebsd-ports-gnome-2ba1bd2cc1fafbb0ae7dba87bad4f43ec1f82b87.zip |
- update to 5.0.1
- rename to py-irc to follow upstream
- change MASTER_SITES to pypi
- switch to easy_install
- update examples
- convert to optionsng
- add optional dependency on py-importlib for python < 2.7
- update WWW and port description
- general clean-up
This port should be python3 aware, so change USE_PYTHON to yes, but it still
doesn't builds with it because py-hgtools isn't, so can't test for sure.
PR: 173828
Submitted by: rm (myself)
Approved by: William Grzybowski <william88 at gmail dot com> (maintainer, via python@ ML)
Feature safe: yes
-rw-r--r-- | MOVED | 1 | ||||
-rw-r--r-- | irc/Makefile | 2 | ||||
-rw-r--r-- | irc/py-irc/Makefile | 37 | ||||
-rw-r--r-- | irc/py-irc/distinfo | 2 | ||||
-rw-r--r-- | irc/py-irc/pkg-descr | 6 | ||||
-rw-r--r-- | irc/py-irc/pkg-plist | 8 | ||||
-rw-r--r-- | irc/py-irclib/Makefile | 41 | ||||
-rw-r--r-- | irc/py-irclib/distinfo | 2 | ||||
-rw-r--r-- | irc/py-irclib/pkg-descr | 6 | ||||
-rw-r--r-- | irc/py-irclib/pkg-plist | 20 |
10 files changed, 55 insertions, 70 deletions
@@ -3845,3 +3845,4 @@ net-im/qutim-plugin-jabber||2012-11-19|Has expired: It is not needed for new Qut www/trac-customroadmap||2012-11-19|Has expired: Functionality of this plugin is available in the Trac core as of 0.11 net-mgmt/py-snmp2||2012-11-19|Has expired: Dead upstream, use net-mgmt/py-snmp4 instead net-im/ccmsn||2012-11-19|Has expired: The project no longer exists +irc/py-irclib|irc/py-irc|2012-11-22|Rename according to upstream name change diff --git a/irc/Makefile b/irc/Makefile index 315ce6558baf..edd9d653a34d 100644 --- a/irc/Makefile +++ b/irc/Makefile @@ -103,7 +103,7 @@ SUBDIR += pure-emacs21 SUBDIR += pure-xemacs21-mule SUBDIR += py-gozerbot - SUBDIR += py-irclib + SUBDIR += py-irc SUBDIR += py-supybot SUBDIR += py-supybot-plugins SUBDIR += quassel diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile new file mode 100644 index 000000000000..878f68098c44 --- /dev/null +++ b/irc/py-irc/Makefile @@ -0,0 +1,37 @@ +# Created by: Hye-Shik Chang +# $FreeBSD$ + +PORTNAME= irc +PORTVERSION= 5.0.1 +CATEGORIES= irc python +MASTER_SITES= CHEESESHOP +PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} + +MAINTAINER= william88@gmail.com +COMMENT= IRC protocol client library for Python + +USE_PYTHON= yes +USE_PYDISTUTILS=easy_install +USE_ZIP= yes + +BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}hgtools>0:${PORTSDIR}/devel/py-hgtools + +EXAMPLEFILES= irccat.py irccat2.py servermap.py testbot.py \ + dccreceive.py dccsend.py +EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME} + +.include <bsd.port.pre.mk> + +.if ${PORT_OPTIONS:MEXAMPLES} +post-install: + @${MKDIR} ${EXAMPLESDIR} +.for file in ${EXAMPLEFILES} + @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${file} ${EXAMPLESDIR}/ +.endfor +.endif + +.if ${PYTHON_REL} < 270 +RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib>0:${PORTSDIR}/devel/py-importlib +.endif + +.include <bsd.port.post.mk> diff --git a/irc/py-irc/distinfo b/irc/py-irc/distinfo new file mode 100644 index 000000000000..9e2c8cdff97f --- /dev/null +++ b/irc/py-irc/distinfo @@ -0,0 +1,2 @@ +SHA256 (irc-5.0.1.zip) = c7262b21a4b6f713913aaddcd6e1c73920a07903feda9758065699d6d5fc3796 +SIZE (irc-5.0.1.zip) = 88039 diff --git a/irc/py-irc/pkg-descr b/irc/py-irc/pkg-descr new file mode 100644 index 000000000000..4bedabc2aa57 --- /dev/null +++ b/irc/py-irc/pkg-descr @@ -0,0 +1,6 @@ +This library is intended to encapsulate the IRC protocol at a quite +low level. It provides an event-driven IRC client framework. It has +a fairly thorough support for the basic IRC protocol, CTCP and DCC +connections. + +WWW: https://bitbucket.org/jaraco/irc diff --git a/irc/py-irc/pkg-plist b/irc/py-irc/pkg-plist new file mode 100644 index 000000000000..a4165ad75531 --- /dev/null +++ b/irc/py-irc/pkg-plist @@ -0,0 +1,8 @@ +%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%% +%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dccreceive.py +%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dccsend.py +%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irccat.py +%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irccat2.py +%%PORTEXAMPLES%%%%EXAMPLESDIR%%/servermap.py +%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testbot.py +%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%% diff --git a/irc/py-irclib/Makefile b/irc/py-irclib/Makefile deleted file mode 100644 index e8abf2357c72..000000000000 --- a/irc/py-irclib/Makefile +++ /dev/null @@ -1,41 +0,0 @@ -# Created by: Hye-Shik Chang -# $FreeBSD$ - -PORTNAME= irclib -PORTVERSION= 0.6.4 -PORTREVISION= 1 -CATEGORIES= irc python -MASTER_SITES= SF/python-${PORTNAME} -PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} -DISTNAME= python-irclib-${PORTVERSION} - -MAINTAINER= william88@gmail.com -COMMENT= IRC protocol client library for Python - -USE_PYTHON= -2.7 -USE_ZIP= yes -USE_PYDISTUTILS=yes -PYDISTUTILS_PKGNAME= python-irclib -PYDISTUTILS_NOEGGINFO=yes - -# TODO: irclib have some weird install script bundled and use of -# USE_PYDISTUTILS=easy_install would break it -BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools \ - ${PYTHON_PKGNAMEPREFIX}hgtools>0:${PORTSDIR}/devel/py-hgtools - -PLIST_SUB= VERSION=${PORTVERSION} PYVER=${PYTHON_VERSION:S/python//} - -EXAMPLEFILES= irccat irccat2 servermap testbot.py \ - dccreceive dccsend -EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME} - -.if !defined(NOPORTEXAMPLES) -post-install: - @${MKDIR} ${EXAMPLESDIR} -.for file in ${EXAMPLEFILES} - @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${file} ${EXAMPLESDIR}/ -.endfor - @${FIND} ${PYTHONPREFIX_SITELIBDIR}/${PYDISTUTILS_EGGINFO} -type f -exec ${CHMOD} 644 {} +; -.endif - -.include <bsd.port.mk> diff --git a/irc/py-irclib/distinfo b/irc/py-irclib/distinfo deleted file mode 100644 index 5be728a907fd..000000000000 --- a/irc/py-irclib/distinfo +++ /dev/null @@ -1,2 +0,0 @@ -SHA256 (python-irclib-0.6.4.zip) = f18205c0d7b25b6f5e5acb1d13e35be930434590585acc2b701a7dd498839dc1 -SIZE (python-irclib-0.6.4.zip) = 74319 diff --git a/irc/py-irclib/pkg-descr b/irc/py-irclib/pkg-descr deleted file mode 100644 index 579a41c6c393..000000000000 --- a/irc/py-irclib/pkg-descr +++ /dev/null @@ -1,6 +0,0 @@ -This library is intended to encapsulate the IRC protocol at a quite -low level. It provides an event-driven IRC client framework. It has -a fairly thorough support for the basic IRC protocol, CTCP and DCC. -It actually does CTCP parsing exactly as the CTCP specifications describe it. - -WWW: http://sourceforge.net/projects/python-irclib/ diff --git a/irc/py-irclib/pkg-plist b/irc/py-irclib/pkg-plist deleted file mode 100644 index f7c503543dd6..000000000000 --- a/irc/py-irclib/pkg-plist +++ /dev/null @@ -1,20 +0,0 @@ -%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dccsend -%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dccreceive -%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irccat2 -%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irccat -%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testbot.py -%%PORTEXAMPLES%%%%EXAMPLESDIR%%/servermap -%%PYTHON_LIBDIR%%/site-packages/python_irclib-%%VERSION%%-py%%PYVER%%.egg-info/PKG-INFO -%%PYTHON_LIBDIR%%/site-packages/python_irclib-%%VERSION%%-py%%PYVER%%.egg-info/dependency_links.txt -%%PYTHON_LIBDIR%%/site-packages/python_irclib-%%VERSION%%-py%%PYVER%%.egg-info/SOURCES.txt -%%PYTHON_LIBDIR%%/site-packages/python_irclib-%%VERSION%%-py%%PYVER%%.egg-info/top_level.txt -%%PYTHON_LIBDIR%%/site-packages/ircbot.pyc -%%PYTHON_LIBDIR%%/site-packages/irclib.pyc -%%PYTHON_LIBDIR%%/site-packages/ircbot.py -%%PYTHON_LIBDIR%%/site-packages/ircbot.pyo -%%PYTHON_LIBDIR%%/site-packages/irclib.pyo -%%PYTHON_LIBDIR%%/site-packages/irclib.py -@dirrm %%PYTHON_LIBDIR%%/site-packages/python_irclib-%%VERSION%%-py%%PYVER%%.egg-info -@dirrmtry %%PYTHON_LIBDIR%%/site-packages -@dirrmtry %%PYTHON_LIBDIR%% -%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%% |