aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-12-28 17:11:28 +0800
committeredwin <edwin@FreeBSD.org>2003-12-28 17:11:28 +0800
commit2cb4dc44f3cfa2fe6218d40eaaebeedc0c826661 (patch)
treec0a0fd2006df428d14a6e8f4625b96e08187ac7c
parent09994c796223a4e0691ac0662d041eefc783a3ff (diff)
downloadfreebsd-ports-gnome-2cb4dc44f3cfa2fe6218d40eaaebeedc0c826661.tar.gz
freebsd-ports-gnome-2cb4dc44f3cfa2fe6218d40eaaebeedc0c826661.tar.zst
freebsd-ports-gnome-2cb4dc44f3cfa2fe6218d40eaaebeedc0c826661.zip
pear-* ports: simplify path to devel/pear-PEAR/Makefile.common
.include <bsd.port.pre.mk> .include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common" can be simplified to: .include <bsd.port.pre.mk> .include "${PORTSDIR}/devel/pear-PEAR/Makefile.common" the latter version also doesn't make any assumptions about the path of including Makefile PR: ports/57152 Submitted by: Roman Neuhauser <neuhauser@bellavista.cz>
-rw-r--r--devel/pear-HTML_Common/Makefile2
-rw-r--r--devel/pear-apd/Makefile4
-rw-r--r--net/pear-Net_NNTP/Makefile2
-rw-r--r--www/pear-APC/Makefile4
-rw-r--r--www/pear-HTTP/Makefile2
-rw-r--r--www/pear-HTTP_Header/Makefile2
-rw-r--r--www/pear-HTTP_Session/Makefile2
-rw-r--r--www/pear-HTTP_Session2/Makefile2
-rw-r--r--www/pear-HTTP_Upload/Makefile2
-rw-r--r--www/pecl-APC-devel/Makefile4
-rw-r--r--www/pecl-APC/Makefile4
11 files changed, 15 insertions, 15 deletions
diff --git a/devel/pear-HTML_Common/Makefile b/devel/pear-HTML_Common/Makefile
index fe14cf60ee48..676f005c1c04 100644
--- a/devel/pear-HTML_Common/Makefile
+++ b/devel/pear-HTML_Common/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
do-install:
@${MKDIR} ${PEARDIR}/HTML
diff --git a/devel/pear-apd/Makefile b/devel/pear-apd/Makefile
index 0056c95dde2d..65a9700ff0fb 100644
--- a/devel/pear-apd/Makefile
+++ b/devel/pear-apd/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apd
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
diff --git a/net/pear-Net_NNTP/Makefile b/net/pear-Net_NNTP/Makefile
index 93562c5b07fd..6bcb3d15a2ad 100644
--- a/net/pear-Net_NNTP/Makefile
+++ b/net/pear-Net_NNTP/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
LIB_FILES= NNTP/Realtime.php NNTP/Protocol.php NNTP/Header.php NNTP/Message.php
PORTDOCS= README
diff --git a/www/pear-APC/Makefile b/www/pear-APC/Makefile
index e5fa8bd38da5..7396299260d7 100644
--- a/www/pear-APC/Makefile
+++ b/www/pear-APC/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
diff --git a/www/pear-HTTP/Makefile b/www/pear-HTTP/Makefile
index bdcd65fd90ed..95111cfe8c36 100644
--- a/www/pear-HTTP/Makefile
+++ b/www/pear-HTTP/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
do-install:
@${CP} ${WRKSRC}/HTTP.php ${PEARDIR}
diff --git a/www/pear-HTTP_Header/Makefile b/www/pear-HTTP_Header/Makefile
index 294f331c275e..7c388eb1c124 100644
--- a/www/pear-HTTP_Header/Makefile
+++ b/www/pear-HTTP_Header/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS} \
${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pear-HTTP_Session/Makefile b/www/pear-HTTP_Session/Makefile
index ba9efc793dd2..5b94c8a269f0 100644
--- a/www/pear-HTTP_Session/Makefile
+++ b/www/pear-HTTP_Session/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pear-HTTP_Session2/Makefile b/www/pear-HTTP_Session2/Makefile
index ba9efc793dd2..5b94c8a269f0 100644
--- a/www/pear-HTTP_Session2/Makefile
+++ b/www/pear-HTTP_Session2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pear-HTTP_Upload/Makefile b/www/pear-HTTP_Upload/Makefile
index bb76d459f820..5bafc4824ccf 100644
--- a/www/pear-HTTP_Upload/Makefile
+++ b/www/pear-HTTP_Upload/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pecl-APC-devel/Makefile b/www/pecl-APC-devel/Makefile
index e5fa8bd38da5..7396299260d7 100644
--- a/www/pecl-APC-devel/Makefile
+++ b/www/pecl-APC-devel/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index e5fa8bd38da5..7396299260d7 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \