aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2004-02-02 00:19:27 +0800
committerlev <lev@FreeBSD.org>2004-02-02 00:19:27 +0800
commit2ccc3e818542009b0933de8bf804c43bb81eb29b (patch)
tree88bacb653246bd6c603fc133eb1d6bce025282ca
parentd61a89291a78b0428958cb5bcad655fa1938dc48 (diff)
downloadfreebsd-ports-gnome-2ccc3e818542009b0933de8bf804c43bb81eb29b.tar.gz
freebsd-ports-gnome-2ccc3e818542009b0933de8bf804c43bb81eb29b.tar.zst
freebsd-ports-gnome-2ccc3e818542009b0933de8bf804c43bb81eb29b.zip
Add xwelltris, Tetris-like game for X11.
-rw-r--r--games/Makefile1
-rw-r--r--games/xwelltris/Makefile31
-rw-r--r--games/xwelltris/distinfo2
-rw-r--r--games/xwelltris/files/patch-src::image::picinfo.h12
-rw-r--r--games/xwelltris/pkg-descr16
5 files changed, 62 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ebce470b2c1c..ff81bee4c71e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -583,6 +583,7 @@
SUBDIR += xvier
SUBDIR += xvmahjongg
SUBDIR += xvmines
+ SUBDIR += xwelltris
SUBDIR += xword
SUBDIR += xworm
SUBDIR += xzip
diff --git a/games/xwelltris/Makefile b/games/xwelltris/Makefile
new file mode 100644
index 000000000000..31246159676e
--- /dev/null
+++ b/games/xwelltris/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xwelltris
+# Date created: 1 Feb 2004
+# Whom: lev
+#
+# $FreeBSD$
+#
+
+PORTNAME= xwelltris
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.xnc.dubna.su/xwelltris/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= lev@FreeBSD.org
+COMMENT= 3D Tetris, blockout-like game
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_SIZE= yes
+PLIST_FILES= bin/xwelltris \
+ share/xwelltris/board2.gif \
+ share/xwelltris/font2.gif \
+ share/xwelltris/polyomino.dat \
+ share/xwelltris/topnine.gif \
+ share/xwelltris/wellcuts.gif \
+ share/xwelltris/wellintro.gif \
+ share/xwelltris/welltris.scores
+PLIST_DIRS= share/xwelltris
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+
+.include <bsd.port.mk>
diff --git a/games/xwelltris/distinfo b/games/xwelltris/distinfo
new file mode 100644
index 000000000000..0b0ad4bf4e2e
--- /dev/null
+++ b/games/xwelltris/distinfo
@@ -0,0 +1,2 @@
+MD5 (xwelltris-1.0.1.src.tar.gz) = 8730c2009244df113200b06c9e6b9885
+SIZE (xwelltris-1.0.1.src.tar.gz) = 422822
diff --git a/games/xwelltris/files/patch-src::image::picinfo.h b/games/xwelltris/files/patch-src::image::picinfo.h
new file mode 100644
index 000000000000..73922b29823f
--- /dev/null
+++ b/games/xwelltris/files/patch-src::image::picinfo.h
@@ -0,0 +1,12 @@
+--- src/image/picinfo.h.orig Sat Jan 31 16:49:01 2004
++++ src/image/picinfo.h Sat Jan 31 16:49:59 2004
+@@ -11,8 +11,7 @@
+ #include <string.h>
+ #include <sys/param.h>
+ #include <sys/types.h>
+-#ifndef __FreeBSD__
+-#elif ! defined __OpenBSD__
++#if ! defined __OpenBSD__ && ! defined __FreeBSD__
+ #include <malloc.h>
+ #endif
+ #include <fcntl.h>
diff --git a/games/xwelltris/pkg-descr b/games/xwelltris/pkg-descr
new file mode 100644
index 000000000000..c816ce7c1d4f
--- /dev/null
+++ b/games/xwelltris/pkg-descr
@@ -0,0 +1,16 @@
+XWelltris is a tetris like popular game.
+
+ Imaging that you are looking into the glass from the top. You see four
+walls and the bottom. The flat 2d figures falling down from the walls one
+by one. You can move these figures from one wall to another or rotate them.
+If the figure leave the wall then it moves on the bottom while another
+figure is pushed. You need to form full rows and/or columns on the bottom.
+When you form such row, it disappear and you receive additional empty space
+on the bottom and scores :). The more rows disappear at a time, the more
+scores you have. If you can't place the whole figure on the bottom, then it
+stays on the wall and this wall became frozen (you can't place figures on
+it) for a while. After nth rows were successfully cleared, you will receive
+bonus figure and go to to the next level - game speed will be increased.
+Your task is to play more longer and earn more scores.
+
+WWW: http://www.xnc.dubna.su/xwelltris/