aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2005-03-13 05:45:29 +0800
committerbland <bland@FreeBSD.org>2005-03-13 05:45:29 +0800
commit2d7967f5cc49fc3194a7a846b6e395dfc2235e7d (patch)
tree00ee0e602817575349371bdc0e2ac131b6bfcebd
parentbb18c40505a935d2130da206a4564ec84f470666 (diff)
downloadfreebsd-ports-gnome-2d7967f5cc49fc3194a7a846b6e395dfc2235e7d.tar.gz
freebsd-ports-gnome-2d7967f5cc49fc3194a7a846b6e395dfc2235e7d.tar.zst
freebsd-ports-gnome-2d7967f5cc49fc3194a7a846b6e395dfc2235e7d.zip
Restore WITHOUT_PYTHON knob.
-rw-r--r--devel/libglade2/Makefile22
-rw-r--r--devel/libglade2/pkg-plist2
2 files changed, 18 insertions, 6 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index 1189bceee5ea..fcbace52f556 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libglade2
PORTVERSION= 2.5.1
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.5
@@ -16,15 +17,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME glade library
-BUILD_DEPENDS= ${PYEXPAT}
-RUN_DEPENDS= ${PYEXPAT} \
- xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
+RUN_DEPENDS= xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
-USE_PYTHON= yes
USE_LIBTOOL_VER=15
USE_GNOME= gnomehack libxml2 gtk20
INSTALLS_SHLIB= yes
@@ -37,4 +34,19 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_SUB= XMLCATALOG="${LOCALBASE}/bin/xmlcatalog" \
CATALOG_PORTS_XML="${LOCALBASE}/share/xml/catalog.ports"
+.if !defined(WITHOUT_PYTHON)
+BUILD_DEPENDS+= ${PYEXPAT}
+RUN_DEPENDS+= ${PYEXPAT}
+
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+.else
+USE_REINPLACE= yes
+PLIST_SUB+= PYTHON="@comment "
+
+post-patch:
+ @${REINPLACE_CMD} -E 's/in (python.*)+ none/in none/' \
+ ${WRKSRC}/configure
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libglade2/pkg-plist b/devel/libglade2/pkg-plist
index cba156fe6624..588f41a86546 100644
--- a/devel/libglade2/pkg-plist
+++ b/devel/libglade2/pkg-plist
@@ -1,4 +1,4 @@
-bin/libglade-convert
+%%PYTHON%%bin/libglade-convert
include/libglade-2.0/glade/glade-build.h
include/libglade-2.0/glade/glade-init.h
include/libglade-2.0/glade/glade-parser.h