aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-20 00:08:33 +0800
committertrevor <trevor@FreeBSD.org>2003-11-20 00:08:33 +0800
commit2dbb41c3ad680b815aad624fa56069443a91812f (patch)
treec214c60734fc80a417c36584537131cca1613d16
parent7563fb4ab6b985cc02fdc94a41fbe423d0905485 (diff)
downloadfreebsd-ports-gnome-2dbb41c3ad680b815aad624fa56069443a91812f.tar.gz
freebsd-ports-gnome-2dbb41c3ad680b815aad624fa56069443a91812f.tar.zst
freebsd-ports-gnome-2dbb41c3ad680b815aad624fa56069443a91812f.zip
new Linux/i386 binary port of XFree86 libraries
-rw-r--r--x11/Makefile1
-rw-r--r--x11/linux-XFree86-libs/Makefile39
-rw-r--r--x11/linux-XFree86-libs/distinfo.i3862
-rw-r--r--x11/linux-XFree86-libs/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 10cd7294f555..cac67eec910c 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -76,6 +76,7 @@
SUBDIR += libxfce4mcs
SUBDIR += libxfce4util
SUBDIR += libxklavier
+ SUBDIR += linux-XFree86-libs
SUBDIR += linux-gnomelibs
SUBDIR += login.app
SUBDIR += lupe
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
new file mode 100644
index 000000000000..58ab56bb42af
--- /dev/null
+++ b/x11/linux-XFree86-libs/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: linux-XFree86-libs
+# Date created: 2003-11-19
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= XFree86-libs
+PORTVERSION= 4.3.0
+PORTREVISION= 0
+CATEGORIES= x11 linux
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
+MASTER_SITE_SUBDIR= updates/9/en/os/i386
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= XFree86 libraries, Linux/i386 binary
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+
+BASEVERSION= 9
+ONLY_FOR_ARCHS= i386
+PLIST= ${WRKDIR}/plist
+RPM_SET= XFree86-libs-4.3.0-2.90.43.i386.rpm
+
+pre-install:
+ ${RM} -rf ${WRKSRC}/tmp
+ ${MKDIR} ${WRKSRC}/tmp
+ cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ ${FIND} * -type f -o -type l > ${PLIST}
+.for ii in \
+ usr/X11R6/lib/X11/locale/lib/common \
+ usr/X11R6/lib/X11/locale/lib \
+ usr/X11R6/lib/X11/locale \
+ usr/X11R6/lib/X11
+ ${ECHO_CMD} @dirrm ${ii} >> ${PLIST}
+.endfor
+
+.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/x11/linux-XFree86-libs/distinfo.i386 b/x11/linux-XFree86-libs/distinfo.i386
new file mode 100644
index 000000000000..fec758bd16d7
--- /dev/null
+++ b/x11/linux-XFree86-libs/distinfo.i386
@@ -0,0 +1,2 @@
+$FreeBSD$
+MD5 (rpm/XFree86-libs-4.3.0-2.90.43.i386.rpm) = d3b427915a56fcf2a4de2a26266f7903
diff --git a/x11/linux-XFree86-libs/pkg-descr b/x11/linux-XFree86-libs/pkg-descr
new file mode 100644
index 000000000000..a249e2c48b40
--- /dev/null
+++ b/x11/linux-XFree86-libs/pkg-descr
@@ -0,0 +1,4 @@
+This is a Linux/i386 binary port of the libraries from XFree86, "a freely
+redistributable open-source implementation of X11."
+
+WWW: http://xfree86.org