aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-07-15 14:41:07 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-07-15 14:41:07 +0800
commit2e62fde15d45d2ebc77e786d8f418f00cbbd8bd2 (patch)
tree49fc4fb0b2bbc98a632fb120185aa9a58111872d
parentc3d031988e6c78ec6faf46b1c32e020c418d36fa (diff)
downloadfreebsd-ports-gnome-2e62fde15d45d2ebc77e786d8f418f00cbbd8bd2.tar.gz
freebsd-ports-gnome-2e62fde15d45d2ebc77e786d8f418f00cbbd8bd2.tar.zst
freebsd-ports-gnome-2e62fde15d45d2ebc77e786d8f418f00cbbd8bd2.zip
- USE_RC_SUBR != yes
- portlint
-rw-r--r--sysutils/uptimec/Makefile12
-rw-r--r--sysutils/uptimec/files/uptimec.in (renamed from sysutils/uptimec/files/uptimec.sh.in)2
2 files changed, 7 insertions, 7 deletions
diff --git a/sysutils/uptimec/Makefile b/sysutils/uptimec/Makefile
index b5ce5523dac9..d3bcacd026d7 100644
--- a/sysutils/uptimec/Makefile
+++ b/sysutils/uptimec/Makefile
@@ -7,6 +7,7 @@
PORTNAME= uptimec
PORTVERSION= 0.2p5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.mrEriksson.net/downloads/ \
ftp://ftp.mrEriksson.net/pub/uptimec/
@@ -14,14 +15,14 @@ MASTER_SITES= http://www.mrEriksson.net/downloads/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Client for Uptime Project
-USE_RC_SUBR= yes
+USE_RC_SUBR= ${PORTNAME}
USE_GMAKE= yes
GNU_CONFIGURE= yes
-PLIST_FILES= sbin/uptimec etc/uptimecrc.sample etc/rc.d/uptimec.sh
+PLIST_FILES= sbin/uptimec etc/uptimecrc.sample
PORTDOCS= README ChangeLog INSTALL protocol.txt
-SUB_FILES= pkg-message uptimec.sh
+SUB_FILES= pkg-message
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
@@ -29,11 +30,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uptimec ${PREFIX}/sbin
${INSTALL_DATA} ${FILESDIR}/uptimecrc.sample ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${WRKDIR}/uptimec.sh ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
.endfor
.endif
diff --git a/sysutils/uptimec/files/uptimec.sh.in b/sysutils/uptimec/files/uptimec.in
index ec44abbfda5e..0b0a10b4c265 100644
--- a/sysutils/uptimec/files/uptimec.sh.in
+++ b/sysutils/uptimec/files/uptimec.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/sysutils/uptimec/files/Attic/uptimec.in,v 1.1 2009-07-15 06:41:07 pgollucci Exp $
#
# PROVIDE: uptimec