aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-03-25 03:32:45 +0800
committerpawel <pawel@FreeBSD.org>2013-03-25 03:32:45 +0800
commit2e71cd02ea36f2f316cd6806a800b51afef5bc8c (patch)
tree1a754cb162eb66270a1e7403460b2659247e30ec
parentd9d2519de63a975d3ecee400bdf2c95f5d35c5e3 (diff)
downloadfreebsd-ports-gnome-2e71cd02ea36f2f316cd6806a800b51afef5bc8c.tar.gz
freebsd-ports-gnome-2e71cd02ea36f2f316cd6806a800b51afef5bc8c.tar.zst
freebsd-ports-gnome-2e71cd02ea36f2f316cd6806a800b51afef5bc8c.zip
- Fix build after glib update [1]
- Fix few portlint warnings PR: ports/177134 [1] Submitted by: John Marino <draco@marino.st>
-rw-r--r--ftp/gwget/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index 034b27c4738e..78e37601cf32 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME wget front-end
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
OPTIONS_DEFINE= NOTIFY EPIPHANY
@@ -21,8 +21,8 @@ EPIPHANY_DESC= Epiphany extension
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_GNOME= gnomeprefix gnomehack gtk20 gconf2 libgnomeui \
- desktopfileutils
+USES= pathfix
+USE_GNOME= desktopfileutils gnomeprefix gtk20 gconf2 libgnomeui
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -32,8 +32,8 @@ GCONF_SCHEMAS= ${PORTNAME}.schemas
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNOFITY}
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+.if ${PORT_OPTIONS:MNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
.else
CONFIGURE_ARGS+= --disable-libnotify
@@ -49,6 +49,10 @@ CONFIGURE_ARGS+= --disable-epiphany-extension
PLIST_SUB+= EPIPHANY="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} 's|glib/gerror|glib|' \
+ ${WRKSRC}/src/gwget-application.h
+
post-install:
@-update-desktop-database