aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-04-09 09:49:10 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-04-09 09:49:10 +0800
commit2e968a2918006aecf7ef50e280a906a94a1a770b (patch)
treef1bc57133b8dfdacdef996e872aafeb1154f9f0f
parent31b09f84a9846f90a7e0a1ee3c60f3b0d6ab2765 (diff)
downloadfreebsd-ports-gnome-2e968a2918006aecf7ef50e280a906a94a1a770b.tar.gz
freebsd-ports-gnome-2e968a2918006aecf7ef50e280a906a94a1a770b.tar.zst
freebsd-ports-gnome-2e968a2918006aecf7ef50e280a906a94a1a770b.zip
Remove debugging leftover in release.
error: mm_request_receive: socket closed Obtained from: Upstream c7fe79ed7db427f1474e72b9f8b465901d61d3f6
-rw-r--r--security/openssh-portable/Makefile2
-rw-r--r--security/openssh-portable/files/patch-monitor_wrap.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index eb739540edca..d13620ef7210 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssh
DISTVERSION= 6.8p1
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security ipv6
MASTER_SITES= ${MASTER_SITE_OPENBSD}
diff --git a/security/openssh-portable/files/patch-monitor_wrap.c b/security/openssh-portable/files/patch-monitor_wrap.c
new file mode 100644
index 000000000000..67e0b979c138
--- /dev/null
+++ b/security/openssh-portable/files/patch-monitor_wrap.c
@@ -0,0 +1,16 @@
+diff --git a/monitor_wrap.c b/monitor_wrap.c
+index b379f05..d39d491 100644
+--- monitor_wrap.c
++++ monitor_wrap.c
+@@ -153,10 +153,8 @@ mm_request_receive(int sock, Buffer *m)
+ debug3("%s entering", __func__);
+
+ if (atomicio(read, sock, buf, sizeof(buf)) != sizeof(buf)) {
+- if (errno == EPIPE) {
+- error("%s: socket closed", __func__);
++ if (errno == EPIPE)
+ cleanup_exit(255);
+- }
+ fatal("%s: read: %s", __func__, strerror(errno));
+ }
+ msg_len = get_u32(buf);