aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2010-05-18 07:53:03 +0800
committersahil <sahil@FreeBSD.org>2010-05-18 07:53:03 +0800
commit2eb84237344665b2d7cdf500cb90cb37b558dfdc (patch)
treed6e9d4fe6f16b27c2d351ec82c529ec9090ad973
parent40457a44b3940f6711a7b98fbf3e17eb085ca54c (diff)
downloadfreebsd-ports-gnome-2eb84237344665b2d7cdf500cb90cb37b558dfdc.tar.gz
freebsd-ports-gnome-2eb84237344665b2d7cdf500cb90cb37b558dfdc.tar.zst
freebsd-ports-gnome-2eb84237344665b2d7cdf500cb90cb37b558dfdc.zip
spmfilter-clamav is a plugin for spmfilter that enables spmfilter
to check mails with the Clam AntiVirus open source toolkit for viruses. The major goal of this plugin is to provide an easy way for virus-scanning emails. If ClamAV detects malicious software like viruses the affected email is discarded by the plugin. Optionally notifications can be enabled to inform the recipients and sender (configurable) about the discarded message. WWW: http://www.spmfilter.org/ PR: ports/146182 Submitted by: Axel Steiner <ast at treibsand.com> Approved by: wxs@ (mentor)
-rw-r--r--mail/Makefile1
-rw-r--r--mail/spmfilter-clamav/Makefile49
-rw-r--r--mail/spmfilter-clamav/distinfo3
-rw-r--r--mail/spmfilter-clamav/pkg-descr9
-rw-r--r--mail/spmfilter-clamav/pkg-plist3
5 files changed, 65 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 766b89cfe44f..7d04529af969 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -646,6 +646,7 @@
SUBDIR += spamstats
SUBDIR += spfval
SUBDIR += spmfilter
+ SUBDIR += spmfilter-clamav
SUBDIR += spmfilter-spamassassin
SUBDIR += spruce
SUBDIR += sqlgrey
diff --git a/mail/spmfilter-clamav/Makefile b/mail/spmfilter-clamav/Makefile
new file mode 100644
index 000000000000..d6725feaa48d
--- /dev/null
+++ b/mail/spmfilter-clamav/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: spmfilter-clamav
+# Date created: 2010-04-30
+# Whom: Axel Steiner <ast@treibsand.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spmfilter-clamav
+PORTVERSION= 0.1.1
+CATEGORIES= mail
+MASTER_SITES= http://www.spmfilter.org/attachments/download/59/
+
+MAINTAINER= ast@treibsand.com
+COMMENT= ClamAV plugin for spmfilter
+
+BUILD_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
+
+RUN_DEPENDS= spmfilter>=0.4:${PORTSDIR}/mail/spmfilter
+
+USE_CMAKE= yes
+CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
+ -DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
+
+USE_LDCONFIG= ${PREFIX}/lib/spmfilter
+
+OPTIONS= DEBUG "Enable Debugging" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
+.endif
+
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|' \
+ ${WRKSRC}/cmake/Modules/SMFMacros.cmake
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}/contrib
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/contrib/virus-notify.txt ${DOCSDIR}/contrib
+.endif
+.include <bsd.port.post.mk>
diff --git a/mail/spmfilter-clamav/distinfo b/mail/spmfilter-clamav/distinfo
new file mode 100644
index 000000000000..fab5ad7820c9
--- /dev/null
+++ b/mail/spmfilter-clamav/distinfo
@@ -0,0 +1,3 @@
+MD5 (spmfilter-clamav-0.1.1.tar.gz) = 10e4151465ae7df00e7fc1dceb82d32b
+SHA256 (spmfilter-clamav-0.1.1.tar.gz) = 7b68b9b7347bf5787fe63da77e733c7a67c40c82d6c87760f8f5d658573dc8a9
+SIZE (spmfilter-clamav-0.1.1.tar.gz) = 9065
diff --git a/mail/spmfilter-clamav/pkg-descr b/mail/spmfilter-clamav/pkg-descr
new file mode 100644
index 000000000000..b77d9ab3bacc
--- /dev/null
+++ b/mail/spmfilter-clamav/pkg-descr
@@ -0,0 +1,9 @@
+spmfilter-clamav is a plugin for spmfilter that enables spmfilter
+to check mails with the Clam AntiVirus open source toolkit for
+viruses. The major goal of this plugin is to provide an easy way
+for virus-scanning emails. If ClamAV detects malicious software
+like viruses the affected email is discarded by the plugin.
+Optionally notifications can be enabled to inform the recipients
+and sender (configurable) about the discarded message.
+
+WWW: http://www.spmfilter.org/
diff --git a/mail/spmfilter-clamav/pkg-plist b/mail/spmfilter-clamav/pkg-plist
new file mode 100644
index 000000000000..933daee7d117
--- /dev/null
+++ b/mail/spmfilter-clamav/pkg-plist
@@ -0,0 +1,3 @@
+lib/spmfilter/libclamav.so
+lib/spmfilter/libclamav.so.0.1.1
+@dirrmtry lib/spmfilter