aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2009-11-06 13:18:58 +0800
committerache <ache@FreeBSD.org>2009-11-06 13:18:58 +0800
commit2ee93aa08ffef52de97d6a761ff1fdb28ea79f5e (patch)
tree83e4f0a819e52a6a73bc2fa40a2b25518e1f8e4a
parent7de1df3fcfec33eec8cc27a7ab45a9cfd4afb2a9 (diff)
downloadfreebsd-ports-gnome-2ee93aa08ffef52de97d6a761ff1fdb28ea79f5e.tar.gz
freebsd-ports-gnome-2ee93aa08ffef52de97d6a761ff1fdb28ea79f5e.tar.zst
freebsd-ports-gnome-2ee93aa08ffef52de97d6a761ff1fdb28ea79f5e.zip
For unknown reason bsd.port.mk's eval dislike ( and ) in the path, when
MASTER_SITE_BACKUP with ${MASTER_SITES:S/%SUBDIR%/${MASTER_SITE_SUBDIR}/} at the end and MASTER_SITE_OVERRIDE ?= ${MASTER_SITE_BACKUP} are used together in /etc/make.conf. So, use simple workaround: replace ( and ) by their URL-encoded %-codes. (There is the bug in that area still remains, but not fatal: the combination above don't understand properly ending :tags sometimes and tries mass fetching with ending :tags unstripped. Someone should look at that whole bsd.ports.mk/bsd.sites.mk mess) While I am here, slightly rearrange ending :tags.
-rw-r--r--archivers/unzip/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index bc9cc1c5654d..5ef946c432c1 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -8,9 +8,10 @@
PORTNAME= unzip
PORTVERSION= 6.0
CATEGORIES?= archivers
-MASTER_SITES= SF/infozip/UnZip%206.x%20(latest)/UnZip%20${PORTVERSION} \
- SF/infozip/UnZip%205.x%20and%20earlier/5.51:unreduce
+MASTER_SITES= SF/infozip/UnZip%206.x%20%28latest%29/UnZip%20${PORTVERSION}/:main \
+ SF/infozip/UnZip%205.x%20and%20earlier/5.51/:unreduce
DISTNAME= ${PORTNAME}60
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:main
MAINTAINER?= ache@FreeBSD.org
COMMENT?= List, test and extract compressed files in a ZIP archive
@@ -30,8 +31,8 @@ LOCAL_UNZIP= ${CFLAGS} -DACORN_FTYPE_NFS -DWILD_STOP_AT_DIR \
-DLARGE_FILE_SUPPORT
.if defined(WITH_UNZIP_UNREDUCE)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unreduce_full.zip:unreduce
-EXTRACT_ONLY= ${PORTNAME}60.tar.gz
+DISTFILES+= unreduce_full.zip:unreduce
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
LOCAL_UNZIP+= -DUSE_SMITH_CODE
.endif