diff options
author | danfe <danfe@FreeBSD.org> | 2007-07-10 22:06:51 +0800 |
---|---|---|
committer | danfe <danfe@FreeBSD.org> | 2007-07-10 22:06:51 +0800 |
commit | 2f9bdc6c971c7c45500e7704944135af81efd526 (patch) | |
tree | 7f7f0778304d04536888b152fe52cc0b62ad1eae | |
parent | fef4c1d1873e628c4f4ca3f1dad99be9d55e2833 (diff) | |
download | freebsd-ports-gnome-2f9bdc6c971c7c45500e7704944135af81efd526.tar.gz freebsd-ports-gnome-2f9bdc6c971c7c45500e7704944135af81efd526.tar.zst freebsd-ports-gnome-2f9bdc6c971c7c45500e7704944135af81efd526.zip |
- Enable SSL by default in www/lynx
- Unregister CONFLICTS with lynx-ssl
- Canonicalize Makefile header
- s/=\?/=/ since no longer master port
- Deorbit www/lynx-ssl
Approved by: maintainer
-rw-r--r-- | MOVED | 1 | ||||
-rw-r--r-- | www/Makefile | 1 | ||||
-rw-r--r-- | www/lynx-ssl/Makefile | 21 | ||||
-rw-r--r-- | www/lynx-ssl/pkg-descr | 7 | ||||
-rw-r--r-- | www/lynx/Makefile | 15 |
5 files changed, 9 insertions, 36 deletions
@@ -3096,3 +3096,4 @@ net/py-rrdpipe|databases/py-rrdpipe|2007-07-08|Chase move of databases/rrdtool net/php5-rrdtool|databases/php5-rrdtool|2007-07-08|Chase move of databases/rrdtool textproc/ruby-spreadsheet-excel|textproc/rubygem-spreadsheet-excel|2007-07-09|Port updated in rubygem version net/gnet-glib2|net/gnet2|2007-07-09|Functionality merged into gnet2 +www/lynx-ssl|www/lynx|2007-07-10|SSL enabled by default in www/lynx diff --git a/www/Makefile b/www/Makefile index a37b3122c4d8..fd41a2f103d9 100644 --- a/www/Makefile +++ b/www/Makefile @@ -284,7 +284,6 @@ SUBDIR += lws SUBDIR += lynx SUBDIR += lynx-current - SUBDIR += lynx-ssl SUBDIR += mambo SUBDIR += man2web SUBDIR += mapedit diff --git a/www/lynx-ssl/Makefile b/www/lynx-ssl/Makefile deleted file mode 100644 index 7af91fb4ba3a..000000000000 --- a/www/lynx-ssl/Makefile +++ /dev/null @@ -1,21 +0,0 @@ -# New ports collection makefile for: lynx -# Date created: 15 Dec 1994 -# Whom: Stefan `Sec` Zehl <sec@42.org> -# -# $FreeBSD$ -# - -PKGNAMESUFFIX= -ssl - -COMMENT= A non-graphical, text-based World-Wide Web client with SSL support - -MASTERDIR= ${.CURDIR}/../lynx -DESCR= ${.CURDIR}/pkg-descr - -CONFIGURE_ARGS+= --with-ssl -CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${OPENSSLINC}" - -CONFLICTS= lynx-2* lynx-current* -USE_OPENSSL= yes - -.include "${MASTERDIR}/Makefile" diff --git a/www/lynx-ssl/pkg-descr b/www/lynx-ssl/pkg-descr deleted file mode 100644 index 6b8a6ddb051f..000000000000 --- a/www/lynx-ssl/pkg-descr +++ /dev/null @@ -1,7 +0,0 @@ -lynx is a program which allows a user to access World-Wide Web servers -and other information servers. It uses only ascii representation so -that it can be used from ascii-terminals and dial-in lines. - -WWW: http://lynx.isc.org/ - -This version compiles with ssl enabled to access pages via https. diff --git a/www/lynx/Makefile b/www/lynx/Makefile index 704bc2373484..05503fb6bb5f 100644 --- a/www/lynx/Makefile +++ b/www/lynx/Makefile @@ -1,6 +1,6 @@ -# New ports collection makefile for: lynx -# Date created: 15 Dec 1994 -# Whom: ache +# New ports collection makefile for: lynx +# Date created: 15 Dec 1994 +# Whom: Andrey Chernov <ache@FreeBSD.org> # # $FreeBSD$ # @@ -13,17 +13,18 @@ MASTER_SITES= http://lynx.isc.org/current/ \ ftp://lynx.isc.org/lynx${PORTVERSION}/patches/:patches DISTNAME= ${PORTNAME}${PORTVERSION:R}rel.${PORTVERSION:E} -MAINTAINER?= jharris@widomaker.com -COMMENT?= A non-graphical, text-based World-Wide Web client +MAINTAINER= jharris@widomaker.com +COMMENT= A non-graphical, text-based World-Wide Web client -CONFLICTS?= lynx-ssl* lynx-current* +CONFLICTS= lynx-current* USE_BZIP2= yes USE_ICONV= yes +USE_OPENSSL= yes WRKSRC= ${WRKDIR}/${PORTNAME}2-8-6 GNU_CONFIGURE= yes CONFIGURE_ARGS+=--with-screen=ncurses --with-zlib --libdir="${L_LIB}" \ - --enable-nsl-fork --enable-persistent-cookies \ + --enable-nsl-fork --enable-persistent-cookies --with-ssl \ --with-curses-dir=/usr --with-libiconv-prefix="${LOCALBASE}" .if defined(WITHOUT_NLS) |