aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-16 04:03:11 +0800
committerpav <pav@FreeBSD.org>2005-01-16 04:03:11 +0800
commit300795a6599be4bf7350e3d9401802964db314fc (patch)
tree325a84efa10a57e929c80ef0588343910e11213d
parent6427f2784f58250eeb2508b2bbea10ad140454e7 (diff)
downloadfreebsd-ports-gnome-300795a6599be4bf7350e3d9401802964db314fc.tar.gz
freebsd-ports-gnome-300795a6599be4bf7350e3d9401802964db314fc.tar.zst
freebsd-ports-gnome-300795a6599be4bf7350e3d9401802964db314fc.zip
cgprof generates colored graphs for profiled executables using gcc and gprof.
cgprof helps to have a better understanding of program structure and execution. It makes hot spots identification visual and intuitive. It is a shell script using gnu awk, that should run on any Unix like system. PR: ports/75173 Submitted by: Adam McLaurin <adam.freebsd@fastmail.fm>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cgprof/Makefile25
-rw-r--r--devel/cgprof/distinfo2
-rw-r--r--devel/cgprof/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cf1223990383..125f7a5a88d4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -113,6 +113,7 @@
SUBDIR += cedet-emacs20
SUBDIR += cflow
SUBDIR += cflow2vcg
+ SUBDIR += cgprof
SUBDIR += chora
SUBDIR += cil
SUBDIR += cl-asdf
diff --git a/devel/cgprof/Makefile b/devel/cgprof/Makefile
new file mode 100644
index 000000000000..c4cd27513ed4
--- /dev/null
+++ b/devel/cgprof/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cgprof
+# Date created: 16 December 2004
+# Whom: Adam McLaurin
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgprof
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://mvertes.free.fr/download/
+
+MAINTAINER= adam.freebsd@fastmail.fm
+COMMENT= Generates colored graphs for profiled executables using gcc and gprof
+
+RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
+ dotty:${PORTSDIR}/graphics/graphviz
+
+NO_BUILD= yes
+MAKE_ENV= prefix=${PREFIX}
+
+MAN1= cgprof.1
+PLIST_FILES= bin/cgprof
+
+.include <bsd.port.mk>
diff --git a/devel/cgprof/distinfo b/devel/cgprof/distinfo
new file mode 100644
index 000000000000..57f42bff00fa
--- /dev/null
+++ b/devel/cgprof/distinfo
@@ -0,0 +1,2 @@
+MD5 (cgprof-1.2.tar.gz) = dcf9f91367fb348f56bb816e0732e500
+SIZE (cgprof-1.2.tar.gz) = 17458
diff --git a/devel/cgprof/pkg-descr b/devel/cgprof/pkg-descr
new file mode 100644
index 000000000000..cbcb2eaa2482
--- /dev/null
+++ b/devel/cgprof/pkg-descr
@@ -0,0 +1,6 @@
+cgprof generates colored graphs for profiled executables using gcc and gprof.
+cgprof helps to have a better understanding of program structure and execution.
+It makes hot spots identification visual and intuitive.
+It is a shell script using gnu awk, that should run on any Unix like system.
+
+WWW: http://mvertes.free.fr/