aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2012-02-19 12:23:57 +0800
committersobomax <sobomax@FreeBSD.org>2012-02-19 12:23:57 +0800
commit311ba0855cb23544c32615d7a40473e2eab4076e (patch)
tree110a843c82f3e9ae197624c4e93b103001e51c76
parentf36368e85d8656666d394d3e6e7b4e81d14e648b (diff)
downloadfreebsd-ports-gnome-311ba0855cb23544c32615d7a40473e2eab4076e.tar.gz
freebsd-ports-gnome-311ba0855cb23544c32615d7a40473e2eab4076e.tar.zst
freebsd-ports-gnome-311ba0855cb23544c32615d7a40473e2eab4076e.zip
Add patch that allows package to work with Python 2.6 and 2.7. Obtained
from the vendor.
-rw-r--r--devel/py-dal/Makefile4
-rw-r--r--devel/py-dal/files/patch-dal_dbapi_db__row.py13
2 files changed, 15 insertions, 2 deletions
diff --git a/devel/py-dal/Makefile b/devel/py-dal/Makefile
index 388efdc44012..3c0564b807da 100644
--- a/devel/py-dal/Makefile
+++ b/devel/py-dal/Makefile
@@ -7,9 +7,9 @@
PORTNAME= dal
PORTVERSION= 20081016
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
-MASTER_SITES= http://devel.sippysoft.com:8080/~bamby/
+MASTER_SITES= http://download.sippysoft.com/bamby/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= bamby@sippysoft.com
diff --git a/devel/py-dal/files/patch-dal_dbapi_db__row.py b/devel/py-dal/files/patch-dal_dbapi_db__row.py
new file mode 100644
index 000000000000..d1a704795fdb
--- /dev/null
+++ b/devel/py-dal/files/patch-dal_dbapi_db__row.py
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- dal/dbapi/db_row.py
++++ dal/dbapi/db_row.py
+@@ -699,7 +699,6 @@
+ assert '__init__' not in cls_dict
+
+ def __init__(self, fields):
+- super(row_class, self).__init__(fields)
+ self.fields = field_class(fields)
+
+ row_class.__init__ = __init__