aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-11-06 06:03:48 +0800
committertota <tota@FreeBSD.org>2012-11-06 06:03:48 +0800
commit31ce99dc4704c33de0733cd001e162ce3f5ca99f (patch)
tree44f9f55bb19d5a6509d66d1650a998cfe9e2f5a2
parentbac9589ef375dff15e0115009601290304d58220 (diff)
downloadfreebsd-ports-gnome-31ce99dc4704c33de0733cd001e162ce3f5ca99f.tar.gz
freebsd-ports-gnome-31ce99dc4704c33de0733cd001e162ce3f5ca99f.tar.zst
freebsd-ports-gnome-31ce99dc4704c33de0733cd001e162ce3f5ca99f.zip
- Add missing PHP extensions
- Remove specific ABI version number from LIB_DEPENDS - Convert to new Makefile header - Bump PORTREVISION PR: ports/173367 (based on) Submitted by: tota (myself) Approved by: Bo-Yi Wu (maintainer) Feature safe: yes
-rw-r--r--www/gallery3/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index 9be635c51371..237a8e05f2a9 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: gallery3
-# Date created: 16 June 2009
-# Whom: Bo-Yi Wu <appleboy.tw@gmail.com>
-#
+# Created by: Bo-Yi Wu <appleboy.tw@gmail.com>
# $FreeBSD$
-#
PORTNAME= gallery3
PORTVERSION= 3.0.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/gallery/${PORTNAME}/${PORTVERSION}
DISTNAME= gallery-${PORTVERSION}
@@ -16,8 +13,8 @@ COMMENT= Web based photo album organizer written in PHP
USE_ZIP= yes
-USE_PHP= pcre session filter xml iconv spl simplexml json mysql \
- tokenizer
+USE_PHP= ctype filter iconv json mysql mbstring pcre \
+ simplexml session spl tokenizer xml
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -47,7 +44,7 @@ RUN_DEPENDS+= dcraw:${PORTSDIR}/graphics/dcraw
.endif
.if defined(WITH_FFMPEG)
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
.endif
.if defined(WITH_GD)