aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-25 18:18:14 +0800
committermiwi <miwi@FreeBSD.org>2011-06-25 18:18:14 +0800
commit321fc9c6cc0c7c131844168da07ba38e9f3ce639 (patch)
treebde0e806572ed3699f5527dd8a74388f48b1f962
parent1f5ac5aa6d2071ca1cf379f98e16bf3923d349af (diff)
downloadfreebsd-ports-gnome-321fc9c6cc0c7c131844168da07ba38e9f3ce639.tar.gz
freebsd-ports-gnome-321fc9c6cc0c7c131844168da07ba38e9f3ce639.tar.zst
freebsd-ports-gnome-321fc9c6cc0c7c131844168da07ba38e9f3ce639.zip
Belier allows opening a shell or executing a command on a remote computer
through a SSH connection. The main feature of Belier is its ability to cross several intermediate computers before realizing the job. WWW: http://www.ohmytux.com/belier/index.html PR: ports/156757 Submitted by: rokaz
-rw-r--r--security/Makefile1
-rw-r--r--security/belier/Makefile41
-rw-r--r--security/belier/distinfo2
-rw-r--r--security/belier/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9ddb65bd9f3f..7e7123c72795 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -34,6 +34,7 @@
SUBDIR += bcwipe
SUBDIR += bdc
SUBDIR += beecrypt
+ SUBDIR += belier
SUBDIR += bfbtester
SUBDIR += bioapi
SUBDIR += blindelephant
diff --git a/security/belier/Makefile b/security/belier/Makefile
new file mode 100644
index 000000000000..50aab664667b
--- /dev/null
+++ b/security/belier/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: belier
+# Date created: 1 May 2011
+# Whom: rokaz
+#
+# $FreeBSD$
+#
+
+PORTNAME= belier
+PORTVERSION= 1.2
+CATEGORIES= security net
+MASTER_SITES= http://www.ohmytux.com/belier/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= romain.garbage@gmail.com
+COMMENT= easily cross several machines with ssh
+
+RUN_DEPENDS= expect>=5.42.1:${PORTSDIR}/lang/expect
+
+PLIST_FILES= lib/${PYTHON_VERSION}/site-packages/belier/corps.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/terminal.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/options.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/corps.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/__init__.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/optionstunnel.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/terminal.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/__init__.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/corps.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/optionstunnel.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/terminal.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/options.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/__init__.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/options.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/optionstunnel.pyo \
+ bin/bel \
+ share/locale/fr/LC_MESSAGES/bel.mo
+PLIST_DIRS= lib/${PYTHON_VERSION}/site-packages/belier
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/security/belier/distinfo b/security/belier/distinfo
new file mode 100644
index 000000000000..a11dd824a071
--- /dev/null
+++ b/security/belier/distinfo
@@ -0,0 +1,2 @@
+SHA256 (belier-1.2.tar.gz) = 9fe20425d0e061112c38288ce105bc7905a55c22836e801b310541b56e4df409
+SIZE (belier-1.2.tar.gz) = 9774
diff --git a/security/belier/pkg-descr b/security/belier/pkg-descr
new file mode 100644
index 000000000000..a988f0787977
--- /dev/null
+++ b/security/belier/pkg-descr
@@ -0,0 +1,5 @@
+Belier allows opening a shell or executing a command on a remote computer
+through a SSH connection. The main feature of Belier is its ability to cross
+several intermediate computers before realizing the job.
+
+WWW: http://www.ohmytux.com/belier/index.html