aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-10-30 00:58:13 +0800
committernox <nox@FreeBSD.org>2011-10-30 00:58:13 +0800
commit3326c545928e80f11042ad5dfe4aad1ccc6a0c72 (patch)
tree61713710f93476e04db4c0e19509f84523f39e4d
parent6a5c707500e5e7d2a034b0890ef9ac0ff7a9a1f5 (diff)
downloadfreebsd-ports-gnome-3326c545928e80f11042ad5dfe4aad1ccc6a0c72.tar.gz
freebsd-ports-gnome-3326c545928e80f11042ad5dfe4aad1ccc6a0c72.tar.zst
freebsd-ports-gnome-3326c545928e80f11042ad5dfe4aad1ccc6a0c72.zip
libxine only builds with -O1 or higher, add a check to avoid more people
wondering about obscure build failures otherwise. PR: ports/162037 [1] (related to) Submitted by: Ilya Ermolin <ermolinis@gmail.com> [1]
-rw-r--r--multimedia/libxine/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 044217e83cd0..708389ff0c58 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -102,6 +102,11 @@ PATCH_DIST_ARGS= -d ${WRKSRC} -p1 --forward --quiet
DEBUG_FLAGS= -g -O1
.endif
+# Check for forced -O0 (or no -O)
+.if ${CFLAGS:M-O0} == "-O0" || (${CFLAGS:M-O} == "" && ${CFLAGS:M-O[1-9]} == "")
+IGNORE= only builds with -O1 or higher, check CFLAGS
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""