aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-09-11 22:32:13 +0800
committersobomax <sobomax@FreeBSD.org>2002-09-11 22:32:13 +0800
commit341c7341543a7f0fd44daf9be94d20e94668268d (patch)
treeeedcfd0cfc564c1914c5c1bfb3a706280a6086fd
parentbdb9a41df44b342effe0d73d2ca5a4dc7829990a (diff)
downloadfreebsd-ports-gnome-341c7341543a7f0fd44daf9be94d20e94668268d.tar.gz
freebsd-ports-gnome-341c7341543a7f0fd44daf9be94d20e94668268d.tar.zst
freebsd-ports-gnome-341c7341543a7f0fd44daf9be94d20e94668268d.zip
Since FreeBSD doesn't have unified eject command which works for
all types of removable media, use `cdcontrol eject' instead, because it will at least make the most popular removable media working.
-rw-r--r--x11-fm/nautilus2/Makefile2
-rw-r--r--x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c16
2 files changed, 15 insertions, 3 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index 6106194f50d6..899f14b73cc7 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nautilus2
PORTVERSION= 2.0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.1/sources/${PORTNAME:S/2$//}
diff --git a/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c b/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c
index 3d1bca830ca0..fbb9b3b47b47 100644
--- a/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c
+++ b/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c
@@ -1,5 +1,8 @@
---- libnautilus-private/nautilus-volume-monitor.c.orig Wed Aug 28 09:37:20 2002
-+++ libnautilus-private/nautilus-volume-monitor.c Wed Sep 11 02:04:23 2002
+
+$FreeBSD$
+
+--- libnautilus-private/nautilus-volume-monitor.c.orig Wed Aug 28 16:37:20 2002
++++ libnautilus-private/nautilus-volume-monitor.c Wed Sep 11 16:39:15 2002
@@ -59,6 +59,18 @@
#include <sys/types.h>
#include <unistd.h>
@@ -135,6 +138,15 @@
static gboolean
volume_is_removable (const NautilusVolume *volume)
+@@ -885,7 +924,7 @@
+ char *command;
+
+ if (path != NULL) {
+- command = g_strdup_printf ("eject %s", path);
++ command = g_strdup_printf ("/usr/sbin/cdcontrol -f %s eject", path);
+ eel_gnome_shell_execute (command);
+ g_free (command);
+ }
@@ -963,23 +1002,34 @@