aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2016-07-29 20:09:19 +0800
committerrm <rm@FreeBSD.org>2016-07-29 20:09:19 +0800
commit351141974df698d751d7bfe41f87a2ceb5dac570 (patch)
treedb9d1bb9b9dbbdeed60b725019405b6c28a0dbc0
parent5d73afc76a6c3a2a1ae672553d1fefc4083e0518 (diff)
downloadfreebsd-ports-gnome-351141974df698d751d7bfe41f87a2ceb5dac570.tar.gz
freebsd-ports-gnome-351141974df698d751d7bfe41f87a2ceb5dac570.tar.zst
freebsd-ports-gnome-351141974df698d751d7bfe41f87a2ceb5dac570.zip
This is a backport of the standard library typing module to Python
versions older than 3.5. Typing defines a standard notation for Python function and variable type annotations. The notation can be used for documenting code in a concise, standard format, and it has been designed to also be used by static and runtime type checkers, static analyzers, IDEs and other tools. WWW: https://pypi.python.org/pypi/typing
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-typing/Makefile19
-rw-r--r--devel/py-typing/distinfo3
-rw-r--r--devel/py-typing/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a038854d5612..92caa719dfcf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4510,6 +4510,7 @@
SUBDIR += py-twistedFlow
SUBDIR += py-twistedRunner
SUBDIR += py-txaio
+ SUBDIR += py-typing
SUBDIR += py-tzlocal
SUBDIR += py-ua_parser
SUBDIR += py-ujson
diff --git a/devel/py-typing/Makefile b/devel/py-typing/Makefile
new file mode 100644
index 000000000000..ed1022c83670
--- /dev/null
+++ b/devel/py-typing/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= typing
+PORTVERSION= 3.5.2.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Type Hints for Python
+
+LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USES= python:-3.4
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-typing/distinfo b/devel/py-typing/distinfo
new file mode 100644
index 000000000000..d35e12abffc7
--- /dev/null
+++ b/devel/py-typing/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469629456
+SHA256 (typing-3.5.2.2.tar.gz) = 2bce34292653af712963c877f3085250a336738e64f99048d1b8509bebc4772f
+SIZE (typing-3.5.2.2.tar.gz) = 51101
diff --git a/devel/py-typing/pkg-descr b/devel/py-typing/pkg-descr
new file mode 100644
index 000000000000..eda3df1f97ed
--- /dev/null
+++ b/devel/py-typing/pkg-descr
@@ -0,0 +1,8 @@
+This is a backport of the standard library typing module to Python
+versions older than 3.5.
+Typing defines a standard notation for Python function and variable type
+annotations. The notation can be used for documenting code in a concise,
+standard format, and it has been designed to also be used by static and
+runtime type checkers, static analyzers, IDEs and other tools.
+
+WWW: https://pypi.python.org/pypi/typing