aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-08-02 11:18:00 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-08-02 11:18:00 +0800
commit35a4aa9719a65dd62b2ec2b5f38fd5b1ffe58fe7 (patch)
treec2e2cfd1df51992f8f7e75ed99888a004608c2bc
parent855bf36c99adebd881e509c6772aaaa660afcb55 (diff)
downloadfreebsd-ports-gnome-35a4aa9719a65dd62b2ec2b5f38fd5b1ffe58fe7.tar.gz
freebsd-ports-gnome-35a4aa9719a65dd62b2ec2b5f38fd5b1ffe58fe7.tar.zst
freebsd-ports-gnome-35a4aa9719a65dd62b2ec2b5f38fd5b1ffe58fe7.zip
- Add p5-Sub-Exporter-Progressive 0.001002
Sub::Exporter is an incredibly powerful module, but with that power comes great responsibility, er- as well as some runtime penalties. This module is a Sub::Exporter wrapper that will let your users just use Exporter if all they are doing is picking exports, but use Sub::Exporter if your users try to use Sub::Exporter's more advanced features features, like renaming exports, if they try to use them. Note that this module will export @EXPORT and @EXPORT_OK package variables for Exporter to work. Additionally, if your package uses advanced Sub::Exporter features like currying, this module will only ever use Sub::Exporter, so you might as well use it directly. WWW: http://search.cpan.org/dist/Sub-Exporter-Progressive/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Exporter-Progressive/Makefile28
-rw-r--r--devel/p5-Sub-Exporter-Progressive/distinfo2
-rw-r--r--devel/p5-Sub-Exporter-Progressive/pkg-descr13
-rw-r--r--devel/p5-Sub-Exporter-Progressive/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 58386d70c66d..8ffb42ebda74 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2491,6 +2491,7 @@
SUBDIR += p5-Sub-Exporter
SUBDIR += p5-Sub-Exporter-ForMethods
SUBDIR += p5-Sub-Exporter-GlobExporter
+ SUBDIR += p5-Sub-Exporter-Progressive
SUBDIR += p5-Sub-Identify
SUBDIR += p5-Sub-Install
SUBDIR += p5-Sub-Installer
diff --git a/devel/p5-Sub-Exporter-Progressive/Makefile b/devel/p5-Sub-Exporter-Progressive/Makefile
new file mode 100644
index 000000000000..f2214f02a1ab
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Progressive/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Sub-Exporter-Progressive
+# Date created: 2012-08-01
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Exporter-Progressive
+PORTVERSION= 0.001.002
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Only use Sub::Exporter if you need it
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Exporter::Progressive.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sub-Exporter-Progressive/distinfo b/devel/p5-Sub-Exporter-Progressive/distinfo
new file mode 100644
index 000000000000..4119c509f726
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Progressive/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Sub-Exporter-Progressive-0.001002.tar.gz) = 071c4f13766a5dadd3ad09e5e5634fe3d5835c7cba349d0e527957c80e63500d
+SIZE (Sub-Exporter-Progressive-0.001002.tar.gz) = 10664
diff --git a/devel/p5-Sub-Exporter-Progressive/pkg-descr b/devel/p5-Sub-Exporter-Progressive/pkg-descr
new file mode 100644
index 000000000000..90cb9f8db832
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Progressive/pkg-descr
@@ -0,0 +1,13 @@
+Sub::Exporter is an incredibly powerful module, but with that power comes great
+responsibility, er- as well as some runtime penalties. This module is a
+Sub::Exporter wrapper that will let your users just use Exporter if all they are
+doing is picking exports, but use Sub::Exporter if your users try to use
+Sub::Exporter's more advanced features features, like renaming exports, if they
+try to use them.
+
+Note that this module will export @EXPORT and @EXPORT_OK package variables for
+Exporter to work. Additionally, if your package uses advanced Sub::Exporter
+features like currying, this module will only ever use Sub::Exporter, so you
+might as well use it directly.
+
+WWW: http://search.cpan.org/dist/Sub-Exporter-Progressive/
diff --git a/devel/p5-Sub-Exporter-Progressive/pkg-plist b/devel/p5-Sub-Exporter-Progressive/pkg-plist
new file mode 100644
index 000000000000..93e90b583f1c
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Progressive/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Sub/Exporter/Progressive.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter/Progressive/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter/Progressive
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/Sub/Exporter
+@dirrmtry %%SITE_PERL%%/Sub