aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-11-23 21:33:44 +0800
committerwen <wen@FreeBSD.org>2009-11-23 21:33:44 +0800
commit35aa25a563c6990177c17abfa7d84c5f9534dffc (patch)
tree8f2068243496e00f95adf289355c7bb0be06ab93
parent63d14096516e27a8485d8878dea02bea142c3006 (diff)
downloadfreebsd-ports-gnome-35aa25a563c6990177c17abfa7d84c5f9534dffc.tar.gz
freebsd-ports-gnome-35aa25a563c6990177c17abfa7d84c5f9534dffc.tar.zst
freebsd-ports-gnome-35aa25a563c6990177c17abfa7d84c5f9534dffc.zip
The PyMongo distribution contains tools for interacting with
the Mongo database from Python. The pymongo package is a native Python driver for the Mongo database. The gridfs package is a gridfs implementation on top of pymongo. WWW: http://github.com/mongodb/mongo-python-driver
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pymongo/Makefile23
-rw-r--r--databases/pymongo/distinfo3
-rw-r--r--databases/pymongo/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 66d9cb28d194..676f3ee9e0b9 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -588,6 +588,7 @@
SUBDIR += py25-bsddb
SUBDIR += pydbdesigner
SUBDIR += pydbx
+ SUBDIR += pymongo
SUBDIR += qdbm
SUBDIR += qdbm-plus
SUBDIR += qt-ibase-plugin
diff --git a/databases/pymongo/Makefile b/databases/pymongo/Makefile
new file mode 100644
index 000000000000..dd933e8a81a8
--- /dev/null
+++ b/databases/pymongo/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: pymongo
+# Date created: 23 Nov, 2009
+# Whom: wen@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pymongo
+PORTVERSION= 1.1.1
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Python driver for MongoDB
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+PYDISTUTILS_NOEGGINFO= yes
+
+.include <bsd.port.mk>
diff --git a/databases/pymongo/distinfo b/databases/pymongo/distinfo
new file mode 100644
index 000000000000..4e498b8ee0d8
--- /dev/null
+++ b/databases/pymongo/distinfo
@@ -0,0 +1,3 @@
+MD5 (pymongo-1.1.1.tar.gz) = 631279fb113126e40535c66b95498a42
+SHA256 (pymongo-1.1.1.tar.gz) = ceb154ae3ca799ee8c9034c1de70fe99db895f5c3db6d5f82bf0605c8c993e60
+SIZE (pymongo-1.1.1.tar.gz) = 93994
diff --git a/databases/pymongo/pkg-descr b/databases/pymongo/pkg-descr
new file mode 100644
index 000000000000..c46dcbf865d4
--- /dev/null
+++ b/databases/pymongo/pkg-descr
@@ -0,0 +1,6 @@
+The PyMongo distribution contains tools for interacting with
+the Mongo database from Python. The pymongo package is a native
+Python driver for the Mongo database. The gridfs package is a
+gridfs implementation on top of pymongo.
+
+WWW: http://github.com/mongodb/mongo-python-driver