aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-28 16:26:23 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-28 16:26:23 +0800
commit35f785b8c5f2c0d7fa7e17f007522c1933d99afb (patch)
treeac29e3e08a82242deaceaae475f788f12d650f82
parent12c07c730b8746e4375ca35c214e62dff2e99460 (diff)
downloadfreebsd-ports-gnome-35f785b8c5f2c0d7fa7e17f007522c1933d99afb.tar.gz
freebsd-ports-gnome-35f785b8c5f2c0d7fa7e17f007522c1933d99afb.tar.zst
freebsd-ports-gnome-35f785b8c5f2c0d7fa7e17f007522c1933d99afb.zip
Add p5-Math-Combinatorics.
Combinatorics is the branch of mathematics studying the enumeration, combination, and permutation of sets of elements and the mathematical relations that characterize their properties. As a jumping off point, refer to: http://mathworld.wolfram.com/Combinatorics.html This module provides a pure-perl implementation of nCk, nPk, and n! (combination, permutation, and factorial, respectively). Author: Allen Day <allenday@ucla.edu> WWW: http://search.cpan.org/dist/Math-Combinatorics/ PR: ports/81572 Submitted by: Aaron Dalton <aaron@daltons.ca>
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Combinatorics/Makefile28
-rw-r--r--math/p5-Math-Combinatorics/distinfo2
-rw-r--r--math/p5-Math-Combinatorics/pkg-descr16
-rw-r--r--math/p5-Math-Combinatorics/pkg-plist5
5 files changed, 52 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8fec97e87584..9b79e5b425b6 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -148,6 +148,7 @@
SUBDIR += p5-Math-BigInt
SUBDIR += p5-Math-BigRat
SUBDIR += p5-Math-Calc-Units
+ SUBDIR += p5-Math-Combinatorics
SUBDIR += p5-Math-Currency
SUBDIR += p5-Math-Derivative
SUBDIR += p5-Math-Expr
diff --git a/math/p5-Math-Combinatorics/Makefile b/math/p5-Math-Combinatorics/Makefile
new file mode 100644
index 000000000000..af8c01c352c8
--- /dev/null
+++ b/math/p5-Math-Combinatorics/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Math-Combinatorics
+# Date created: 27 May 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Combinatorics
+PORTVERSION= 0.04
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Perform combinations and permutations on lists
+
+MAN3= Math::Combinatorics.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Perl 5.6 or greater required. Install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Combinatorics/distinfo b/math/p5-Math-Combinatorics/distinfo
new file mode 100644
index 000000000000..e37308f1031e
--- /dev/null
+++ b/math/p5-Math-Combinatorics/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-Combinatorics-0.04.tar.gz) = bb2db2b6cfff4188a6b14f218c2f8f21
+SIZE (Math-Combinatorics-0.04.tar.gz) = 6618
diff --git a/math/p5-Math-Combinatorics/pkg-descr b/math/p5-Math-Combinatorics/pkg-descr
new file mode 100644
index 000000000000..99b0e5168165
--- /dev/null
+++ b/math/p5-Math-Combinatorics/pkg-descr
@@ -0,0 +1,16 @@
+Combinatorics is the branch of mathematics studying the enumeration,
+combination, and permutation of sets of elements and the mathematical
+relations that characterize their properties. As a jumping off point,
+refer to:
+
+http://mathworld.wolfram.com/Combinatorics.html
+
+This module provides a pure-perl implementation of nCk, nPk, and n!
+(combination, permutation, and factorial, respectively).
+
+Author: Allen Day <allenday@ucla.edu>
+
+WWW: http://search.cpan.org/dist/Math-Combinatorics/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/math/p5-Math-Combinatorics/pkg-plist b/math/p5-Math-Combinatorics/pkg-plist
new file mode 100644
index 000000000000..0fa60ad08a34
--- /dev/null
+++ b/math/p5-Math-Combinatorics/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Combinatorics.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Combinatorics/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Combinatorics
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Math 2>/dev/null || true