aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-04 18:18:03 +0800
committermiwi <miwi@FreeBSD.org>2009-11-04 18:18:03 +0800
commit361ed93b0ba3f58244a7312d5ae34ffc06a5e9e0 (patch)
tree09d78a7fd81cc0b28e72188b627e854392f92fe7
parent1f2f4a69610ae71703db275ba9242e9604047f8b (diff)
downloadfreebsd-ports-gnome-361ed93b0ba3f58244a7312d5ae34ffc06a5e9e0.tar.gz
freebsd-ports-gnome-361ed93b0ba3f58244a7312d5ae34ffc06a5e9e0.tar.zst
freebsd-ports-gnome-361ed93b0ba3f58244a7312d5ae34ffc06a5e9e0.zip
GitTrac is a plugin for Trac which enables Git to be used instead of Subversion
as the VersioningSystemBackend for Trac. WWW: http://trac-hacks.org/wiki/GitPlugin PR: ports/140235 Submitted by: Douglas Thrift
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-gitplugin/Makefile34
-rw-r--r--www/trac-gitplugin/distinfo3
-rw-r--r--www/trac-gitplugin/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d81297597a61..5f4e5d29aa6f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1530,6 +1530,7 @@
SUBDIR += trac-email2trac
SUBDIR += trac-fullblog
SUBDIR += trac-gantt
+ SUBDIR += trac-gitplugin
SUBDIR += trac-graphviz
SUBDIR += trac-hierwiki
SUBDIR += trac-iniadmin
diff --git a/www/trac-gitplugin/Makefile b/www/trac-gitplugin/Makefile
new file mode 100644
index 000000000000..f4088eb01f15
--- /dev/null
+++ b/www/trac-gitplugin/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-gitplugin
+# Date created: 2 November 2009
+# Whom: Douglas Thrift
+#
+# $FreeBSD$
+#
+
+PORTNAME= gitplugin
+PORTVERSION= 0.11.0.2.7034
+CATEGORIES= www devel python
+MASTER_SITES= http://code.douglasthrift.net/files/${PORTNAME}/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}-r${PORTVERSION:E}
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Git plugin for Trac
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git \
+ tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+PYDISTUTILS_PKGNAME= TracGit
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:R}
+WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTVERSION:C/(.[0-9]+){3}$//}
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+pre-configure:
+ ${CHMOD} -R a+r ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/www/trac-gitplugin/distinfo b/www/trac-gitplugin/distinfo
new file mode 100644
index 000000000000..fe31fbc4a1cc
--- /dev/null
+++ b/www/trac-gitplugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (gitplugin-r7034.zip) = aa97d9343a43be86f1701375f9a90c1d
+SHA256 (gitplugin-r7034.zip) = 1ece50a8a0870e860af24d6d91da7d6140f0a716ba79856514a6fd8532d152ab
+SIZE (gitplugin-r7034.zip) = 32645
diff --git a/www/trac-gitplugin/pkg-descr b/www/trac-gitplugin/pkg-descr
new file mode 100644
index 000000000000..77c818d18576
--- /dev/null
+++ b/www/trac-gitplugin/pkg-descr
@@ -0,0 +1,4 @@
+GitTrac is a plugin for Trac which enables Git to be used instead of Subversion
+as the VersioningSystemBackend for Trac.
+
+WWW: http://trac-hacks.org/wiki/GitPlugin