aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-04-06 03:59:22 +0800
committerjrm <jrm@FreeBSD.org>2017-04-06 03:59:22 +0800
commit37eab7a636aa8ec34064f1c71737c4e926361164 (patch)
tree3445401470c9a97a4f9b6c099c6577bf8d462777
parentc55f318f50f9f77a62174bc558099dbde5093402 (diff)
downloadfreebsd-ports-gnome-37eab7a636aa8ec34064f1c71737c4e926361164.tar.gz
freebsd-ports-gnome-37eab7a636aa8ec34064f1c71737c4e926361164.tar.zst
freebsd-ports-gnome-37eab7a636aa8ec34064f1c71737c4e926361164.zip
New port, devel/rubygem-appraisal: Integrates with bundler and rake to test
library dependencies WWW: https://github.com/thoughtbot/appraisal/ Approved by: swills (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D10284
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-appraisal/Makefile25
-rw-r--r--devel/rubygem-appraisal/distinfo3
-rw-r--r--devel/rubygem-appraisal/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ef99e3dc6cd2..c7764e9e2edd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5116,6 +5116,7 @@
SUBDIR += rubygem-apipie-bindings
SUBDIR += rubygem-apipie-params
SUBDIR += rubygem-app_config
+ SUBDIR += rubygem-appraisal
SUBDIR += rubygem-arr-pm
SUBDIR += rubygem-arrayfields
SUBDIR += rubygem-ascii85
diff --git a/devel/rubygem-appraisal/Makefile b/devel/rubygem-appraisal/Makefile
new file mode 100644
index 000000000000..30dddbe9f8c5
--- /dev/null
+++ b/devel/rubygem-appraisal/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= appraisal
+PORTVERSION= 2.1.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Integrates with bundler and rake to test library dependencies
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-rake>=0:devel/rubygem-rake \
+ rubygem-bundler>=0:sysutils/rubygem-bundler \
+ rubygem-thor>=0.14.0:devel/rubygem-thor \
+ rubygem-activesupport5>0:devel/rubygem-activesupport5 \
+ rubygem-rspec>=3.0:devel/rubygem-rspec
+
+USE_RUBY= yes
+USES= gem
+
+PLIST_FILES= bin/appraisal
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-appraisal/distinfo b/devel/rubygem-appraisal/distinfo
new file mode 100644
index 000000000000..4f45df5f5822
--- /dev/null
+++ b/devel/rubygem-appraisal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491421131
+SHA256 (rubygem/appraisal-2.1.0.gem) = 77135863db8a1117e4cd77778e0591f26224f65b87450ee5f48d6b484100cf82
+SIZE (rubygem/appraisal-2.1.0.gem) = 24064
diff --git a/devel/rubygem-appraisal/pkg-descr b/devel/rubygem-appraisal/pkg-descr
new file mode 100644
index 000000000000..f24265f1e8a3
--- /dev/null
+++ b/devel/rubygem-appraisal/pkg-descr
@@ -0,0 +1,6 @@
+Appraisal integrates with bundler and rake to test your library against
+different versions of dependencies in repeatable scenarios called "appraisals."
+Appraisal is designed to make it easy to check for regressions in your library
+without interfering with day-to-day development using Bundler.
+
+WWW: http://github.com/thoughtbot/appraisal/