aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-05-19 02:01:39 +0800
committerchinsan <chinsan@FreeBSD.org>2008-05-19 02:01:39 +0800
commit381ad020255745417561740277333581a7b1f8a6 (patch)
tree629e92914f880d9029d3f47f71564bfee1005436
parent159bd9a451510e12fad54c613303d572fb798b50 (diff)
downloadfreebsd-ports-gnome-381ad020255745417561740277333581a7b1f8a6.tar.gz
freebsd-ports-gnome-381ad020255745417561740277333581a7b1f8a6.tar.zst
freebsd-ports-gnome-381ad020255745417561740277333581a7b1f8a6.zip
Reverse-resolve IP in Apache log files.
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-reslog/Makefile32
-rw-r--r--sysutils/p5-reslog/distinfo3
-rw-r--r--sysutils/p5-reslog/pkg-descr12
4 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5a2e900bd275..eb8b232173cc 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -512,6 +512,7 @@
SUBDIR += p5-User
SUBDIR += p5-arclog
SUBDIR += p5-mogilefs-server
+ SUBDIR += p5-reslog
SUBDIR += paicc
SUBDIR += pax-utils
SUBDIR += pcfclock
diff --git a/sysutils/p5-reslog/Makefile b/sysutils/p5-reslog/Makefile
new file mode 100644
index 000000000000..eb2370e2e2a8
--- /dev/null
+++ b/sysutils/p5-reslog/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-reslog
+# Date created: 2008/05/18
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= reslog
+PORTVERSION= 3.16
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Locale/IMACAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Reverse-resolve IP in Apache log files
+
+BUILD_DEPENDS= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
+ p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-ExtUtils-MakeMaker>=0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN1= reslog.1
+
+PLIST_FILES= bin/reslog \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-reslog/distinfo b/sysutils/p5-reslog/distinfo
new file mode 100644
index 000000000000..51eeb56f2a08
--- /dev/null
+++ b/sysutils/p5-reslog/distinfo
@@ -0,0 +1,3 @@
+MD5 (reslog-3.16.tar.gz) = 9782ce712a26e578dc7d55aea42b2375
+SHA256 (reslog-3.16.tar.gz) = f48ace32ca142eacd771f51857f07f9f18cf0e516d00eb05d787b1340258443d
+SIZE (reslog-3.16.tar.gz) = 90495
diff --git a/sysutils/p5-reslog/pkg-descr b/sysutils/p5-reslog/pkg-descr
new file mode 100644
index 000000000000..51fcb80b6bff
--- /dev/null
+++ b/sysutils/p5-reslog/pkg-descr
@@ -0,0 +1,12 @@
+reslog resolves IPs in Apache(8) log files. The result can then be analyzed
+by another program, like Analog. You can think of it as a replacement of the
+Apache(8) HostNameLookups directive, in the sense that it resolves client
+IPs altogether once a day.
+
+Resolving takes long time. This is mainly caused by resolving: Network
+packets may be filtered by firewalls; DNS servers may not be correctly
+configured; may not be up working; may sit in slow network sections; may be
+old slow machines; may have traffic jam... etc. All these reasons are out of
+our control.
+
+WWW: http://search.cpan.org/dist/reslog/