aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2013-01-28 10:44:33 +0800
committersahil <sahil@FreeBSD.org>2013-01-28 10:44:33 +0800
commit38823f8f01bb978dccb8cc474f6e756f0d0cf6e1 (patch)
tree32b33418b13b711ce54dcdbe4e2396934c9b6ad1
parent69006a9a22b27c4ed098146fac4858c535956202 (diff)
downloadfreebsd-ports-gnome-38823f8f01bb978dccb8cc474f6e756f0d0cf6e1.tar.gz
freebsd-ports-gnome-38823f8f01bb978dccb8cc474f6e756f0d0cf6e1.tar.zst
freebsd-ports-gnome-38823f8f01bb978dccb8cc474f6e756f0d0cf6e1.zip
Update to 2.6.18 and revise the PKGINSTALL script to
distinguish between upgrades and fresh installs. Also, backport an upstream patch that allows Postfix packages to build in a jail that has IPv6 enabled, but no addresses assigned on any interface.
-rw-r--r--mail/postfix26/Makefile3
-rw-r--r--mail/postfix26/distinfo4
-rw-r--r--mail/postfix26/files/patch-src-util-inet_proto.c20
-rw-r--r--mail/postfix26/files/patch-src::util::sys_defs.h6
-rw-r--r--mail/postfix26/files/pkg-install.in14
5 files changed, 35 insertions, 12 deletions
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index 3452ea49ca80..09eb6558adb2 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.6.17
-PORTREVISION= 2
+PORTVERSION= 2.6.18
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
diff --git a/mail/postfix26/distinfo b/mail/postfix26/distinfo
index b44b1bdf7945..258cd00c7c78 100644
--- a/mail/postfix26/distinfo
+++ b/mail/postfix26/distinfo
@@ -1,4 +1,4 @@
-SHA256 (postfix/postfix-2.6.17.tar.gz) = b7c34426bcdaa748ebc66a14b17266706f8049a9e21f3e055586bceffd02d10f
-SIZE (postfix/postfix-2.6.17.tar.gz) = 3327385
+SHA256 (postfix/postfix-2.6.18.tar.gz) = fdefebe46f6398f3feef5d6c58dfe6a26ccf283bb9361b6225c5cccd2a7aeb9e
+SIZE (postfix/postfix-2.6.18.tar.gz) = 3327921
SHA256 (postfix/postfix-2.6.5-vda-ng.patch.gz) = e1c04e9d268dc84832334997e1f593af9877dbd5030708280427a0dc4452e797
SIZE (postfix/postfix-2.6.5-vda-ng.patch.gz) = 12435
diff --git a/mail/postfix26/files/patch-src-util-inet_proto.c b/mail/postfix26/files/patch-src-util-inet_proto.c
new file mode 100644
index 000000000000..89c4c9b3ebe8
--- /dev/null
+++ b/mail/postfix26/files/patch-src-util-inet_proto.c
@@ -0,0 +1,20 @@
+--- src/util/inet_proto.c.orig 2013-01-27 20:38:42.000000000 +0000
++++ src/util/inet_proto.c 2013-01-27 20:39:54.000000000 +0000
+@@ -205,7 +205,7 @@
+ pf->dns_atype_list = make_unsigned_vector(2, T_AAAA, 0);
+ pf->sa_family_list = make_uchar_vector(2, AF_INET6, 0);
+ break;
+- } else if (errno == EAFNOSUPPORT) {
++ } else if (errno == EAFNOSUPPORT || errno == EPROTONOSUPPORT) {
+ msg_fatal("%s: IPv6 support is disabled: %m", context);
+ } else {
+ msg_fatal("socket: %m");
+@@ -219,7 +219,7 @@
+ pf->dns_atype_list = make_unsigned_vector(3, T_A, T_AAAA, 0);
+ pf->sa_family_list = make_uchar_vector(3, AF_INET, AF_INET6, 0);
+ break;
+- } else if (errno == EAFNOSUPPORT) {
++ } else if (errno == EAFNOSUPPORT || errno == EPROTONOSUPPORT) {
+ msg_warn("%s: IPv6 support is disabled: %m", context);
+ msg_warn("%s: configuring for IPv4 support only", context);
+ /* FALLTHROUGH */
diff --git a/mail/postfix26/files/patch-src::util::sys_defs.h b/mail/postfix26/files/patch-src::util::sys_defs.h
index a13c320759ff..91e084cf2daf 100644
--- a/mail/postfix26/files/patch-src::util::sys_defs.h
+++ b/mail/postfix26/files/patch-src::util::sys_defs.h
@@ -1,10 +1,10 @@
---- src/util/sys_defs.h.orig 2011-03-01 19:35:19.000000000 -0500
-+++ src/util/sys_defs.h 2011-03-01 19:36:54.000000000 -0500
+--- src/util/sys_defs.h.orig 2013-01-27 20:38:47.000000000 +0000
++++ src/util/sys_defs.h 2013-01-27 20:39:28.000000000 +0000
@@ -25,7 +25,7 @@
*/
#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
|| defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
-- || defined(FREEBSD8) \
+- || defined(FREEBSD8) || defined(FREEBSD9) \
+ || defined(FREEBSD8) || defined(FREEBSD9) || defined(FREEBSD10) \
|| defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
|| defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
diff --git a/mail/postfix26/files/pkg-install.in b/mail/postfix26/files/pkg-install.in
index 7f9a1329fb4d..3137ba3d2ecb 100644
--- a/mail/postfix26/files/pkg-install.in
+++ b/mail/postfix26/files/pkg-install.in
@@ -65,11 +65,15 @@ if [ "$2" = "POST-INSTALL" ]; then
fi
done
- /bin/sh ${DAEMONDIR}/post-install tempdir=/tmp \
- daemon_directory=${DAEMONDIR} \
- html_directory=${READMEDIR} \
- readme_directory=${READMEDIR} \
- upgrade-package
+ cmp ${DAEMONDIR}/main.cf ${ETCDIR}/main.cf >/dev/null 2>&1 \
+ && POSTARG="set-permissions" \
+ || POSTARG="upgrade-package"
+
+ /bin/sh ${DAEMONDIR}/post-install tempdir=/tmp \
+ daemon_directory=${DAEMONDIR} \
+ html_directory=${READMEDIR} \
+ readme_directory=${READMEDIR} \
+ ${POSTARG}
fi
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" -a -f "${MC}" ]; then