aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2013-06-07 11:39:31 +0800
committerashish <ashish@FreeBSD.org>2013-06-07 11:39:31 +0800
commit38ef03385059aa4ea8be46ce903af9d0bf6c415e (patch)
tree0856ca0fe124982cda72f166dcf6808a047a6e7e
parentbe34c886031e9bc4c9ceb768965391b4aaad8ce9 (diff)
downloadfreebsd-ports-gnome-38ef03385059aa4ea8be46ce903af9d0bf6c415e.tar.gz
freebsd-ports-gnome-38ef03385059aa4ea8be46ce903af9d0bf6c415e.tar.zst
freebsd-ports-gnome-38ef03385059aa4ea8be46ce903af9d0bf6c415e.zip
- Update to 5.3.3p1
- Remove unneeded dependency on databases/sqlite3 - Use a cleaner way to pass configuration directory[1] PR: ports/179364[1] Submitted by: Emmanuel Vadot <elbarto at bocal.org>[1] Changes: http://article.gmane.org/gmane.mail.opensmtpd.general/630
-rw-r--r--mail/opensmtpd/Makefile13
-rw-r--r--mail/opensmtpd/distinfo4
-rw-r--r--mail/opensmtpd/files/patch-smtpd_Makefile.am28
3 files changed, 8 insertions, 37 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index ca3d7ee4bd8a..f14ae17e5a4e 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: opensmtpd
-# Date created: 2012-05-13
-# Whom: Ashish SHUKLA <ashish@FreeBSD.org>
-#
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= opensmtpd
-PORTVERSION= 5.3.2
+PORTVERSION= 5.3.3
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
@@ -16,8 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}p1
MAINTAINER= ashish@FreeBSD.org
COMMENT= OpenSMTPD is a free MTA
-LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent \
- sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
LICENSE_NAME= ISCL
@@ -27,7 +22,7 @@ OPTIONS_DEFAULT= PAM
USE_AUTOTOOLS= autoconf:env automake:env libtool:env
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE}
+CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/
USE_RC_SUBR= smtpd
SUB_FILES= pkg-install pkg-deinstall pkg-message
diff --git a/mail/opensmtpd/distinfo b/mail/opensmtpd/distinfo
index cfb4ee87eef0..37f262ec1313 100644
--- a/mail/opensmtpd/distinfo
+++ b/mail/opensmtpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opensmtpd-5.3.2p1.tar.gz) = 512a80333d267a3cecf858b5106200a386e96894907e18e105b69cbd27699a08
-SIZE (opensmtpd-5.3.2p1.tar.gz) = 345468
+SHA256 (opensmtpd-5.3.3p1.tar.gz) = 34f0e208e6fdde5c5c25bb11f468436c4d6148a8b640c32117869cad140b823c
+SIZE (opensmtpd-5.3.3p1.tar.gz) = 343733
diff --git a/mail/opensmtpd/files/patch-smtpd_Makefile.am b/mail/opensmtpd/files/patch-smtpd_Makefile.am
index 7577aaf0874e..7db3013e1793 100644
--- a/mail/opensmtpd/files/patch-smtpd_Makefile.am
+++ b/mail/opensmtpd/files/patch-smtpd_Makefile.am
@@ -3,31 +3,7 @@ $FreeBSD$
--- smtpd/Makefile.am.orig
+++ smtpd/Makefile.am
-@@ -97,7 +97,7 @@
- CFLAGS+= -D_GNU_SOURCE
- CPPFLAGS= -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
-
--PATHS= -DSMTPD_CONFDIR=\"$(sysconfdir)\" \
-+PATHS= -DSMTPD_CONFDIR=\"$(sysconfdir)/mail\" \
- -DPATH_SMTPCTL=\"$(sbindir)/smtpctl\" \
- -DPATH_MAILLOCAL=\"$(libexecdir)/mail.local\"
-
-@@ -116,7 +116,7 @@
- ../contrib/lib/libc/asr/asr_private.h \
- $(CONFIGFILES_IN) $(MANPAGES_IN)
-
--PATHSUBS= -e 's|/etc/mail/|$(sysconfdir)/|g' \
-+PATHSUBS= -e 's|/etc/mail/|$(sysconfdir)/mail/|g' \
- -e 's|/usr/libexec|$(libexecdir)|g' \
- -e 's|/var/run/smtpd.sock|$(sockdir)/smtpd.sock|g'
-
-@@ -142,16 +142,12 @@
- # smtpd.conf
- # newaliases makemap
- install-exec-hook: $(CONFIGFILES) $(MANPAGES)
-- $(MKDIR_P) $(DESTDIR)$(sysconfdir)
-+ $(MKDIR_P) $(DESTDIR)$(sysconfdir)/mail
- $(MKDIR_P) $(DESTDIR)$(bindir)
+@@ -162,11 +162,7 @@
$(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)5
$(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)8
@@ -36,7 +12,7 @@ $FreeBSD$
- else \
- echo "$(DESTDIR)$(sysconfdir)/smtpd.conf already exists, install will not overwrite"; \
- fi
-+ $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/mail/smtpd.conf.sample
++ $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/smtpd.conf.sample
ln -f $(DESTDIR)$(sbindir)/smtpctl$(EXEEXT) \
$(DESTDIR)$(bindir)/mailq$(EXEEXT);