aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-07-22 05:21:59 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-07-22 05:21:59 +0800
commit397633a9b4765f65d5c516d681258c5f29fe064d (patch)
treeb0de1d478d69298063c653fa3f9fe8226d6987e4
parent7b174dadc683745567fcec5bddd890f628d4dd9b (diff)
downloadfreebsd-ports-gnome-397633a9b4765f65d5c516d681258c5f29fe064d.tar.gz
freebsd-ports-gnome-397633a9b4765f65d5c516d681258c5f29fe064d.tar.zst
freebsd-ports-gnome-397633a9b4765f65d5c516d681258c5f29fe064d.zip
Second attempt to fix build on 11.0-CURRENT.
-rw-r--r--math/aamath/Makefile2
-rw-r--r--math/aamath/files/patch-Makefile7
2 files changed, 6 insertions, 3 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index e6455e0e8771..2bd6c2d5564f 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -19,6 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/aamath man/man1/aamath.1.gz
+CFLAGS+= -I${LOCALBASE}/include
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/math/aamath/files/patch-Makefile b/math/aamath/files/patch-Makefile
index 1557574f9a77..7a62f71b33e1 100644
--- a/math/aamath/files/patch-Makefile
+++ b/math/aamath/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig
-+++ Makefile
+--- ./Makefile.orig 2005-06-22 22:12:18.000000000 +0200
++++ ./Makefile 2014-07-22 01:12:20.000000000 +0200
@@ -1,17 +1,22 @@
-CXX = g++
-LD = g++
@@ -14,7 +14,8 @@
LIBS = -lreadline -ltermcap
$(TARGET): $(OBJS)
- $(LD) $(LFLAGS) $(OBJS) -o $@ $(LIBS)
+- $(LD) $(LFLAGS) $(OBJS) -o $@ $(LIBS)
++ $(LD) $(LDFLAGS) $(OBJS) -o $@ $(LIBS)
-parser.cc parser.h: parser.y
- yacc -d parser.y && mv y.tab.c parser.cc && mv y.tab.h parser.h