aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-01-17 23:58:46 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-01-17 23:58:46 +0800
commit39aea5ee4f5651d6c7eb10f0c23fc1f127027f37 (patch)
tree0880de13da670029e16b502d368c260c9507f662
parent6a71c0b7111fc4acb8982f96c0e60ca50f6590c2 (diff)
downloadfreebsd-ports-gnome-39aea5ee4f5651d6c7eb10f0c23fc1f127027f37.tar.gz
freebsd-ports-gnome-39aea5ee4f5651d6c7eb10f0c23fc1f127027f37.tar.zst
freebsd-ports-gnome-39aea5ee4f5651d6c7eb10f0c23fc1f127027f37.zip
Fix use with clang. CCACHE_CPP2 is still required. Otherwise the
errors with parenthesis occur again. Seen with www/uwsgi. Reported by: blackflow on freenode
-rw-r--r--devel/ccache/Makefile2
-rw-r--r--devel/ccache/files/patch-conf.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 3b04b204e3db..cf46b59294c7 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ccache
PORTVERSION= 3.2.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.samba.org/ftp/ccache/ \
LOCAL/bdrewery
diff --git a/devel/ccache/files/patch-conf.c b/devel/ccache/files/patch-conf.c
new file mode 100644
index 000000000000..5021fce33b76
--- /dev/null
+++ b/devel/ccache/files/patch-conf.c
@@ -0,0 +1,24 @@
+--- conf.c.orig 2015-01-16 16:26:23.872241677 -0600
++++ conf.c 2015-01-16 16:27:00.595237894 -0600
+@@ -15,6 +15,9 @@
+ * this program; if not, write to the Free Software Foundation, Inc., 51
+ * Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
++#if defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
+
+ #include "conf.h"
+ #include "ccache.h"
+@@ -321,7 +324,11 @@ conf_create(void)
+ conf->read_only = false;
+ conf->read_only_direct = false;
+ conf->recache = false;
++#if __FreeBSD_version >= 1000024 || defined(CC_IS_CLANG)
++ conf->run_second_cpp = true;
++#else
+ conf->run_second_cpp = false;
++#endif
+ conf->sloppiness = 0;
+ conf->stats = true;
+ conf->temporary_dir = x_strdup("");