aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2008-12-05 02:17:27 +0800
committerleeym <leeym@FreeBSD.org>2008-12-05 02:17:27 +0800
commit39e737c9605d4dfac6c52798d7d2fc4a096df6f7 (patch)
treeef1adccd2435e0a8899b1692af52e060b6ed37d7
parent53e7d96c4d99d1bc2f8a14751187cbd7a6daa868 (diff)
downloadfreebsd-ports-gnome-39e737c9605d4dfac6c52798d7d2fc4a096df6f7.tar.gz
freebsd-ports-gnome-39e737c9605d4dfac6c52798d7d2fc4a096df6f7.tar.zst
freebsd-ports-gnome-39e737c9605d4dfac6c52798d7d2fc4a096df6f7.zip
- add Data::Stream::Bulk 0.03
This module tries to find middle ground between one at a time and all at once processing of data sets. The purpose of this module is to avoid the overhead of implementing an iterative api when this isn't necessary, without breaking forward compatibility in case that becomes necessary later on. The API optimizes for when a data set typically fits in memory and is returned as an array, but the consumer cannot assume that the data set is bounded. The API is destructive in order to minimize the chance that resultsets are leaked due to improper usage. WWW: http://search.cpan.org/dist/Data-Stream-Bulk/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Stream-Bulk/Makefile47
-rw-r--r--devel/p5-Data-Stream-Bulk/distinfo3
-rw-r--r--devel/p5-Data-Stream-Bulk/pkg-descr15
-rw-r--r--devel/p5-Data-Stream-Bulk/pkg-plist19
5 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fdf6f16aa7d5..d688db037e1c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1141,6 +1141,7 @@
SUBDIR += p5-Data-Serializer
SUBDIR += p5-Data-ShowTable
SUBDIR += p5-Data-Stag
+ SUBDIR += p5-Data-Stream-Bulk
SUBDIR += p5-Data-Structure-Util
SUBDIR += p5-Data-Swap
SUBDIR += p5-Data-Table
diff --git a/devel/p5-Data-Stream-Bulk/Makefile b/devel/p5-Data-Stream-Bulk/Makefile
new file mode 100644
index 000000000000..4826faf9b653
--- /dev/null
+++ b/devel/p5-Data-Stream-Bulk/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Data::Stream::Bulk
+# Date created: 2008-11-28
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Stream-Bulk
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= N at a time iteration API
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-namespace-clean>=0.08:${PORTSDIR}/devel/p5-namespace-clean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= p5-DBD-Mock>=0:${PORTSDIR}/databases/p5-DBD-Mock \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Test-TempDir>=0:${PORTSDIR}/devel/p5-Test-TempDir \
+ p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Stream::Bulk.3 \
+ Data::Stream::Bulk::Array.3 \
+ Data::Stream::Bulk::Callback.3 \
+ Data::Stream::Bulk::Cat.3 \
+ Data::Stream::Bulk::DBI.3 \
+ Data::Stream::Bulk::DBIC.3 \
+ Data::Stream::Bulk::DoneFlag.3 \
+ Data::Stream::Bulk::Filter.3 \
+ Data::Stream::Bulk::Nil.3 \
+ Data::Stream::Bulk::Path::Class.3 \
+ Data::Stream::Bulk::Util.3
+
+# minor fixes for pod2man
+post-patch:
+ ${PERL} -pi"" -e "s/METHODS/METHODS\n\n=over 4/" ${WRKSRC}/lib/Data/Stream/Bulk/Filter.pm
+ ${PERL} -pi"" -e "s/<max_rows\)/<max_rows>)/" ${WRKSRC}/lib/Data/Stream/Bulk/DBI.pm
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Stream-Bulk/distinfo b/devel/p5-Data-Stream-Bulk/distinfo
new file mode 100644
index 000000000000..8aa7d6a4d37a
--- /dev/null
+++ b/devel/p5-Data-Stream-Bulk/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Stream-Bulk-0.03.tar.gz) = 0ccbf13f45f9f7b7650f6f22202113a4
+SHA256 (Data-Stream-Bulk-0.03.tar.gz) = 09b367601426b9b0c3fb4a892a659d145d9aca9754cd4029c982db053c8c4bdd
+SIZE (Data-Stream-Bulk-0.03.tar.gz) = 11743
diff --git a/devel/p5-Data-Stream-Bulk/pkg-descr b/devel/p5-Data-Stream-Bulk/pkg-descr
new file mode 100644
index 000000000000..f394cc939816
--- /dev/null
+++ b/devel/p5-Data-Stream-Bulk/pkg-descr
@@ -0,0 +1,15 @@
+This module tries to find middle ground between one at a time and all at
+once processing of data sets.
+
+The purpose of this module is to avoid the overhead of implementing an
+iterative api when this isn't necessary, without breaking forward
+compatibility in case that becomes necessary later on.
+
+The API optimizes for when a data set typically fits in memory and is
+returned as an array, but the consumer cannot assume that the data set is
+bounded.
+
+The API is destructive in order to minimize the chance that resultsets are
+leaked due to improper usage.
+
+WWW: http://search.cpan.org/dist/Data-Stream-Bulk/
diff --git a/devel/p5-Data-Stream-Bulk/pkg-plist b/devel/p5-Data-Stream-Bulk/pkg-plist
new file mode 100644
index 000000000000..709fd7a20d48
--- /dev/null
+++ b/devel/p5-Data-Stream-Bulk/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/Data/Stream/Bulk.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Array.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Callback.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Cat.pm
+%%SITE_PERL%%/Data/Stream/Bulk/DBI.pm
+%%SITE_PERL%%/Data/Stream/Bulk/DBIC.pm
+%%SITE_PERL%%/Data/Stream/Bulk/DoneFlag.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Filter.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Nil.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Path/Class.pm
+%%SITE_PERL%%/Data/Stream/Bulk/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Stream/Bulk/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Stream/Bulk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Stream
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data/Stream/Bulk/Path
+@dirrmtry %%SITE_PERL%%/Data/Stream/Bulk
+@dirrmtry %%SITE_PERL%%/Data/Stream
+@dirrmtry %%SITE_PERL%%/Data