aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-01-23 00:33:23 +0800
committerijliao <ijliao@FreeBSD.org>2001-01-23 00:33:23 +0800
commit3a34de25cdf5d6e115da6a9099cfc1722e0f2049 (patch)
tree067b3592061e04fc90e00e8320fdc382706d9f72
parent0176224f58b4daec86990de167ab7d6cee184a33 (diff)
downloadfreebsd-ports-gnome-3a34de25cdf5d6e115da6a9099cfc1722e0f2049.tar.gz
freebsd-ports-gnome-3a34de25cdf5d6e115da6a9099cfc1722e0f2049.tar.zst
freebsd-ports-gnome-3a34de25cdf5d6e115da6a9099cfc1722e0f2049.zip
add libdsp, a C++ class library of common digital signal processing functions
PR: 24373 Approved by: clive (my mentor)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libdsp/Makefile30
-rw-r--r--devel/libdsp/distinfo1
-rw-r--r--devel/libdsp/files/patch-Makefile_FreeBSD18
-rw-r--r--devel/libdsp/pkg-comment1
-rw-r--r--devel/libdsp/pkg-descr6
-rw-r--r--devel/libdsp/pkg-plist12
7 files changed, 69 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1f61f17c8d15..b9cf57d2cb53 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -144,6 +144,7 @@
SUBDIR += libcii
SUBDIR += libcoro
SUBDIR += libdlmalloc
+ SUBDIR += libdsp
SUBDIR += libffi
SUBDIR += libg++
SUBDIR += libgetline
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
new file mode 100644
index 000000000000..90ed74ee2097
--- /dev/null
+++ b/devel/libdsp/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: libdsp
+# Date created: Jan 16, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdsp
+PORTVERSION= 3.3.4
+CATEGORIES= devel audio
+MASTER_SITES= http://www.pp.clinet.fi/~visitor/dlbins/
+DISTNAME= libdsp-src
+
+MAINTAINER= ijliao@FreeBSD.org
+
+# dont use "USE_LIBTOOL=yes" because there's no configure script
+BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
+
+INSTALLS_SHLIB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
+MAKEFILE= Makefile.FreeBSD
+
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/devel/libdsp/distinfo b/devel/libdsp/distinfo
new file mode 100644
index 000000000000..ec2b3a94d7fa
--- /dev/null
+++ b/devel/libdsp/distinfo
@@ -0,0 +1 @@
+MD5 (libdsp-src.tar.gz) = e844f463d7c15ff98746c3c316038a86
diff --git a/devel/libdsp/files/patch-Makefile_FreeBSD b/devel/libdsp/files/patch-Makefile_FreeBSD
new file mode 100644
index 000000000000..7771159be21d
--- /dev/null
+++ b/devel/libdsp/files/patch-Makefile_FreeBSD
@@ -0,0 +1,18 @@
+--- Makefile.FreeBSD.orig Tue Jan 16 13:35:30 2001
++++ Makefile.FreeBSD Tue Jan 16 13:38:31 2001
+@@ -18,12 +18,12 @@
+ #
+
+ CXX = g++
+-CXXFLAGS = -mcpu=k6 -march=k6 -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=3 -malign-jumps=3 -malign-functions=3 -mpreferred-stack-boundary=3 -mfancy-math-387 -Wall
++CXXFLAGS = -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=3 -malign-jumps=3 -malign-functions=3 -mpreferred-stack-boundary=3 -mfancy-math-387 -Wall
+ DEFS = -D_REENTRANT -D_THREAD_SAFE -DFREEBSD
+-INCS = -I.
++INCS = -I. -I../Inlines-1.0.0.3
+ LIBS = -lm #-ldrfftw -ldfftw
+ LIBTOOL = libtool
+-PREFIX = /usr/local
++PREFIX = %%PREFIX%%
+
+ VERSION = 0:4:0
+
diff --git a/devel/libdsp/pkg-comment b/devel/libdsp/pkg-comment
new file mode 100644
index 000000000000..8dfcd3fc9b65
--- /dev/null
+++ b/devel/libdsp/pkg-comment
@@ -0,0 +1 @@
+C++ class library of common digital signal processing functions
diff --git a/devel/libdsp/pkg-descr b/devel/libdsp/pkg-descr
new file mode 100644
index 000000000000..95db89a32dac
--- /dev/null
+++ b/devel/libdsp/pkg-descr
@@ -0,0 +1,6 @@
+libDSP is C++ class library of common digital signal processing functions.
+
+WWW: http://www.pp.clinet.fi/~visitor/
+
+-- Ying-Chieh Liao
+ ijliao@FreeBSD.org
diff --git a/devel/libdsp/pkg-plist b/devel/libdsp/pkg-plist
new file mode 100644
index 000000000000..e1f445a345fe
--- /dev/null
+++ b/devel/libdsp/pkg-plist
@@ -0,0 +1,12 @@
+include/dsp/DSPConfig.hh
+include/dsp/DSPOp.hh
+include/dsp/Decimator.hh
+include/dsp/Filter.hh
+include/dsp/Transform4.hh
+include/dsp/Transform8.hh
+include/dsp/TransformS.hh
+@dirrm include/dsp
+lib/libdsp.a
+lib/libdsp.la
+lib/libdsp.so
+lib/libdsp.so.0