aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-08-15 00:10:14 +0800
committervanilla <vanilla@FreeBSD.org>2014-08-15 00:10:14 +0800
commit3ad03ec13e13ffd197497a38e69bbc9dbf36f43a (patch)
treeac160edb2a53006a639475a2c85ae9eb88951b9d
parentd366e32bfc8b3f4227f4a794af6795731abcc715 (diff)
downloadfreebsd-ports-gnome-3ad03ec13e13ffd197497a38e69bbc9dbf36f43a.tar.gz
freebsd-ports-gnome-3ad03ec13e13ffd197497a38e69bbc9dbf36f43a.tar.zst
freebsd-ports-gnome-3ad03ec13e13ffd197497a38e69bbc9dbf36f43a.zip
1: add USE_GCC=any to fix build.
2: Stagify.
-rw-r--r--graphics/ffff/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/ffff/Makefile b/graphics/ffff/Makefile
index 32c4b2ad7d3b..b65d614cc977 100644
--- a/graphics/ffff/Makefile
+++ b/graphics/ffff/Makefile
@@ -14,6 +14,7 @@ COMMENT= Fast Mandelbrot fractal generator
USE_XORG= x11 xmu xext
USE_GL= gl glut
USES= dos2unix zip
+USE_GCC= any
SOURCE= FFFF3 FragmentProgram FragmentProgramARB10 GPUProgram \
PixelBuffer VertexProgram VertexProgramATI VertexProgramNV \
@@ -29,7 +30,6 @@ PLIST_FILES= bin/ffff
# contains x86 assembler
ONLY_FOR_ARCHS= i386
-NO_STAGE= yes
do-build:
.for f in ${SOURCE}
${CXX} ${CXXFLAGS} -c ${WRKSRC}/${f}.cpp -o ${WRKSRC}/${f}.obj
@@ -37,6 +37,6 @@ do-build:
${CXX} ${LDFLAGS} ${SOURCE:C/(.*)/${WRKSRC}\/\1.obj/} -o ${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>