aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-02-11 16:01:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-02-11 16:01:39 +0800
commit3be72f0d8d2aa64a0d3a683c78cff0b91d562121 (patch)
tree3bc136a0001c9553170c66784d911798679dc760
parent7cb1bec8bcab2b1ddb764ce693bbfe6aee40254a (diff)
downloadfreebsd-ports-gnome-3be72f0d8d2aa64a0d3a683c78cff0b91d562121.tar.gz
freebsd-ports-gnome-3be72f0d8d2aa64a0d3a683c78cff0b91d562121.tar.zst
freebsd-ports-gnome-3be72f0d8d2aa64a0d3a683c78cff0b91d562121.zip
- Update to 2.9.0.4
- Update snortsam checksum - Fix LIBNET_CONFIG issue - Pet portlint Changes: http://www.snort.org/downloads/740 PR: ports/154668 Submitted by: Dean Freeman <wfreeman@sourcefire.com> (maintainer)
-rw-r--r--security/snort/Makefile30
-rw-r--r--security/snort/distinfo8
-rw-r--r--security/snort/pkg-plist1
3 files changed, 21 insertions, 18 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index d0679aae650a..08a93bccac20 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= snort
-PORTVERSION= 2.9.0.3
+PORTVERSION= 2.9.0.4
CATEGORIES= security
MASTER_SITES= SF/snort/snort
@@ -60,16 +60,21 @@ PREPROC_RULES= decoder.rules preprocessor.rules sensitive-data.rules
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+.if exists(${LIBNET_CONFIG})
LIBNET_CFLAGS!= ${LIBNET_CONFIG} --cflags
LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
+.else
+LIBNET_CFLAGS= -I${LOCALBASE}/include/libnet11
+LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11 -lnet
+.endif
LIBNET_INCDIR= ${LIBNET_CFLAGS:M-I*:S/-I//}
LIBNET_LIBDIR= ${LIBNET_LIBS:M-L*:S/-L//}
-CONFIGURE_ARGS+= --enable-dynamicplugin --enable-build-dynamic-examples \
- --enable-reload --enable-reload-restart \
- --disable-corefiles \
- --with-dnet-includes=${LIBNET_INCDIR} \
- --with-dnet-libraries=${LIBNET_LIBDIR}
+CONFIGURE_ARGS= --enable-dynamicplugin --enable-build-dynamic-examples \
+ --enable-reload --enable-reload-restart \
+ --disable-corefiles \
+ --with-dnet-includes=${LIBNET_INCDIR} \
+ --with-dnet-libraries=${LIBNET_LIBDIR}
PLIST_SUB+= DYNAMIC=""
@@ -149,9 +154,8 @@ CONFIGURE_ARGS+= --enable-react
.endif
.if defined(WITH_SNORTSAM)
-USE_AUTOTOOLS+= automake
-PATCH_SITES+= http://www.snortsam.net/files/snort-plugin/:snortsam \
- http://www.secnap.com/downloads/:snortsam
+USE_AUTOTOOLS+= automake
+PATCH_SITES+= http://www.snortsam.net/files/snort-plugin/:snortsam
PATCHFILES+= snortsam-2.9.0.3.diff.gz:snortsam
.endif
@@ -161,10 +165,8 @@ post-patch:
.endif
pre-configure:
- ${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|lib/snort_|lib/snort/|g'
- ${REINPLACE_CMD} "s,/etc/snort.conf,${CONFIG_DIR}/snort.conf," \
- ${WRKSRC}/src/snort.c ${WRKSRC}/snort.8
+ ${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e 's|lib/snort_|lib/snort/|g'
+ ${REINPLACE_CMD} "s,/etc/snort.conf,${CONFIG_DIR}/snort.conf," ${WRKSRC}/src/snort.c ${WRKSRC}/snort.8
${REINPLACE_CMD} -e 's|lib/snort_|lib/snort/|g' ${WRKSRC}/etc/snort.conf
${REINPLACE_CMD} -e 's|^dynamicdetection|#dynamicdetection|' ${WRKSRC}/etc/snort.conf
${REINPLACE_CMD} -e '/var HOME_NET/s/any/[YOU_NEED_TO_SET_HOME_NET_IN_snort.conf]/' ${WRKSRC}/etc/snort.conf
@@ -199,7 +201,7 @@ post-install:
@cd ${LOCALBASE}/lib && ${MV} snort_dynamicrules/* snort/dynamicrules
@cd ${LOCALBASE}/lib && ${MV} snort_dynamicengine/* snort/dynamicengine
@cd ${LOCALBASE}/lib && ${MV} snort_dynamicpreprocessor/* snort/dynamicpreprocessor
- @cd ${LOCALBASE}/lib && ${${RMDIR} snort_dynamic*
+ @cd ${LOCALBASE}/lib && ${RMDIR} snort_dynamic*
@${MKDIR} ${LOCALBASE}/libdata/pkgconfig/ && ${MV} ${LOCALBASE}/lib/pkgconfig/snort.pc ${LOCALBASE}/libdata/pkgconfig/snort.pc
@${RMDIR} ${LOCALBASE}/lib/pkgconfig
.endif
diff --git a/security/snort/distinfo b/security/snort/distinfo
index 1b36eb68fbf6..5daf2e596501 100644
--- a/security/snort/distinfo
+++ b/security/snort/distinfo
@@ -1,4 +1,4 @@
-SHA256 (snort-2.9.0.3.tar.gz) = 382768dc7a47bbf4e1a85cd765d8bf4f245643be2acfc740fda1cd3d24e32a48
-SIZE (snort-2.9.0.3.tar.gz) = 5791144
-SHA256 (snortsam-2.9.0.3.diff.gz) = f32baf0408e80c7aed3560ce46229d936d71b8e7a4180efdba04f8e0021e70bc
-SIZE (snortsam-2.9.0.3.diff.gz) = 28890
+SHA256 (snort-2.9.0.4.tar.gz) = 131f54b48005677b73c55a2c3d893ab3607562912272d0810fc9b85c63fc91e9
+SIZE (snort-2.9.0.4.tar.gz) = 5862444
+SHA256 (snortsam-2.9.0.3.diff.gz) = da0f9567f213c69e3682bfda4c6310090ce255b0495c02984b3f7e089b19e149
+SIZE (snortsam-2.9.0.3.diff.gz) = 28889
diff --git a/security/snort/pkg-plist b/security/snort/pkg-plist
index d79dc6e9c980..6f0121598099 100644
--- a/security/snort/pkg-plist
+++ b/security/snort/pkg-plist
@@ -161,6 +161,7 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%PORTDOCS%%%%DOCSDIR%%/README.thresholding
%%PORTDOCS%%%%DOCSDIR%%/README.u2boat
%%PORTDOCS%%%%DOCSDIR%%/README.variables
+%%PORTDOCS%%%%DOCSDIR%%/README.rzb_saac
%%PORTDOCS%%%%DOCSDIR%%/RELEASE.NOTES
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/USAGE