aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorphantom <phantom@FreeBSD.org>2002-07-08 23:23:24 +0800
committerphantom <phantom@FreeBSD.org>2002-07-08 23:23:24 +0800
commit3c5fe990c1ea8844bb09b8c5bb1dbb02bf06e71d (patch)
tree539c36cd307215352518fee531589ed05b8a9895
parent2ababa14736f212f61fe5d8f78015066cc5b4633 (diff)
downloadfreebsd-ports-gnome-3c5fe990c1ea8844bb09b8c5bb1dbb02bf06e71d.tar.gz
freebsd-ports-gnome-3c5fe990c1ea8844bb09b8c5bb1dbb02bf06e71d.tar.zst
freebsd-ports-gnome-3c5fe990c1ea8844bb09b8c5bb1dbb02bf06e71d.zip
PERL -> REINPLACE_CMD
PR: 39749 Submitted by: Paul Marquis <pmarquis@pobox.com>
-rw-r--r--devel/bugzilla/Makefile6
-rw-r--r--devel/bugzilla2/Makefile6
-rw-r--r--devel/bugzilla3/Makefile6
3 files changed, 12 insertions, 6 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index b2068834c5da..eb9ae42e9053 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -32,6 +32,8 @@ RUN_DEPENDS+= ${PERL_SITEDIR}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
RUN_DEPENDS+= ${PERL_SITEDIR}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
.endif
+USE_REINPLACE= yes
+
NO_BUILD= yes
BINMODE= 700
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -65,11 +67,11 @@ post-patch:
@find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
@find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
- @${PERL} -pi -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
+ @${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
.endfor
.for i in ${SENDMAILWC}
- @${PERL} -pi -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
+ @${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor
diff --git a/devel/bugzilla2/Makefile b/devel/bugzilla2/Makefile
index b2068834c5da..eb9ae42e9053 100644
--- a/devel/bugzilla2/Makefile
+++ b/devel/bugzilla2/Makefile
@@ -32,6 +32,8 @@ RUN_DEPENDS+= ${PERL_SITEDIR}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
RUN_DEPENDS+= ${PERL_SITEDIR}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
.endif
+USE_REINPLACE= yes
+
NO_BUILD= yes
BINMODE= 700
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -65,11 +67,11 @@ post-patch:
@find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
@find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
- @${PERL} -pi -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
+ @${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
.endfor
.for i in ${SENDMAILWC}
- @${PERL} -pi -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
+ @${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index b2068834c5da..eb9ae42e9053 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -32,6 +32,8 @@ RUN_DEPENDS+= ${PERL_SITEDIR}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
RUN_DEPENDS+= ${PERL_SITEDIR}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
.endif
+USE_REINPLACE= yes
+
NO_BUILD= yes
BINMODE= 700
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -65,11 +67,11 @@ post-patch:
@find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
@find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
- @${PERL} -pi -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
+ @${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
.endfor
.for i in ${SENDMAILWC}
- @${PERL} -pi -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
+ @${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor