diff options
author | clement <clement@FreeBSD.org> | 2007-09-19 04:03:15 +0800 |
---|---|---|
committer | clement <clement@FreeBSD.org> | 2007-09-19 04:03:15 +0800 |
commit | 3d7b0954e3aff4b6d2c3b81d8d8ea1ef419a31db (patch) | |
tree | 2a22c835076aa83b47b9768f0d79b54db360f87c | |
parent | 6db6de9e885d16511cd8b274ae276941942267aa (diff) | |
download | freebsd-ports-gnome-3d7b0954e3aff4b6d2c3b81d8d8ea1ef419a31db.tar.gz freebsd-ports-gnome-3d7b0954e3aff4b6d2c3b81d8d8ea1ef419a31db.tar.zst freebsd-ports-gnome-3d7b0954e3aff4b6d2c3b81d8d8ea1ef419a31db.zip |
- Add experimental support of OPTIONS.
From UPDATING:
By popular request, OPTIONS support has been added. When actived
(default), these knobs are ignored:
* WITH_<CATEGORY>_MODULES
* WITHOUT_<CATEGORY>_MODULES
* WITH_CUSTOM_<CATEGORY>
* WITH_MODULES
* WITHOUT_MODULES
* WITH_STATIC_MODULES
However, you can disable OPTIONS by defining WITHOUT_APACHE_OPTIONS.
- move envvars support to the beginning of apache22_checkconfig() to be
sure we're using envvars during configtest [1]
PR: ports/116329 [1]
Submitted by: Ruud Althuizen <ruud@il.fontys.nl> [1]
-rw-r--r-- | UPDATING | 14 | ||||
-rw-r--r-- | www/apache22/Makefile | 11 | ||||
-rw-r--r-- | www/apache22/Makefile.options | 75 | ||||
-rw-r--r-- | www/apache22/files/apache22.sh.in | 12 |
4 files changed, 106 insertions, 6 deletions
@@ -6,6 +6,20 @@ You should get into the habit of checking this file for changes each time you update your ports collection, before attempting any port upgrades. +20070918: + AFFECTS: users of www/apache22 + AUTHOR: clement@FreeBSD.org + + By popular request, OPTIONS support has been added. When actived + (default), these knobs are ignored: + * WITH_<CATEGORY>_MODULES + * WITHOUT_<CATEGORY>_MODULES + * WITH_CUSTOM_<CATEGORY> + * WITH_MODULES + * WITHOUT_MODULES + * WITH_STATIC_MODULES + However, you can disable OPTIONS by defining WITHOUT_APACHE_OPTIONS. + 20070913: AFFECTS: users of x11/xorg AUTHOR: flz@FreeBSD.org diff --git a/www/apache22/Makefile b/www/apache22/Makefile index b63fe7df4240..df65a148e200 100644 --- a/www/apache22/Makefile +++ b/www/apache22/Makefile @@ -51,6 +51,17 @@ USE_RC_SUBR= apache22.sh htcacheclean.sh SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX} LIBTOOLFILES= configure +.if !defined(WITHOUT_APACHE_OPTIONS) +OPTIONS= \ + APR_FROM_PORTS "Use devel/apr as APR (beware!)" Off \ + THREADS "Enable threads support in APR" Off \ + MYSQL "Enable MySQL support for apr-dbd" Off \ + PGSQL "Enable PostgreSQL support for apr-dbd" Off \ + SQLITE "Enable SQLite support for apr-dbd" Off \ + IPV6 "Enable IPv6 support" On +.include "${.CURDIR}/Makefile.options" +.endif + .if !defined(WITH_APR_FROM_PORTS) USE_LDCONFIG= yes .endif diff --git a/www/apache22/Makefile.options b/www/apache22/Makefile.options new file mode 100644 index 000000000000..1a6df40903ae --- /dev/null +++ b/www/apache22/Makefile.options @@ -0,0 +1,75 @@ +OPTIONS+= \ + AUTH_BASIC "Enable mod_auth_basic" ON \ + AUTH_DIGEST "Enable mod_auth_digest" ON \ + AUTHN_FILE "Enable mod_authn_file" ON \ + AUTHN_DBD "Enable mod_authn_dbd" OFF \ + AUTHN_DBM "Enable mod_authn_dbm" ON \ + AUTHN_ANON "Enable mod_authn_anon" ON \ + AUTHN_DEFAULT "Enable mod_authn_default" ON \ + AUTHN_ALIAS "Enable mod_authn_alias" ON \ + AUTHZ_HOST "Enable mod_authz_host" ON \ + AUTHZ_GROUPFILE "Enable mod_authz_groupfile" ON \ + AUTHZ_USER "Enable mod_authz_user" ON \ + AUTHZ_DBM "Enable mod_authz_dbm" ON \ + AUTHZ_OWNER "Enable mod_authz_owner" ON \ + AUTHZ_DEFAULT "Enable mod_authz_default" ON \ + CACHE "Enable mod_cache" ON \ + DISK_CACHE "Enable mod_disk_cache" ON \ + FILE_CACHE "Enable mod_file_cache" ON \ + MEM_CACHE "Enable mod_mem_cache" OFF \ + DAV "Enable mod_dav" ON \ + DAV_FS "Enable mod_dav_fs" ON \ + BUCKETEER "Enable mod_bucketeer" OFF \ + CASE_FILTER "Enable mod_case_filter" OFF \ + CASE_FILTER_IN "Enable mod_case_filter_in" OFF \ + EXT_FILTER "Enable mod_ext_filter" OFF \ + CHARSET_LITE "Enable mod_charset_lite" ON \ + LOG_FORENSIC "Enable mod_log_forensic" OFF \ + OPTIONAL_HOOK_EXPORT "Enable mod_optional_hook_export" OFF \ + OPTIONAL_HOOK_IMPORT "Enable mod_optional_hook_import" OFF \ + OPTIONAL_FN_IMPORT "Enable mod_optional_fn_import" OFF \ + OPTIONAL_FN_EXPORT "Enable mod_optional_fn_export" OFF \ + LDAP "Enable mod_ldap" OFF \ + AUTHNZ_LDAP "Enable mod_authnz_ldap" OFF \ + ACTIONS "Enable mod_actions" ON \ + ALIAS "Enable mod_alias" ON \ + ASIS "Enable mod_asis" ON \ + AUTOINDEX "Enable mod_autoindex" ON \ + CERN_META "Enable mod_cern_meta" ON \ + CGI "Enable mod_cgi" ON \ + CHARSET_LITE "Enable mod_charset_lite" ON \ + DBD "Enable mod_dbd" OFF \ + DEFLATE "Enable mod_deflate" ON \ + DIR "Enable mod_dir" ON \ + DUMPIO "Enable mod_dumpio" ON \ + ENV "Enable mod_env" ON \ + EXPIRES "Enable mod_expires" ON \ + HEADERS "Enable mod_headers" ON \ + IMAGEMAP "Enable mod_imagemap" ON \ + INCLUDE "Enable mod_include" ON \ + INFO "Enable mod_info" ON \ + LOG_CONFIG "Enable mod_log_config" ON \ + LOGIO "Enable mod_logio" ON \ + MIME "Enable mod_mime" ON \ + MIME_MAGIC "Enable mod_mime_magic" ON \ + NEGOTIATION "Enable mod_negotiation" ON \ + REWRITE "Enable mod_rewrite" ON \ + SETENVIF "Enable mod_setenvif" ON \ + SPELING "Enable mod_speling" ON \ + STATUS "Enable mod_status" ON \ + UNIQUE_ID "Enable mod_unique_id" ON \ + USERDIR "Enable mod_userdir" ON \ + USERTRACK "Enable mod_usertrack" ON \ + VHOST_ALIAS "Enable mod_vhost_alias" ON \ + FILTER "Enable mod_filter" ON \ + VERSION "Enable mod_version" ON \ + PROXY "Enable mod_proxy" OFF \ + PROXY_CONNECT "Enable mod_proxy_connect" OFF \ + PROXY_FTP "Enable mod_proxy_ftp" OFF \ + PROXY_HTTP "Enable mod_proxy_http" OFF \ + PROXY_AJP "Enable mod_proxy_ajp" OFF \ + PROXY_BALANCER "Enable mod_proxy_balancer" OFF \ + SSL "Enable mod_ssl" ON \ + SUEXEC "Enable mod_suexec" OFF \ + CGID "Enable mod_cgid" OFF \ + diff --git a/www/apache22/files/apache22.sh.in b/www/apache22/files/apache22.sh.in index 1ff6101c637b..861733f77e78 100644 --- a/www/apache22/files/apache22.sh.in +++ b/www/apache22/files/apache22.sh.in @@ -1,6 +1,6 @@ #!/bin/sh # -# $FreeBSD: /tmp/pcvs/ports/www/apache22/files/Attic/apache22.sh.in,v 1.4 2007-09-09 14:55:17 clement Exp $ +# $FreeBSD: /tmp/pcvs/ports/www/apache22/files/Attic/apache22.sh.in,v 1.5 2007-09-18 20:03:15 clement Exp $ # # PROVIDE: apache22 @@ -116,6 +116,11 @@ apache22_requirepidfile() apache22_checkconfig() { + if test -f %%PREFIX%%/sbin/envvars + then + . %%PREFIX%%/sbin/envvars + fi + echo "Performing sanity check on apache22 configuration:" eval ${command} ${apache22_flags} -t } @@ -138,11 +143,6 @@ apache22_precmd() { apache22_checkconfig - if test -f %%PREFIX%%/sbin/envvars - then - . %%PREFIX%%/sbin/envvars - fi - if checkyesno apache22limits_enable then eval `/usr/bin/limits ${apache22limits_args}` 2>/dev/null |