aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-06-07 11:29:27 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-06-07 11:29:27 +0800
commit3e594718609bed8865f475d54ca534f4f60beb80 (patch)
tree545f42454277b5aa3bed780c196b7cdc47f4ac34
parent8d937ad5575902c50ace8efeae70091fba2b9cf2 (diff)
downloadfreebsd-ports-gnome-3e594718609bed8865f475d54ca534f4f60beb80.tar.gz
freebsd-ports-gnome-3e594718609bed8865f475d54ca534f4f60beb80.tar.zst
freebsd-ports-gnome-3e594718609bed8865f475d54ca534f4f60beb80.zip
- Convert from pre-everything to OPTIONS
-rw-r--r--www/mod_accounting/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/mod_accounting/Makefile b/www/mod_accounting/Makefile
index b4dad01729d8..a36246ca5df0 100644
--- a/www/mod_accounting/Makefile
+++ b/www/mod_accounting/Makefile
@@ -17,9 +17,14 @@ COMMENT= An Apache module that records traffic statistics into a database
MAKE_JOBS_SAFE= yes
+OPTIONS= MYSQL "Enable MySQL support" on \
+ PGSQL "Enable PGSQL support" on
+
USE_APACHE= 13
MAKE_ARGS+= APXS="${APXS}"
+.include <bsd.port.options.mk>
+
.if defined(WITHOUT_PGSQL)
MAKE_ARGS+= WITHOUT_PGSQL=YES
.else
@@ -34,12 +39,6 @@ USE_MYSQL= YES
PORTDOCS= README FAQ.txt LICENSE
-pre-everything::
- @${ECHO} ""
- @${ECHO} " WITHOUT_MYSQL Disable MySQL support"
- @${ECHO} " WITHOUT_PGSQL Disable PostgreSQL support"
- @${ECHO} ""
-
post-install:
@${MKDIR} ${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/schema.sql ${DATADIR}/