aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-17 15:26:23 +0800
committerpav <pav@FreeBSD.org>2004-08-17 15:26:23 +0800
commit3e799cae62c639ca41faac04ff13986787abbe61 (patch)
treee76f84d85a711c58dc65c60ec8d21ece1e5d9332
parent9581648190668d4df044bc808612e7c9ba3337bd (diff)
downloadfreebsd-ports-gnome-3e799cae62c639ca41faac04ff13986787abbe61.tar.gz
freebsd-ports-gnome-3e799cae62c639ca41faac04ff13986787abbe61.tar.zst
freebsd-ports-gnome-3e799cae62c639ca41faac04ff13986787abbe61.zip
- Update to 0.6.0
PR: ports/70554 Submitted by: Jean-Yves Lefort <jylefort@brutele.be> (maintainer)
-rw-r--r--mail/mail-notification/Makefile34
-rw-r--r--mail/mail-notification/distinfo4
-rw-r--r--mail/mail-notification/pkg-descr13
-rw-r--r--mail/mail-notification/pkg-plist15
4 files changed, 43 insertions, 23 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index 7ce2cf1be6a3..51ce6b24d5ef 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mail-notification
-PORTVERSION= 0.5.0
-CATEGORIES= mail
+PORTVERSION= 0.6.0
+CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
@@ -18,13 +18,17 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack eel2
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= MBOX "mbox support" on \
MH "MH support" on \
MAILDIR "Maildir support" on \
POP3 "POP3 support" on \
+ IMAP "IMAP support" on \
+ SSL "SSL support" on \
+ SASL "SASL authentication support" on \
SYLPHEED "Sylpheed support" on \
GMAIL "Gmail support" on
@@ -41,8 +45,14 @@ CONFIGURE_ARGS+= --disable-maildir
.endif
.if defined(WITHOUT_POP3)
CONFIGURE_ARGS+= --disable-pop3
-.else
-LIB_DEPENDS+= gnet-2.0:${PORTSDIR}/net/gnet2
+.endif
+.if defined(WITHOUT_IMAP)
+CONFIGURE_ARGS+= --disable-imap
+.endif
+.if defined(WITHOUT_POP3) && defined(WITHOUT_IMAP)
+# only POP3 and IMAP use SSL and SASL
+WITHOUT_SSL= yes
+WITHOUT_SASL= yes
.endif
.if defined(WITHOUT_SYLPHEED)
CONFIGURE_ARGS+= --disable-sylpheed
@@ -53,4 +63,16 @@ CONFIGURE_ARGS+= --disable-gmail
LIB_DEPENDS+= soup-2.0:${PORTSDIR}/devel/libsoup
.endif
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --disable-ssl
+.else
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.endif
+.if defined(WITHOUT_SASL)
+CONFIGURE_ARGS+= --disable-sasl
+.else
+LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
.include <bsd.port.post.mk>
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
index a5336d5bde5c..d6c27ca2ddd4 100644
--- a/mail/mail-notification/distinfo
+++ b/mail/mail-notification/distinfo
@@ -1,2 +1,2 @@
-MD5 (mail-notification-0.5.0.tar.gz) = 97efb33125bdfe9d4cec8a63ff4d4cb6
-SIZE (mail-notification-0.5.0.tar.gz) = 244997
+MD5 (mail-notification-0.6.0.tar.gz) = 7685358dcacac190cf775a8e7ab2ae74
+SIZE (mail-notification-0.6.0.tar.gz) = 362576
diff --git a/mail/mail-notification/pkg-descr b/mail/mail-notification/pkg-descr
index 55837340787b..c403ee7e92dc 100644
--- a/mail/mail-notification/pkg-descr
+++ b/mail/mail-notification/pkg-descr
@@ -7,11 +7,14 @@ Xfce Notification Area and the KDE System Tray.
Mail Notification features include:
- - multiple mailbox support
- - mbox, MH, Maildir, Sylpheed and POP3 support
- - automatic detection of mailbox format
- - automatic notification
- - HIG compliance
+ * multiple mailbox support
+ * mbox, MH, Maildir, Sylpheed, POP3, IMAP and Gmail support
+ * SASL authentication support
+ * APOP authentication support
+ * SSL support
+ * automatic detection of mailbox format
+ * automatic notification
+ * HIG 2.0 compliance
WWW: http://www.nongnu.org/mailnotify/
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
index 8320225421e7..80d78b276202 100644
--- a/mail/mail-notification/pkg-plist
+++ b/mail/mail-notification/pkg-plist
@@ -2,26 +2,21 @@ bin/mail-notification
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/mail-notification.schemas > /dev/null || /usr/bin/true
etc/gconf/schemas/mail-notification.schemas
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/mail-notification.schemas > /dev/null || /usr/bin/true
+etc/sound/events/mail-notification.soundlist
+libdata/bonobo/servers/GNOME_MailNotification_Automation.server
share/gnome/applications/mail-notification.desktop
+share/gnome/control-center-2.0/capplets/mail-notification-properties.desktop
share/gnome/help/mail-notification/C/documentation-license.xml
-share/gnome/help/mail-notification/C/figures/mail-error.png
share/gnome/help/mail-notification/C/figures/mail.png
-share/gnome/help/mail-notification/C/figures/no-mail-error.png
-share/gnome/help/mail-notification/C/figures/no-mail.png
share/gnome/help/mail-notification/C/mail-notification.xml
share/gnome/help/mail-notification/C/software-license.xml
share/gnome/mail-notification/ui/about-icon.png
share/gnome/mail-notification/ui/dialog.glade
share/gnome/mail-notification/ui/gmail.png
share/gnome/mail-notification/ui/logo.png
-share/gnome/mail-notification/ui/mail-error.png
-share/gnome/mail-notification/ui/mail.png
share/gnome/mail-notification/ui/mailbox-properties.glade
-share/gnome/mail-notification/ui/menu.glade
-share/gnome/mail-notification/ui/no-mail-error.png
-share/gnome/mail-notification/ui/no-mail.png
-share/gnome/mail-notification/ui/preferences-icon.png
-share/gnome/mail-notification/ui/preferences.glade
+share/gnome/mail-notification/ui/properties-icon.png
+share/gnome/mail-notification/ui/properties.glade
share/gnome/mail-notification/ui/unsupported.png
share/gnome/omf/mail-notification/mail-notification-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/mail-notification/mail-notification-C.omf 2>/dev/null || /usr/bin/true