aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-19 07:09:58 +0800
committerbapt <bapt@FreeBSD.org>2012-12-19 07:09:58 +0800
commit3f2ab89d5deaa9104a52cfe2720139df1f51eb28 (patch)
tree54f365dd93e9a22403596907534617c789e9b454
parent79e1a83e414e54f2b087c20cd4925a0fab93e0bc (diff)
downloadfreebsd-ports-gnome-3f2ab89d5deaa9104a52cfe2720139df1f51eb28.tar.gz
freebsd-ports-gnome-3f2ab89d5deaa9104a52cfe2720139df1f51eb28.tar.zst
freebsd-ports-gnome-3f2ab89d5deaa9104a52cfe2720139df1f51eb28.zip
Update to 1.5.0 (compatible with icu 50.1)
Approved by: bland (maintainer)
-rw-r--r--devel/py-icu/Makefile9
-rw-r--r--devel/py-icu/distinfo4
-rw-r--r--devel/py-icu/files/patch-format.cpp40
-rw-r--r--devel/py-icu/files/patch-numberformat.cpp57
4 files changed, 4 insertions, 106 deletions
diff --git a/devel/py-icu/Makefile b/devel/py-icu/Makefile
index 2779d296169b..0e1e9fa07212 100644
--- a/devel/py-icu/Makefile
+++ b/devel/py-icu/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: py-icu
-# Date created: 26 Sep 2008
-# Whom: bland@FreeBSD.org
-#
+# Created by: bland@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= icu
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.5
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/P/PyICU
diff --git a/devel/py-icu/distinfo b/devel/py-icu/distinfo
index da18223486d7..95066ed695b5 100644
--- a/devel/py-icu/distinfo
+++ b/devel/py-icu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PyICU-1.1.tar.gz) = 986f625f210439400343c6fd299af380c1fd018d5884720801331be850e2b7e2
-SIZE (PyICU-1.1.tar.gz) = 102194
+SHA256 (PyICU-1.5.tar.gz) = 7597ae80f8bbfed5ff321c6c3ed7200ef07d546a26ee8a08dc1ce578a9e33b04
+SIZE (PyICU-1.5.tar.gz) = 207257
diff --git a/devel/py-icu/files/patch-format.cpp b/devel/py-icu/files/patch-format.cpp
deleted file mode 100644
index 6557cf571757..000000000000
--- a/devel/py-icu/files/patch-format.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./format.cpp.orig 2010-12-10 22:25:44.000000000 +0100
-+++ ./format.cpp 2011-07-10 22:21:04.787715370 +0200
-@@ -31,6 +31,10 @@
- #include "dateformat.h"
- #include "numberformat.h"
-
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ DECLARE_CONSTANTS_TYPE(UTimeUnitFormatStyle);
-+#endif
-+
- /* FieldPosition */
-
- class t_fieldposition : public _wrapper {
-@@ -728,7 +732,11 @@
- static int t_timeunitformat_init(t_timeunitformat *self,
- PyObject *args, PyObject *kwds)
- {
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ UTimeUnitFormatStyle style;
-+#else
- TimeUnitFormat::EStyle style;
-+#endif
- Locale *locale;
-
- switch (PyTuple_Size(args)) {
-@@ -1712,8 +1720,13 @@
-
- INSTALL_STATIC_INT(FieldPosition, DONT_CARE);
-
--#if U_ICU_VERSION_HEX >= 0x04020000
-+#if U_ICU_VERSION_HEX >= 0x04020000 && U_ICU_VERSION_HEX < 0x04080000
- INSTALL_STATIC_INT(TimeUnitFormat, kFull);
- INSTALL_STATIC_INT(TimeUnitFormat, kAbbreviate);
- #endif
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ INSTALL_CONSTANTS_TYPE(UTimeUnitFormatStyle, m);
-+ INSTALL_ENUM(UTimeUnitFormatStyle, "FULL", UTMUTFMT_FULL_STYLE);
-+ INSTALL_ENUM(UTimeUnitFormatStyle, "ABBREVIATED", UTMUTFMT_ABBREVIATED_STYLE);
-+#endif
- }
diff --git a/devel/py-icu/files/patch-numberformat.cpp b/devel/py-icu/files/patch-numberformat.cpp
deleted file mode 100644
index d6bba0adfc5b..000000000000
--- a/devel/py-icu/files/patch-numberformat.cpp
+++ /dev/null
@@ -1,57 +0,0 @@
---- ./numberformat.cpp.orig 2010-04-16 04:29:22.000000000 +0200
-+++ ./numberformat.cpp 2011-07-10 22:23:26.996346842 +0200
-@@ -30,6 +30,10 @@
- #include "numberformat.h"
- #include "macros.h"
-
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ DECLARE_CONSTANTS_TYPE(UCurrencySpacing);
-+#endif
-+
- /* DecimalFormatSymbols */
-
- class t_decimalformatsymbols : public _wrapper {
-@@ -502,7 +506,11 @@
-
- static PyObject *t_decimalformatsymbols_getPatternForCurrencySpacing(t_decimalformatsymbols *self, PyObject *args)
- {
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ UCurrencySpacing type;
-+#else
- DecimalFormatSymbols::ECurrencySpacing type;
-+#endif
- UBool beforeCurrency;
-
- if (!parseArgs(args, "ib", &type, &beforeCurrency))
-@@ -518,7 +526,11 @@
- static PyObject *t_decimalformatsymbols_setPatternForCurrencySpacing(t_decimalformatsymbols *self, PyObject *args)
- {
- UnicodeString *u, _u;
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ UCurrencySpacing type;
-+#else
- DecimalFormatSymbols::ECurrencySpacing type;
-+#endif
- UBool beforeCurrency;
-
- if (!parseArgs(args, "ibS", &type, &beforeCurrency, &u, &_u))
-@@ -2286,12 +2298,18 @@
- INSTALL_STATIC_INT(DecimalFormatSymbols, kNaNSymbol);
- INSTALL_STATIC_INT(DecimalFormatSymbols, kSignificantDigitSymbol);
-
--#if U_ICU_VERSION_HEX >= 0x04020000
-+#if U_ICU_VERSION_HEX >= 0x04020000 && U_ICU_VERSION_HEX < 0x04080000
- INSTALL_STATIC_INT(DecimalFormatSymbols, kCurrencyMatch);
- INSTALL_STATIC_INT(DecimalFormatSymbols, kSurroundingMatch);
- INSTALL_STATIC_INT(DecimalFormatSymbols, kInsert);
- INSTALL_STATIC_INT(DecimalFormatSymbols, kCurrencySpacingCount);
- #endif
-+#if U_ICU_VERSION_HEX >= 0x04080000
-+ INSTALL_CONSTANTS_TYPE(UCurrencySpacing, m);
-+ INSTALL_ENUM(UCurrencySpacing, "MATCH", UNUM_CURRENCY_MATCH);
-+ INSTALL_ENUM(UCurrencySpacing, "SURROUNDING_MATCH", UNUM_CURRENCY_SURROUNDING_MATCH);
-+ INSTALL_ENUM(UCurrencySpacing, "INSERT", UNUM_CURRENCY_INSERT);
-+#endif
-
- INSTALL_STATIC_INT(NumberFormat, kIntegerField);
- INSTALL_STATIC_INT(NumberFormat, kFractionField);