aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-04-11 21:44:56 +0800
committerpav <pav@FreeBSD.org>2008-04-11 21:44:56 +0800
commit403bd2afd00993eec8b1f8db6936b506a3221302 (patch)
tree5e5e7f13bebb30588bd120fa9b2b7e0460d2bd1a
parentb5c8d5cd1d62732a4920ff05d795cf4578f1891e (diff)
downloadfreebsd-ports-gnome-403bd2afd00993eec8b1f8db6936b506a3221302.tar.gz
freebsd-ports-gnome-403bd2afd00993eec8b1f8db6936b506a3221302.tar.zst
freebsd-ports-gnome-403bd2afd00993eec8b1f8db6936b506a3221302.zip
- Update to 2.1pre33
PR: ports/121886 Submitted by: bf <bf2006a@yahoo.com> Approved by: maintainer timeout (demon; 3 weeks)
-rw-r--r--www/links/Makefile46
-rw-r--r--www/links/distinfo6
-rw-r--r--www/links/files/patch-ab14
-rw-r--r--www/links/files/patch-default.c8
-rw-r--r--www/links/files/patch-regexp.c19
-rw-r--r--www/links/files/patch-types.c8
6 files changed, 36 insertions, 65 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index ddc843e098f5..e7f925665ad1 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -6,61 +6,65 @@
#
PORTNAME= links
-PORTVERSION= 2.1.p28
+DISTVERSION= 2.1pre33
PORTEPOCH= 1
CATEGORIES?= www
MASTER_SITES= http://links.twibright.com/download/
-DISTNAME= ${PORTNAME}-2.1pre28
MAINTAINER?= demon@FreeBSD.org
COMMENT= Lynx-like text WWW browser
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+CONFLICTS= links-0*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-javascript --with-ssl
-CONFIGURE_ENV+= CPPFLAGS='-I${LOCALBASE}/include'
+CONFIGURE_ARGS+= --with-ssl --without-pmshell --without-atheos \
+ --without-gpm --without-fb
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
USE_BZIP2= yes
OPTIONS= SVGALIB "non-X11 graphics support" off \
+ DIRECTFB "directfb driver support" off \
X11 "X11 graphics support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_SVGALIB)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib \
- png.5:${PORTSDIR}/graphics/png \
+.ifdef(WITH_SVGALIB) || defined(WITH_X11) || defined(WITH_DIRECTFB)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --enable-graphics
-OPTIONS_MESG= "non-X11 graphics support enabled, "
+.else
+CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
+.endif
+
+.ifdef(WITH_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+CONFIGURE_ARGS+= --with-svgalib
.else
CONFIGURE_ARGS+= --without-svgalib
-OPTIONS_MESG= "non-X11 graphics support disabled, "
+.endif
+
+.ifdef(WITH_DIRECTFB)
+LIB_DEPENDS+= libdirectfb:${PORTSDIR}/devel/directfb
+CONFIGURE_ARGS+= --with-directfb
+.else
+CONFIGURE_ARGS+= --without-directfb
.endif
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- tiff.4:${PORTSDIR}/graphics/tiff
-USE_XORG= x11
-CONFIGURE_ARGS+= --enable-graphics --with-x
-OPTIONS_MESG+= "X11 graphics support enabled."
+USE_XORG= x11 xproto
+CONFIGURE_ARGS+= --with-x
.else
CONFIGURE_ARGS+= --without-x
-OPTIONS_MESG+= "X11 graphics support disabled."
.endif
MAN1= links.1
PLIST_FILES= bin/links
-pre-everything::
- @${ECHO_MSG} ${OPTIONS_MESG}
-
post-patch:
- @${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/default.c
+ @${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/os_dep.h
.include <bsd.port.post.mk>
diff --git a/www/links/distinfo b/www/links/distinfo
index 1645f0ca92c9..ccce01c4fe61 100644
--- a/www/links/distinfo
+++ b/www/links/distinfo
@@ -1,3 +1,3 @@
-MD5 (links-2.1pre28.tar.bz2) = 815afe558dd548258eeb03b01cce01ce
-SHA256 (links-2.1pre28.tar.bz2) = 203531be7c84ebe3a5d53c6d6cda4f4a27626dec620ec5aa8926414d0bee5995
-SIZE (links-2.1pre28.tar.bz2) = 3915943
+MD5 (links-2.1pre33.tar.bz2) = 99cdbd1194579eea6d857168a57e0d74
+SHA256 (links-2.1pre33.tar.bz2) = 1f6be6db54eb5fb2947926b5214879c260030da9909c1d189d053d8dc3357f98
+SIZE (links-2.1pre33.tar.bz2) = 3817630
diff --git a/www/links/files/patch-ab b/www/links/files/patch-ab
deleted file mode 100644
index cf7fa0d78353..000000000000
--- a/www/links/files/patch-ab
+++ /dev/null
@@ -1,14 +0,0 @@
---- kbd.c.orig Sat Oct 12 19:47:58 2002
-+++ kbd.c Sat Mar 1 16:03:31 2003
-@@ -746,9 +746,9 @@
- case 'B': ev.x = KBD_DOWN; break;
- case 'C': ev.x = KBD_RIGHT; break;
- case 'D': ev.x = KBD_LEFT; break;
-- case 'F':
-+ case 'F': ev.x = KBD_END; break;
- case 'e': ev.x = KBD_END; break;
-- case 'H':
-+ case 'H': ev.x = KBD_HOME; break;
- case 0: ev.x = KBD_HOME; break;
- case 'I': ev.x = KBD_PAGE_UP; break;
- case 'G': ev.x = KBD_PAGE_DOWN; break;
diff --git a/www/links/files/patch-default.c b/www/links/files/patch-default.c
index 02295e855138..9d2d8aa26d88 100644
--- a/www/links/files/patch-default.c
+++ b/www/links/files/patch-default.c
@@ -1,11 +1,11 @@
---- default.c.orig Tue Feb 11 21:54:38 2003
-+++ default.c Sat Mar 1 16:03:31 2003
-@@ -300,7 +300,7 @@
+--- default.c.orig 2008-03-06 22:43:25.117856165 -0500
++++ default.c 2008-03-06 22:44:12.412560939 -0500
+@@ -400,7 +400,7 @@
get_system_name();
links_home = get_home(&first_use);
if (!links_home) {
- fprintf(stderr, "Unable to find or create links config directory. Please check, that you have $HOME variable set correctly and that you have write permission to your home directory.\n\007");
-+ fprintf(stderr, "Unable to find or create links config directory. Please check, that you have set the $HOME variable correctly and that you have write permission to your home directory.\n");
++ fprintf(stderr, "Unable to find or create links config directory. Please check, that you have $HOME variable set correctly and that you have write permission to your home directory.\n");
sleep(3);
return;
}
diff --git a/www/links/files/patch-regexp.c b/www/links/files/patch-regexp.c
deleted file mode 100644
index 37e75006e285..000000000000
--- a/www/links/files/patch-regexp.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- regexp.c~ Fri Nov 25 02:38:35 2005
-+++ regexp.c Tue Jan 24 12:39:04 2006
-@@ -148,6 +148,7 @@
- #ifdef HAVE_PCRE
- const char *er_ptr;
- int erroffset;
-+ pcre *ppat;
- #else
- regmatch_t pmat[MAXCAPTURE/3];
- regex_t ppat_data;
-@@ -197,7 +198,7 @@
- #endif /* REGEX_DEBUG */
-
- #ifdef HAVE_PCRE
-- pcre *ppat = pcre_compile(pom, 0/*PCRE_ANCHORED*/, &er_ptr, &erroffset, NULL);
-+ ppat = pcre_compile(pom, 0/*PCRE_ANCHORED*/, &er_ptr, &erroffset, NULL);
- pcre_free(pom);
- #else /* HAVE_PCRE */
- ppat = &ppat_data;
diff --git a/www/links/files/patch-types.c b/www/links/files/patch-types.c
index e68d4a8041db..8ae54bd353b8 100644
--- a/www/links/files/patch-types.c
+++ b/www/links/files/patch-types.c
@@ -1,11 +1,11 @@
---- types.c.orig Thu Jul 5 13:10:37 2007
-+++ types.c Thu Jul 5 13:12:07 2007
-@@ -807,7 +807,8 @@
+--- types.c.orig 2008-03-19 18:18:18.614955994 -0400
++++ types.c 2008-03-19 18:21:18.345245179 -0400
+@@ -820,7 +820,8 @@
ext = NULL;
}
if (ext) while (ext[extl] && ext[extl] != '.' && !dir_sep(ext[extl]) && !end_of_dir(url, ext[extl])) extl++;
- if ((extl == 3 && !casecmp(ext, "htm", 3)) ||
-+ if (force_html ||
++ if (force_html ||
+ (extl == 3 && !casecmp(ext, "htm", 3)) ||
(extl == 4 && !casecmp(ext, "html", 4))) return stracpy("text/html");
foreach(e, extensions) {