aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-04-06 01:32:30 +0800
committermezz <mezz@FreeBSD.org>2008-04-06 01:32:30 +0800
commit41255bd51508c4744f42b5ec57604060b222a093 (patch)
treea70d76ff9815131728bb605969999ec541646739
parentcc9d30f1f6c72468f1d86ebdb369026f0b011d1d (diff)
downloadfreebsd-ports-gnome-41255bd51508c4744f42b5ec57604060b222a093.tar.gz
freebsd-ports-gnome-41255bd51508c4744f42b5ec57604060b222a093.tar.zst
freebsd-ports-gnome-41255bd51508c4744f42b5ec57604060b222a093.zip
Fix the crash by clock-applet when add to the panel. Bump the PORTREVISION.
PR: ports/122455 Submitted by: fukui <fukui.FreeBSD@fanet.net> Obtained from: Its SVN
-rw-r--r--x11/gnome-panel/Makefile2
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_set-timezone.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index a459bdeeb665..817e3850b5cc 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnome-panel
PORTVERSION= 2.22.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-panel/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/x11/gnome-panel/files/patch-applets_clock_set-timezone.c b/x11/gnome-panel/files/patch-applets_clock_set-timezone.c
new file mode 100644
index 000000000000..3a9fb4ae9fa8
--- /dev/null
+++ b/x11/gnome-panel/files/patch-applets_clock_set-timezone.c
@@ -0,0 +1,22 @@
+--- trunk/applets/clock/set-timezone.c 2008/02/28 20:48:16 10908
++++ applets/clock/set-timezone.c 2008/04/02 15:08:34 10972
+@@ -139,6 +139,9 @@
+ DBusError dbus_error;
+ gint res = 0;
+
++ pk_caller = NULL;
++ pk_action = NULL;
++
+ system_bus = dbus_g_connection_get_connection (get_system_bus ());
+ if (system_bus == NULL)
+ goto out;
+@@ -147,9 +150,6 @@
+ if (pk_context == NULL)
+ goto out;
+
+- pk_caller = NULL;
+- pk_action = NULL;
+-
+ pk_action = polkit_action_new ();
+ polkit_action_set_action_id (pk_action, pk_action_id);
+
/+11 * - Correct DEPENDSmiwi2012-03-171-6/+9 * - fix build with ruby19dinoex2012-03-163-7/+23 * Remove optional dep on net/socks5jpaetzel2012-03-121-6/+0 * - Update to 0.3.7miwi2012-03-045-36/+20 * Restore missing DEBUG optioncrees2012-02-281-0/+6 * - Uptade to 1.6 [1]jlaffaye2012-02-273-9/+25 * Remove optional build dep on net/socks5, which is exiting the ports tree.jpaetzel2012-02-271-5/+0 * Remove optional dep on net/socks5, which is exiting the ports tree. With a bitjpaetzel2012-02-271-8/+1 * - Add patch to fix CVE-2012-0806swills2012-02-262-0/+142 * - Chase Emacs updatesashish2012-02-222-2/+2 * - Update to 20120219culot2012-02-212-4/+4 * - Update to v3.0.5brix2012-02-203-38/+3 * - Update to 20120110miwi2012-02-192-3/+3 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-162-1/+2 * Bump pcre library dependency due to 8.30 updatemm2012-02-141-1/+2 * - Update to 20120213 (0.3.7-rc2)jgh2012-02-142-7/+7 * Remove optional dependancy on net/socks5, which will be exiting the portsjpaetzel2012-02-131-7/+1 * Remove the option of building against net/socks5, as this port will bejpaetzel2012-02-131-11/+1 * - Update to 20120205 (0.3.7-rc1)miwi2012-02-074-15/+30 * - Update to 0.204miwi2012-01-293-4/+4 * - Update to 0.73miwi2012-01-283-3/+4 * - Add INSPIRCD_LOG and INSPIRCD_RUN substitution patterns forpawel2012-01-261-1/+4 * At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-225-5/+5 * Remove license infodougb2012-01-202-4/+0 * - escape shell namesdinoex2012-01-141-1/+1 * In the rc.d scripts, change assignments to rcvar to use thedougb2012-01-1423-23/+23 * - Update to 0.89miwi2012-01-142-3/+3 * Update to 3.2.9crees2011-12-286-26/+41 * End WWW CPAN URL with a "/"ehaupt2011-12-281-1/+1 * Pacify portlintehaupt2011-12-271-2/+2 * - Update to 1.8.7dhn2011-12-242-3/+3 * - Point at the homepage consistently as defined by rubygems.orgpgollucci2011-12-201-1/+1 * Update MASTER_SITEScrees2011-12-202-8/+4 * Make the IGNORE message more informative.linimon2011-12-121-1/+1 * Update to 1.4makc2011-12-063-52/+25 * - Update to v3.0.4brix2011-12-052-3/+4 * - Update to 6.76miwi2011-12-043-5/+5 * - Update to 6.75miwi2011-11-282-3/+3 * - Update to 1.54culot2011-11-282-3/+3 * Remove trailing whitespaces.ehaupt2011-11-191-1/+1 * Remove CMAKE_USE_PTHREAD from the ports using it.rakuco2011-11-142-2/+0 * Make @dirrms conditional for %%DOCSDIR%% on NOPORTDOCScrees2011-11-142-4/+4 * - Update to 0.88miwi2011-11-062-3/+3 * - Update to 1.18miwi2011-11-062-3/+3 * - Update to 20111030miwi2011-11-062-4/+4 * Update to 20111023cs2011-11-052-5/+5 * Remove references to unsupported FreeBSD versions. Mostly of the form:dougb2011-11-021-7/+1 * Update to 0.7.3makc2011-10-314-5/+104 * A simple, friendly DSL for creating IRC botspgollucci2011-10-304-0/+30 * - bump for miniupnpc updatedinoex2011-10-271-1/+2 * The vast majority of pkg-descr files had the following format when theydougb2011-10-243-5/+2 * Remove more tags from pkg-descr files fo the form:dougb2011-10-245-18/+0 * - Update to 0.202miwi2011-10-234-111/+124 * - Update to 6.74miwi2011-10-232-3/+3 * - Update to 0.3.6miwi2011-10-236-15/+56 * - Update to 20111020culot2011-10-213-5/+6 * - Chase editors/emacs updateashish2011-10-172-2/+2 * - Update to 1.53culot2011-10-142-3/+3 * - Update to 20111010crees2011-10-132-18/+18 * Remove ports maintainted by ports@ which have passed their EXPIRATION_DATEdougb2011-10-0929-2472/+0 * - Update to 1.52sunpoet2011-10-082-5/+8 * - Update to 0.12sunpoet2011-10-072-3/+3 * - Add upstream patch to address segfault issue with tcl-8.6beech2011-10-072-3/+24 * - update to 0.18dinoex2011-10-054-7/+6 * - Update to 20111002 (0.3.6-rc1)eadler2011-10-032-5/+5 * Stop maintaining irc/ninjacrees2011-09-251-1/+1 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-2416-37/+30 * - Update to 20110915beech2011-09-202-5/+5 * - Change PERL_CONFIGURE to "yes" for all values less than or equal to 5.8.0+sunpoet2011-09-171-1/+1 * Chase editors/emacs updateashish2011-09-082-2/+2 * - update to 3.27dinoex2011-09-043-8/+20 * Remove expired ports:crees2011-09-0314-356/+0 * Chase editors/emacs update.ashish2011-08-282-1/+2 * Update Pidgin and friends to 2.10.0. Seemarcus2011-08-282-3/+3 * - Update to 6.70miwi2011-08-262-5/+5 * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ...kwm2011-08-242-1/+12 * - Update to 20110817beech2011-08-185-6/+44 * A PoCo-IRC plugin which provides access to a Hailo conversation simulator.swills2011-08-155-0/+52 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-122-2/+1 * - Fix MASTER_SITESehaupt2011-08-111-6/+10 * Update to 2.2.3ehaupt2011-08-085-63/+47 * - update WWWdinoex2011-08-071-1/+1 * - Make use of CPAN:USER macroswills2011-08-071-6/+9 * - Make use of CPAN:USER macroswills2011-08-071-4/+8 * - Update WWW: linetota2011-08-041-1/+1 * Deprecate some ports where I can't find distfiles and upstreambapt2011-08-033-0/+9 * Update master_sitebapt2011-08-021-1/+1 * - Update to 0.11culot2011-08-012-3/+6 * - Sort SUBDIRssunpoet2011-08-011-1/+1 * - Chase guile shared lib bumpjlaffaye2011-07-311-2/+2 * - Fix build with Ruby 1.9swills2011-07-311-1/+2 * Build fixes with glib 2.28. gtk 2.24, gtkmm 2.24 and vala 0.12.kwm2011-07-301-0/+1 * - Update to 20110228sylvio2011-07-283-12/+11 * Import version 1.2 of inspircd -- 'there's no m_codepage for 2.x yet'.crees2011-07-277-0/+726 * - Fix build after recent gnutls updatepav2011-07-271-1/+2 * Add ability to run as ircd user/groupzi2011-07-252-4/+22 * - Reset maintainership (5 simultaneous timeouts since Sep/2009)crees2011-07-251-4/+4 * - Fix building of port due to gnutls update which removes gcrypt supportashish2011-07-183-5/+26 * - Update to 20110714culot2011-07-172-5/+5 * Reassign maintainership to submitter of ports/155143 due to maintainerlinimon2011-07-101-1/+1 * - Use USERS and GROUPScrees2011-07-095-285/+167 * Oops, ${PORTSDIR}/Mk isn't in the search path of course...crees2011-07-071-1/+1 * Make portlint happier.adamw2011-07-061-3/+3 * Use USERS and GROUPScrees2011-07-062-119/+5 * Use USERS and GROUPScrees2011-07-062-86/+7 * ratbox-services now uses USERS and GROUPScrees2011-07-062-83/+4 * Kill EOL whitespace.danfe2011-07-051-2/+2 * - Reassign to the heaptabthorpe2011-07-052-2/+2 * - Use USERS and GROUPScrees2011-07-052-95/+6 * - Use USERS and GROUPScrees2011-07-053-57/+4 * - Mark as broken with Ruby 1.9swills2011-07-051-1/+5 * - Use USERS and GROUPScrees2011-07-032-29/+6 * - Use USERS and GROUPScrees2011-07-032-29/+6 * - Chase the libgcrypt shared lib versionswills2011-07-031-2/+2 * Update Pidgin and friends to 2.9.0. Seemarcus2011-07-032-3/+3 * - Kick MD5 Supportmiwi2011-07-033-3/+0 * - Fix build under clangdb2011-07-011-1/+2 * - Use USERS and GROUPScrees2011-06-293-81/+14 * - Change IGNORE to BROKENbeech2011-06-281-1/+1 * - Mark IGNORE if WITH_SSL is defined, and the system is amd64beech2011-06-281-4/+7 * - Use USERS and GROUPScrees2011-06-282-83/+4 * - Use USERS and GROUPScrees2011-06-282-43/+3 * Bye Byemiwi2011-06-256-108/+0 * - Update to 1.0.2miwi2011-06-252-3/+3 * - Update 0.87miwi2011-06-252-4/+5 * - Update to 1.02miwi2011-06-252-3/+3 * - Cannoicalize the WWW: [again],pgollucci2011-06-241-1/+1 * Drop maintainership and reassign to ports@mm2011-06-221-1/+1 * Respect CC (fixes build with clang)jlaffaye2011-06-211-0/+1 * - Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.az2011-06-201-2/+2 * Chase the libpurple shared lib version.marcus2011-06-202-3/+3 * - remove irc/ezbounce-devel which now lives in irc/ezbounceflo2011-06-196-96/+0 * - bring over version 1.99.15 from irc/ezbounce-devel (soon to be removed)flo2011-06-193-31/+8 * - Use USERS and GROUPScrees2011-06-182-43/+3 * - Update maintainer addresscrees2011-06-172-2/+2 * Mark broken some ports with unfetchable distfilesbapt2011-06-171-0/+2 * - Update to 20110614culot2011-06-152-6/+5 * - Update to 1.49culot2011-06-143-10/+16 * - Update to v3.0.3brix2011-06-132-4/+3 * Remove irc/bitlbee-otr port.ashish2011-06-1311-502/+0 * Hello Mono 2.10!romain2011-06-131-0/+2 * Update to 2.2jlaffaye2011-06-123-7/+10 * - Update to 6.68miwi2011-06-122-8/+13 * - Update to 0.3.5miwi2011-06-123-7/+10 * - switch to USERS/GROUPS macrobapt2011-06-092-54/+6 * Update my e-mail to my FreeBSD one.jlaffaye2011-06-092-2/+2 * Chase security/gnutls update and add an UPDATING entry.novel2011-06-068-10/+15 * - Update 0.098miwi2011-05-264-9/+42 * - Update to 0.10culot2011-05-252-3/+4 * - Update to 1.8.6dhn2011-05-232-4/+3 * - Add licensesylvio2011-05-211-0/+2 * Add USE_NCURSES=yesvanilla2011-05-201-1/+2 * - Add licensesylvio2011-05-181-0/+1 * - Update to 0.8.8sylvio2011-05-183-6/+5 * Miscellaneous cleanups and fixes, some of the windowmaker stuffdougb2011-05-161-1/+1 * - Update to 20110515culot2011-05-152-5/+5 * - honor CCdinoex2011-05-112-0/+8 * - Update to 20110508culot2011-05-092-5/+5 * Add missing manmakc2011-05-081-1/+2 * Update to 4.0.4makc2011-05-083-9/+19 * mark as broken because the distfile is no more availablebapt2011-05-031-0/+2 * Remove unmaintained expired ports from ircbapt2011-05-0211-215/+0 * - Update to 20110501culot2011-05-022-5/+5 * - Update to 1.44culot2011-04-282-10/+9 * - Update to 20110421 (0.3.5-rc1)beech2011-04-242-5/+5 * - Bump PORTREVISION (forgotten with the previous commit,nivit2011-04-221-0/+1 * - Add missing py-twisted* dependencies to RUN_DEPENDSnivit2011-04-211-0/+5 * - Update WWW link.ashish2011-04-171-1/+1 * Take maintainership againmakc2011-04-171-8/+2 * The functions in this module take care of many of the tasks you arejadawin2011-04-135-0/+34 * CMAKE_BUILD_TYPE is set in bsd.cmake.mk now, remove it from Makefilesmakc2011-04-103-14/+0 * - Update to 20110326culot2011-04-033-8/+12 * - Update to v3.0.2brix2011-04-022-3/+3 * irc/ircd-hybrid-ru is now russian/ircd-hybrid-rubapt2011-03-2713-572/+0 * - Update MASTER_SITES and WWW: linemiwi2011-03-273-27/+15 * - Add LICENSE knob(s)mm2011-03-232-1/+7 * - Update to 1.9.4wen2011-03-213-3/+4 * Bump PORTREVISION for ports linking to default libmysqlclient.ale2011-03-194-2/+4 * - Get Rid MD5 supportmiwi2011-03-19114-135/+0 * - Update to 6.54miwi2011-03-182-3/+3 * - Update to 0.5.10miwi2011-03-183-6/+7 * A powerful IRC daemon, based on ircd-ratbox. Utilized on networks such asmiwi2011-03-177-0/+412 * - Update to 2.0.2miwi2011-03-179-252/+155 * Deprecate unmaintained ports from irc where upstream disapear and/orbapt2011-03-154-0/+12 * Update WWWbapt2011-03-152-2/+1 * - Update to 0.96wen2011-03-142-4/+3 * Fix the build with gmake-3.82 by replace space to tab.mezz2011-03-131-0/+19 * - Update to 1.6dhn2011-03-122-4/+3 * Fix lib depends after eggdrop updatebeech2011-03-101-4/+5 * - Update to 20110217miwi2011-03-042-5/+5 * Return these ports to the pool.linimon2011-03-031-1/+1 * Chase after net/openldap24-server update.delphij2011-02-251-1/+1 * - Move to py25 or abovemiwi2011-02-251-2/+2 * - Fix build after irc/eggdrop updatemiwi2011-02-251-2/+2 * - Fix DEPENDSwen2011-02-222-2/+1 * - update to 3.26dinoex2011-02-21