aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-14 22:05:59 +0800
committerbapt <bapt@FreeBSD.org>2013-06-14 22:05:59 +0800
commit4234b39b01d2943efcf79bdbb45b7243b52d7441 (patch)
tree4e913ea63fd7d24d892a89de1f0ad5453be9e9a8
parent4cda975de4173234122c7ef227a3f7c2f4c41198 (diff)
downloadfreebsd-ports-gnome-4234b39b01d2943efcf79bdbb45b7243b52d7441.tar.gz
freebsd-ports-gnome-4234b39b01d2943efcf79bdbb45b7243b52d7441.tar.zst
freebsd-ports-gnome-4234b39b01d2943efcf79bdbb45b7243b52d7441.zip
Use new options helpers
-rw-r--r--net/libvncserver/Makefile41
1 files changed, 15 insertions, 26 deletions
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
index 862be362374e..ec086bc525c2 100644
--- a/net/libvncserver/Makefile
+++ b/net/libvncserver/Makefile
@@ -25,37 +25,26 @@ CONFIGURE_ARGS= --without-x
OPTIONS_DEFINE= GNUTLS OPENSSL GCRYPT IPV6
OPTIONS_DEFAULT= OPENSSL
-GNUTLS_DESC= Enable GnuTLS support
-OPENSSL_DESC= Enable OpenSSL support
-GCRYPT_DESC= Enable libgcrypt support
+GCRYPT_DESC= libgcrypt support
-.include <bsd.port.options.mk>
+GNUTLS_LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
+GNUTLS_CONFIGURE_ON= --with-gnutls
+GNUTLS_CONFIGURE_OFF= --without-gnutls
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-gnutls
-.else
-CONFIGURE_ARGS+= --without-gnutls
-.endif
+OPENSSL_CONFIGURE_ON= --with-ssl
+OPENSSL_CONFIGURE_OFF= --without-crypto --without-ssl
-.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-ssl
-.else
-CONFIGURE_ARGS+= --without-crypto --without-ssl
-.endif
+GCRYPT_LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+GCRYPT_CONFIGURE_ON= --with-gcrypt
+GCRYPT_CONFIGURE_ON= --without-gcrypt
-.if ${PORT_OPTIONS:MGCRYPT}
-LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+= --with-gcrypt
-.else
-CONFIGURE_ARGS+= --without-gcrypt
-.endif
+IPV6_CONFIGURE_ON= --with-ipv6
+IPV6_CONFIGURE_OFF= --without-ipv6
+
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --with-ipv6
-.else
-CONFIGURE_ARGS+= --without-ipv6
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_OPENSSL= yes
.endif
post-patch: