aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-04-24 20:58:02 +0800
committermiwi <miwi@FreeBSD.org>2017-04-24 20:58:02 +0800
commit441443674827629ac9ce6f6b6f43156d04085279 (patch)
treee164a866ccecca209e23c94b5b7bc7ac50ec08d9
parentce6fa757df04f2602a9fc6253d37bd06ca1114c7 (diff)
downloadfreebsd-ports-gnome-441443674827629ac9ce6f6b6f43156d04085279.tar.gz
freebsd-ports-gnome-441443674827629ac9ce6f6b6f43156d04085279.tar.zst
freebsd-ports-gnome-441443674827629ac9ce6f6b6f43156d04085279.zip
- Fix shebangs
Submitted by: Jochen Neumeister (via irc)
-rw-r--r--astro/foxtrotgps/Makefile10
-rw-r--r--cad/brickutils/Makefile6
-rw-r--r--deskutils/gcalcli/Makefile5
-rw-r--r--deskutils/rox-memo/Makefile5
-rw-r--r--net-im/libpurple/Makefile6
-rw-r--r--net/ceph-devel/Makefile8
-rw-r--r--sysutils/cfengine-masterfiles37/Makefile5
-rw-r--r--sysutils/cfengine-masterfiles38/Makefile5
-rw-r--r--www/cppcms/Makefile5
-rw-r--r--www/py-imdbpy/Makefile4
-rw-r--r--x11-fm/sunflower/Makefile4
11 files changed, 44 insertions, 19 deletions
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
index 6208f07d5acb..aec177c38628 100644
--- a/astro/foxtrotgps/Makefile
+++ b/astro/foxtrotgps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= foxtrotgps
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro geography
MASTER_SITES= http://www.foxtrotgps.org/releases/
@@ -14,17 +14,21 @@ LICENSE= GPLv2
LIB_DEPENDS= libcurl.so:ftp/curl \
libexif.so:graphics/libexif \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libsoup-2.4.so:devel/libsoup \
libgps.so:astro/gpsd
GNU_CONFIGURE= yes
CONFIGURE_ENV= DATADIRNAME=share
CONFIGURE_ARGS= --disable-schemas-install
-USES= gettext gmake pkgconfig shebangfix sqlite:3
+USES= gettext gmake pkgconfig python shebangfix sqlite:3
SHEBANG_FILES= contrib/convert2gpx \
contrib/convert2osm \
contrib/georss2foxtrotgps-poi\
- contrib/gpx2osm
+ contrib/gpx2osm \
+ contrib/poi2osm \
+ contrib/osb2foxtrot \
USE_GNOME= gtk20 gconf2 libxml2 intltool libglade2
INSTALLS_ICONS= yes
diff --git a/cad/brickutils/Makefile b/cad/brickutils/Makefile
index deb6d6f42e39..c69992c09ae0 100644
--- a/cad/brickutils/Makefile
+++ b/cad/brickutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= brickutils
PORTVERSION= 0.1.6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}-obsolete/ \
SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}-obsolete/:docs \
@@ -25,8 +25,10 @@ RUN_DEPENDS= ${LOCALBASE}/share/ldraw/models/car.dat:cad/ldraw \
WRKSRC= ${WRKDIR}/BrickUtils-${PORTVERSION}
NO_ARCH= yes
-USES= python:2
+USES= python:2 shebangfix
USE_GNOME= pygtk2
+SHEBANG_FILES= pyBrickUtils.py \
+ BrickUtils/*.py
PORTDOCS= *
diff --git a/deskutils/gcalcli/Makefile b/deskutils/gcalcli/Makefile
index 7ab233459a09..0ed15a2b43b4 100644
--- a/deskutils/gcalcli/Makefile
+++ b/deskutils/gcalcli/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gcalcli
PORTVERSION= 3.2
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils python
MAINTAINER= ports@thelanman.net
@@ -18,8 +18,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2 \
${PYTHON_PKGNAMEPREFIX}python-gflags>=0:devel/py-python-gflags
-USES= python:-2.7
+USES= python:-2.7 shebangfix
USE_GITHUB= yes
+SHEBANG_FILES= gcalcli
GH_ACCOUNT= insanum
diff --git a/deskutils/rox-memo/Makefile b/deskutils/rox-memo/Makefile
index 96bdad6468ae..815d4f6b111f 100644
--- a/deskutils/rox-memo/Makefile
+++ b/deskutils/rox-memo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rox-memo
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= SF/rox/Memo/${PORTVERSION}
DISTNAME= memo-${PORTVERSION}
@@ -13,7 +13,8 @@ COMMENT= Appointment/TODO management for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:devel/py-roxlib
-USES= python tar:bzip2
+USES= python shebangfix tar:bzip2
+SHEBANG_FILES= Memo/AppRun Memo/AppletRun
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index cab6c335699b..8234eef84016 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.12.0
-PORTREVISION?= 0
+PORTREVISION= 1
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
@@ -26,9 +26,11 @@ INSTALL_TARGET= install-strip
.if !defined(PIDGIN_SLAVE)
# Pidgin slave ports that require the following functionality, must explicitly
# set these macros themselves.
-USES+= iconv python
+USES+= iconv python shebangfix
USE_LDCONFIG= yes
WANT_GNOME= yes
+SHEBANG_FILES= libpurple/purple-remote \
+ libpurple/purple-url-handler
.if defined(PACKAGE_BUILDING)
.undef WITHOUT_GNOME
diff --git a/net/ceph-devel/Makefile b/net/ceph-devel/Makefile
index 6861843adaa4..09b63d05718a 100644
--- a/net/ceph-devel/Makefile
+++ b/net/ceph-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ceph
DISTVERSION= wip.v2017-2-14
+PORTREVISION= 1
CATEGORIES= net
PKGNAMESUFFIX= -devel
@@ -72,8 +73,11 @@ CMAKE_ARGS= \
-D WITH_CEPHFS:BOOL=OFF \
-D WITH_EMBEDDED:BOOL=OFF
-USES= gmake cmake:outsource python:2.7 gettext-runtime shebangfix
-SHEBANG_FILES=src/rbdmap src/ceph-post-file.in src/rbd-replay-many
+USES= gmake gettext-runtime cmake:outsource python:2.7 shebangfix
+SHEBANG_FILES= src/rbdmap src/ceph-post-file.in src/rbd-replay-many \
+ src/ceph-rest-api src/ceph-create-keys \
+ src/brag/client/ceph-brag \
+ src/tools/ceph-monstore-update-crush.sh
# even though i386 will build, it is not really advised.
ONLY_FOR_ARCHS= amd64
diff --git a/sysutils/cfengine-masterfiles37/Makefile b/sysutils/cfengine-masterfiles37/Makefile
index a9770dbda1d2..f68d424af757 100644
--- a/sysutils/cfengine-masterfiles37/Makefile
+++ b/sysutils/cfengine-masterfiles37/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cfengine-masterfiles
PORTVERSION= 3.7.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://cfengine-package-repos.s3.amazonaws.com/tarballs/
@@ -26,9 +27,11 @@ FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
CONFLICTS= cfengine-masterfiles[1689]*
MAKE_JOBS_UNSAFE= yes
-USES= cpe
+USES= cpe python:build shebangfix
HAS_CONFIGURE= yes
EXAMPLESDIR= ${PREFIX}/share/examples/cfengine-masterfiles
CONFIGURE_ARGS= --prefix=${EXAMPLESDIR}
+SHEBANG_FILES= modules/packages/apt_get \
+ modules/packages/yum
.include <bsd.port.mk>
diff --git a/sysutils/cfengine-masterfiles38/Makefile b/sysutils/cfengine-masterfiles38/Makefile
index f88ef7355f3c..d77a9d973788 100644
--- a/sysutils/cfengine-masterfiles38/Makefile
+++ b/sysutils/cfengine-masterfiles38/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cfengine-masterfiles
PORTVERSION= 3.8.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://cfengine-package-repos.s3.amazonaws.com/tarballs/
@@ -26,9 +27,11 @@ FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
CONFLICTS= cfengine-masterfiles[1679]*
MAKE_JOBS_UNSAFE= yes
-USES= cpe
+USES= cpe python:build shebangfix
HAS_CONFIGURE= yes
EXAMPLESDIR= ${PREFIX}/share/examples/cfengine-masterfiles
CONFIGURE_ARGS= --prefix=${EXAMPLESDIR}
+SHEBANG_FILES= modules/packages/apt_get \
+ modules/packages/yum
.include <bsd.port.mk>
diff --git a/www/cppcms/Makefile b/www/cppcms/Makefile
index ee7ffade15ef..a103420fb643 100644
--- a/www/cppcms/Makefile
+++ b/www/cppcms/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cppcms
PORTVERSION= 1.0.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www
MASTER_SITES= SF/cppcms/${PORTNAME}/${PORTVERSION}
@@ -15,8 +15,9 @@ BROKEN_powerpc64= Does not build
LIB_DEPENDS= libpcre.so:devel/pcre
-USES= cmake python:2 tar:bzip2 ssl
+USES= cmake python:2 shebangfix tar:bzip2 ssl
USE_LDCONFIG= yes
+SHEBANG_FILES= bin/cppcms_tmpl_cc
OPTIONS_DEFINE= EXAMPLES GCRYPT ICU
OPTIONS_DEFAULT= ICU
diff --git a/www/py-imdbpy/Makefile b/www/py-imdbpy/Makefile
index 2cbfcf4ac4c0..84d8c00634ac 100644
--- a/www/py-imdbpy/Makefile
+++ b/www/py-imdbpy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imdbpy
PORTVERSION= 5.1.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
SF/${PORTNAME}/IMDbPY/${PORTVERSION}
@@ -23,7 +24,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml \
OPTIONS_DEFINE= DOCS
USES= python:2 shebangfix
-SHEBANG_FILES= docs/goodies/reduce.sh
+SHEBANG_FILES= docs/goodies/download_applydiffs.py \
+ docs/goodies/reduce.sh
USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
diff --git a/x11-fm/sunflower/Makefile b/x11-fm/sunflower/Makefile
index 0a66e5c13954..163f066d16e5 100644
--- a/x11-fm/sunflower/Makefile
+++ b/x11-fm/sunflower/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sunflower
DISTVERSION= 0.3-61
+PORTREVISION= 1
CATEGORIES= x11-fm python
MASTER_SITES= http://sunflower-fm.org/pub/
@@ -18,10 +19,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>0:textproc/py-chardet \
WRKSRC= ${WRKDIR}/Sunflower
-USES= desktop-file-utils gettext python:2.7 tar:tgz
+USES= desktop-file-utils gettext python:2.7 shebangfix tar:tgz
USE_GNOME= gtk20 pygtk2 pygobject
NO_ARCH= yes
INSTALLS_ICONS= yes
+SHEBANG_FILES= Sunflower.py
OPTIONS_DEFINE= VTE
OPTIONS_DEFAULT= VTE