aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-08 06:09:51 +0800
committerwill <will@FreeBSD.org>2002-01-08 06:09:51 +0800
commit4432ba2c576c235fc1b82759d3cc71d31aa0ee48 (patch)
tree9843b320772c55a7fe49e389124b9caaee85e386
parentd5021c011c14953c396818d9fbebbb8afd361b0d (diff)
downloadfreebsd-ports-gnome-4432ba2c576c235fc1b82759d3cc71d31aa0ee48.tar.gz
freebsd-ports-gnome-4432ba2c576c235fc1b82759d3cc71d31aa0ee48.tar.zst
freebsd-ports-gnome-4432ba2c576c235fc1b82759d3cc71d31aa0ee48.zip
Fix error where if '-' is actually used in invoking su(1), we lose all
the environment vars like DISPLAY etc. Bump PORTREVISION. Alan and I still suspect the problem is somewhere else, but this at least gets kdesu working. He feels I should back it out, but I'm going to keep it since it's better than what we had last: a broken kdesu. Submitted by: Alan Eldridge <alane@geeksrus.net>
-rw-r--r--x11/kdelibs2/Makefile4
-rw-r--r--x11/kdelibs2/files/patch-su.cpp2
-rw-r--r--x11/kdelibs3/Makefile4
-rw-r--r--x11/kdelibs4/Makefile4
4 files changed, 7 insertions, 7 deletions
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index 93ee6b9b10f2..ebf462d3e58c 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+=--disable-debug
.endif
.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS}
+CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
.endif
USE_GMAKE= yes
diff --git a/x11/kdelibs2/files/patch-su.cpp b/x11/kdelibs2/files/patch-su.cpp
index bc5440cb692d..1993ba8dd6b2 100644
--- a/x11/kdelibs2/files/patch-su.cpp
+++ b/x11/kdelibs2/files/patch-su.cpp
@@ -4,7 +4,7 @@
setTerminal(true);
QCStringList args;
-+ args+="-";
++ args+="-m";
if ((m_Scheduler != SchedNormal) || (m_Priority > 50))
args += "root";
else
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 93ee6b9b10f2..ebf462d3e58c 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+=--disable-debug
.endif
.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS}
+CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
.endif
USE_GMAKE= yes
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 93ee6b9b10f2..ebf462d3e58c 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kdelibs
PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+=--disable-debug
.endif
.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS}
+CFLAGS= -O0 ${KDE_CFLAGS} -D__PATH_SU=/usr/bin/su
.endif
USE_GMAKE= yes